Bug 106279 - Please include openssh/watchdog patch
Please include openssh/watchdog patch
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-04 15:06 EDT by Stig Hackvan
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-07 09:19:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stig Hackvan 2003-10-04 15:06:52 EDT
Description of problem:

ssh connections die when left idle over a NAT router (timeout varies but is
seldomly configurable for appliance-class devices)


Additional info:

Please include in the redhat release the "watchdog/heartbeat" patches for openssh...

http://www.sc.isc.tohoku.ac.jp/~hgot/sources/openssh-watchdog.html

these allow the automatic transmission of occasional SSH protocol NOP packets
which keep the connection alive and prevent NAT timeouts and dropped connections.

-- stig
Comment 1 Stig Hackvan 2004-11-13 15:08:30 EST
hey nalin, can you bump this issue up a notch?  being able to preserve
connections over NAT (DSL routers, for example) boundaries is really
important these days.  every time i update redhat/fedora i have to
re-do these patches and fork my own rpms.

most people probably just suffer repeatedly dropped connections (with
screen, perhaps, on the far side so moderate the pain)...  all the
windows SSH clients i've seen can keep the connection alive, so why
can't the main branch?
Comment 2 Sitsofe Wheeler 2004-11-14 04:32:14 EST
It seems terribly broken that ssh connections would be dropped just
like that because they are idle. That seems like some broken/overly
aggressive firewalling.. 

On another note, aren't there a server side sshd_config options to
this (e.g. TCPKeepAlive or ClientAliveInterval spring to mind). Why
can't you get your server to set those?
Comment 3 Tomas Mraz 2005-02-07 09:19:05 EST
This is implemented in the current openssh-3.9p1 in FC3.

ServerAliveInterval, TCPKeepAlive are your friends.

See man ssh_config.

Note You need to log in before you can comment on or make changes to this bug.