Bug 1062833 - WARNING at lib/dma-debug.c:491 add_dma_entry
Summary: WARNING at lib/dma-debug.c:491 add_dma_entry
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stanislaw Gruszka
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:8e8031947e2ab80372cda33360d...
: 1061465 1061876 1063059 1063868 1064562 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-08 06:11 UTC by satellitgo
Modified: 2014-04-15 22:32 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-28 11:05:22 UTC


Attachments (Terms of Use)
File: dmesg (71.16 KB, text/plain)
2014-02-08 06:12 UTC, satellitgo
no flags Details
VirtIO disk - virtio-pc - lspci OK (2.52 KB, text/plain)
2014-02-14 07:56 UTC, poma
no flags Details
VirtIO disk - virtio-pc - dmesg OK (37.74 KB, text/plain)
2014-02-14 07:57 UTC, poma
no flags Details
IDE disk - ata_piix - lspci (2.38 KB, text/plain)
2014-02-14 08:00 UTC, poma
no flags Details
IDE disk - ata_piix - dmesg (40.09 KB, text/plain)
2014-02-14 08:02 UTC, poma
no flags Details
SATA disk - ahci - lspci (2.61 KB, text/plain)
2014-02-14 08:04 UTC, poma
no flags Details
SATA disk - ahci - dmesg (42.50 KB, text/plain)
2014-02-14 08:05 UTC, poma
no flags Details
SCSI disk - sym53c8xx - lspci (2.48 KB, text/plain)
2014-02-14 08:07 UTC, poma
no flags Details
SCSI disk - sym53c8xx - dmesg (68.93 KB, text/plain)
2014-02-14 08:09 UTC, poma
no flags Details
VirtIO SCSI disk - 'virtio-scsi' & sym53c8xx - lspci (2.48 KB, text/plain)
2014-02-14 08:11 UTC, poma
no flags Details
VirtIO SCSI disk - 'virtio-scsi' & sym53c8xx - dmesg (68.64 KB, text/plain)
2014-02-14 08:13 UTC, poma
no flags Details
USB disk - usb-storage - lspci (2.39 KB, text/plain)
2014-02-14 08:15 UTC, poma
no flags Details
USB disk - usb-storage - lsusb (474 bytes, text/plain)
2014-02-14 08:16 UTC, poma
no flags Details
USB disk - usb-storage - lsusb -t (559 bytes, text/plain)
2014-02-14 08:17 UTC, poma
no flags Details
USB disk - usb-storage - dmesg (41.27 KB, text/plain)
2014-02-14 08:19 UTC, poma
no flags Details
IDE disk - ata_piix - dmesg - OK (36.81 KB, text/plain)
2014-02-17 13:27 UTC, poma
no flags Details
SATA disk - ahci - dmesg - OK (38.19 KB, text/plain)
2014-02-17 13:28 UTC, poma
no flags Details
SCSI disk - sym53c8xx - dmesg - OK (38.74 KB, text/plain)
2014-02-17 13:29 UTC, poma
no flags Details
VirtIO SCSI disk - virtio_scsi - dmesg - OK (37.12 KB, text/plain)
2014-02-17 13:30 UTC, poma
no flags Details
USB disk - usb_storage - dmesg - OK (37.32 KB, text/plain)
2014-02-17 13:32 UTC, poma
no flags Details

Description satellitgo 2014-02-08 06:11:56 UTC
Additional info:
reporter:       libreport-2.1.12
WARNING: CPU: 7 PID: 626 at lib/dma-debug.c:491 add_dma_entry+0x127/0x130()
DMA-API: exceeded 7 overlapping mappings of pfn 1fa328
Modules linked in: bnep bluetooth 6lowpan_iphc fuse ip6t_rpfilter ip6t_REJECT xt_conntrack ebtable_nat ebtable_broute bridge stp llc ebtable_filter ebtables ip6table_nat nf_conntrack_ipv6 nf_defrag_ipv6 nf_nat_ipv6 ip6table_mangle ip6table_security ip6table_raw ip6table_filter ip6_tables iptable_nat nf_conntrack_ipv4 nf_defrag_ipv4 nf_nat_ipv4 nf_nat nf_conntrack iptable_mangle iptable_security iptable_raw x86_pkg_temp_thermal coretemp kvm_intel kvm uvcvideo videobuf2_vmalloc rtsx_pci_sdmmc videobuf2_memops rtsx_pci_ms iTCO_wdt videobuf2_core mmc_core videodev memstick iTCO_vendor_support media mei_me rtsx_pci arc4 iwldvm joydev mac80211 mei iwlwifi cfg80211 rfkill snd_hda_codec_hdmi shpchp serio_raw snd_hda_codec_via snd_hda_codec_generic snd_hda_intel lpc_ich mfd_core snd_hda_codec snd_hwdep i2c_i801 snd_seq snd_seq_device snd_pcm snd_timer snd soundcore tpm_tis wmi crct10dif_pclmul crc32_pclmul crc32c_intel tpm_infineon tpm ghash_clmulni_intel microcode i915 i2c_algo_bit r8169 drm_kms_helper mii drm i2c_core video usb_storage
CPU: 7 PID: 626 Comm: irq/45-iwlwifi Not tainted 3.14.0-0.rc1.git2.1.fc21.x86_64 #1
Hardware name: System76, Inc. Gazelle Professional/Gazelle Professional, BIOS 4.6.5 09/27/2012
 0000000000000000 0000000008344b04 ffff8800d4b9ef48 ffffffff817ced9d
 ffff8800d4b9ef90 ffff8800d4b9ef80 ffffffff810967cd 00000000001fa328
 ffff88020ff03300 0000000000000292 ffffffff82d6c240 0000000000000292
Call Trace:
 [<ffffffff817ced9d>] dump_stack+0x4d/0x66
 [<ffffffff810967cd>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8109684c>] warn_slowpath_fmt+0x5c/0x80
 [<ffffffff813f363d>] ? active_pfn_read_overlap+0x2d/0x50
 [<ffffffff813f3c07>] add_dma_entry+0x127/0x130
 [<ffffffff813f3f6a>] debug_dma_map_page+0x11a/0x140
 [<ffffffffa0391fe3>] iwl_trans_pcie_tx+0x233/0xad0 [iwlwifi]
 [<ffffffffa048b21d>] iwlagn_tx_skb+0x60d/0xc90 [iwldvm]
 [<ffffffffa0488442>] iwlagn_mac_tx+0x22/0x40 [iwldvm]
 [<ffffffffa03ee4e9>] __ieee80211_tx+0x2f9/0x430 [mac80211]
 [<ffffffffa03f0548>] ieee80211_tx+0xf8/0x130 [mac80211]
 [<ffffffffa03f1161>] ieee80211_xmit+0xa1/0x100 [mac80211]
 [<ffffffffa03f21ec>] ieee80211_subif_start_xmit+0x9fc/0x14f0 [mac80211]
 [<ffffffffa03f1841>] ? ieee80211_subif_start_xmit+0x51/0x14f0 [mac80211]
 [<ffffffff81685b80>] ? dev_queue_xmit_nit+0x180/0x3f0
 [<ffffffff81689e26>] dev_hard_start_xmit+0x2e6/0x8d0
 [<ffffffff816b131e>] sch_direct_xmit+0xee/0x290
 [<ffffffff8168a69d>] __dev_queue_xmit+0x28d/0x9b0
 [<ffffffff8168a415>] ? __dev_queue_xmit+0x5/0x9b0
 [<ffffffff8168add0>] dev_queue_xmit+0x10/0x20
 [<ffffffff816d4c30>] ip_finish_output+0x6a0/0x950
 [<ffffffff816d66ac>] ? ip_output+0x5c/0x100
 [<ffffffff816d66ac>] ip_output+0x5c/0x100
 [<ffffffff816d5a49>] ip_local_out+0x29/0x90
 [<ffffffff816d5f19>] ip_queue_xmit+0x1e9/0x650
 [<ffffffff816d5d35>] ? ip_queue_xmit+0x5/0x650
 [<ffffffff816ef267>] tcp_transmit_skb+0x477/0xac0
 [<ffffffff816f2451>] tcp_send_ack+0xd1/0x120
 [<ffffffff816e473e>] __tcp_ack_snd_check+0x5e/0xa0
 [<ffffffff816eb921>] tcp_rcv_established+0x231/0x680
 [<ffffffff816f6d75>] tcp_v4_do_rcv+0x1b5/0x4f0
 [<ffffffff816f974e>] tcp_v4_rcv+0xa9e/0xb90
 [<ffffffff810f5497>] ? __lock_is_held+0x57/0x80
 [<ffffffff816cf03f>] ip_local_deliver_finish+0x13f/0x460
 [<ffffffff816cef43>] ? ip_local_deliver_finish+0x43/0x460
 [<ffffffff816cf5f8>] ip_local_deliver+0x48/0x80
 [<ffffffff816ce950>] ip_rcv_finish+0x160/0x710
 [<ffffffff816cf8c4>] ip_rcv+0x294/0x3d0
 [<ffffffff81686812>] __netif_receive_skb_core+0xa22/0xdf0
 [<ffffffff81685f4b>] ? __netif_receive_skb_core+0x15b/0xdf0
 [<ffffffff81686bf8>] __netif_receive_skb+0x18/0x60
 [<ffffffff81687e10>] netif_receive_skb_internal+0x40/0x220
 [<ffffffff8168800c>] netif_receive_skb+0x1c/0x110
 [<ffffffffa03e7ae8>] ieee80211_deliver_skb.isra.29+0x98/0x210 [mac80211]
 [<ffffffffa03e950d>] ieee80211_rx_handlers+0xf5d/0x27a0 [mac80211]
 [<ffffffff810f9187>] ? __lock_acquire+0x347/0x1c40
 [<ffffffff810f5497>] ? __lock_is_held+0x57/0x80
 [<ffffffffa03eb1ef>] ieee80211_prepare_and_rx_handle+0x49f/0xba0 [mac80211]
 [<ffffffff810f5497>] ? __lock_is_held+0x57/0x80
 [<ffffffffa03ebe1e>] ieee80211_rx+0x52e/0xd10 [mac80211]
 [<ffffffffa03eb9f7>] ? ieee80211_rx+0x107/0xd10 [mac80211]
 [<ffffffffa0496229>] iwlagn_rx_reply_rx+0x3f9/0x720 [iwldvm]
 [<ffffffffa049783e>] iwl_rx_dispatch+0x8e/0xf0 [iwldvm]
 [<ffffffffa038b93b>] iwl_pcie_irq_handler+0x149b/0x27c0 [iwlwifi]
 [<ffffffff8110edd0>] ? irq_finalize_oneshot.part.28+0xd0/0xd0
 [<ffffffff8110edf0>] irq_thread_fn+0x20/0x50
 [<ffffffff8110f2ab>] irq_thread+0x13b/0x170
 [<ffffffff8110eed0>] ? wake_threads_waitq+0x50/0x50
 [<ffffffff8110f170>] ? irq_thread_check_affinity+0xe0/0xe0
 [<ffffffff810c43ef>] kthread+0xff/0x120
 [<ffffffff810c42f0>] ? insert_kthread_work+0x80/0x80
 [<ffffffff817e2b3c>] ret_from_fork+0x7c/0xb0
 [<ffffffff810c42f0>] ? insert_kthread_work+0x80/0x80

Comment 1 satellitgo 2014-02-08 06:12:03 UTC
Created attachment 860826 [details]
File: dmesg

Comment 2 Igor Gnatenko 2014-02-09 09:24:08 UTC
Getting this

Comment 3 Stanislaw Gruszka 2014-02-13 13:45:25 UTC
This is most likely false positive caused by current lib/dma-debug.c changes. 

There is upstream thread about that:
https://lkml.org/lkml/2014/1/26/49

Comment 4 Stanislaw Gruszka 2014-02-13 13:45:46 UTC
*** Bug 1061465 has been marked as a duplicate of this bug. ***

Comment 5 Stanislaw Gruszka 2014-02-13 13:45:58 UTC
*** Bug 1061876 has been marked as a duplicate of this bug. ***

Comment 6 Stanislaw Gruszka 2014-02-13 13:46:28 UTC
*** Bug 1064562 has been marked as a duplicate of this bug. ***

Comment 7 Stanislaw Gruszka 2014-02-13 13:47:18 UTC
*** Bug 1063868 has been marked as a duplicate of this bug. ***

Comment 8 Stanislaw Gruszka 2014-02-13 13:48:58 UTC
*** Bug 1063059 has been marked as a duplicate of this bug. ***

Comment 9 poma 2014-02-14 07:56:39 UTC
Created attachment 863135 [details]
VirtIO disk - virtio-pc - lspci OK

Comment 10 poma 2014-02-14 07:57:49 UTC
Created attachment 863136 [details]
VirtIO disk - virtio-pc - dmesg OK

Comment 11 poma 2014-02-14 08:00:17 UTC
Created attachment 863137 [details]
IDE disk - ata_piix - lspci

Comment 12 poma 2014-02-14 08:02:14 UTC
Created attachment 863138 [details]
IDE disk - ata_piix - dmesg

"WARNING: CPU: 0 PID: 1328 at lib/dma-debug.c:491 add_dma_entry+0x127/0x130()"
"DMA-API: exceeded 7 overlapping mappings of pfn 2137"

Comment 13 poma 2014-02-14 08:04:18 UTC
Created attachment 863139 [details]
SATA disk - ahci - lspci

Comment 14 poma 2014-02-14 08:05:51 UTC
Created attachment 863140 [details]
SATA disk - ahci - dmesg

"WARNING: CPU: 0 PID: 1543 at lib/dma-debug.c:491 add_dma_entry+0x127/0x130()"
"DMA-API: exceeded 7 overlapping mappings of pfn 2137"

Comment 15 poma 2014-02-14 08:07:49 UTC
Created attachment 863151 [details]
SCSI disk - sym53c8xx - lspci

Comment 16 poma 2014-02-14 08:09:46 UTC
Created attachment 863152 [details]
SCSI disk - sym53c8xx - dmesg

"WARNING: CPU: 1 PID: 1514 at lib/dma-debug.c:491 add_dma_entry+0x127/0x130()"
"DMA-API: exceeded 7 overlapping mappings of pfn 2137"
~~
"WARNING: CPU: 1 PID: 1514 at lib/dma-debug.c:1041 check_unmap+0x8b7/0x9b0()"
"sym53c8xx 0000:00:07.0: DMA-API: device driver tries to free DMA memory it has not allocated [device address=0x0000000002137000] [size=512 bytes]"

Comment 17 poma 2014-02-14 08:11:30 UTC
Created attachment 863153 [details]
VirtIO SCSI disk - 'virtio-scsi' & sym53c8xx - lspci

Comment 18 poma 2014-02-14 08:13:13 UTC
Created attachment 863154 [details]
VirtIO SCSI disk - 'virtio-scsi' & sym53c8xx - dmesg

"WARNING: CPU: 0 PID: 1530 at lib/dma-debug.c:491 add_dma_entry+0x127/0x130()"
"DMA-API: exceeded 7 overlapping mappings of pfn 2137"
~~
"WARNING: CPU: 0 PID: 1530 at lib/dma-debug.c:1041 check_unmap+0x8b7/0x9b0()"
"sym53c8xx 0000:00:07.0: DMA-API: device driver tries to free DMA memory it has not allocated [device address=0x0000000002137000] [size=512 bytes]"

Comment 19 poma 2014-02-14 08:15:34 UTC
Created attachment 863156 [details]
USB disk - usb-storage - lspci

Comment 20 poma 2014-02-14 08:16:37 UTC
Created attachment 863157 [details]
USB disk - usb-storage - lsusb

Comment 21 poma 2014-02-14 08:17:31 UTC
Created attachment 863158 [details]
USB disk - usb-storage - lsusb -t

Comment 22 poma 2014-02-14 08:19:02 UTC
Created attachment 863159 [details]
USB disk - usb-storage - dmesg

"WARNING: CPU: 0 PID: 415 at lib/dma-debug.c:491 add_dma_entry+0x127/0x130()"
"DMA-API: exceeded 7 overlapping mappings of pfn 2137"

Comment 23 Peter Trenholme 2014-02-15 18:54:34 UTC
Description of problem:
During boot

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.12
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.14.0-0.rc0.git9.1.fc21.x86_64 root=UUID=207d8262-a705-4237-8cc6-f527fb3e34cc ro quiet
kernel:         3.14.0-0.rc0.git9.1.fc21.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: CPU: 3 PID: 2384 at lib/dma-debug.c:491 add_dma_entry+0x11a/0x130()
DMA-API: exceeded 7 overlapping mappings of pfn 2133
Modules linked in: bnep bluetooth ccm vfat fat ipt_MASQUERADE iptable_nat nf_nat_ipv4 nf_nat xt_CHECKSUM iptable_mangle tun bridge stp llc isofs loop md4 ebtable_nat ebtables fuse nls_utf8 cifs dns_resolver fscache ip6t_REJECT nf_conntrack_netbios_ns nf_conntrack_broadcast nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 ip6table_filter xt_conntrack ip6_tables nf_conntrack it87 hwmon_vid joydev kvm_amd kvm hid_gyration btrfs raid6_pq libcrc32c xor microcode serio_raw edac_core snd_hda_codec_realtek k10temp edac_mce_amd snd_hda_codec_generic sp5100_tco snd_hda_codec_hdmi arc4 i2c_piix4 rt2800pci rt2800mmio rt2800lib snd_hda_intel snd_hda_codec rt2x00pci snd_hwdep rt2x00mmio rt2x00lib snd_seq snd_seq_device eeprom_93cx6 snd_pcm mac80211 cfg80211 crc_ccitt rfkill snd_timer
 snd soundcore wmi shpchp acpi_cpufreq binfmt_misc nfsd auth_rpcgss nfs_acl lockd sunrpc raid1 radeon usb_storage i2c_algo_bit drm_kms_helper ttm drm r8169 i2c_core mii
CPU: 3 PID: 2384 Comm: dconf-service Not tainted 3.14.0-0.rc0.git9.1.fc21.x86_64 #1
Hardware name: Hewlett-Packard p6710f/2AB1 , BIOS 6.07 05/04/2011
 0000000000000009 ffff8800a5d81628 ffffffff81793c95 ffff8800a5d81670
 ffff8800a5d81660 ffffffff8109272d 0000000000002133 ffff8800bd477cf0
 0000000000000086 ffffffff82d60480 0000000000000086 ffff8800a5d816c0
Call Trace:
 [<ffffffff81793c95>] dump_stack+0x4d/0x66
 [<ffffffff8109272d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8109279c>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff813d708d>] ? active_pfn_read_overlap+0x2d/0x50
 [<ffffffff813d762a>] add_dma_entry+0x11a/0x130
 [<ffffffff813d7ced>] debug_dma_map_sg+0x13d/0x180
 [<ffffffff81517281>] ata_qc_issue+0x281/0x3e0
 [<ffffffff815201a5>] ata_scsi_queuecmd+0x135/0x420
 [<ffffffff8151d090>] ? ata_scsi_invalid_field+0x40/0x40
 [<ffffffff814f46a7>] scsi_dispatch_cmd+0xb7/0x4e0
 [<ffffffff814fc91c>] scsi_request_fn+0x33c/0x540
 [<ffffffff8137c773>] __blk_run_queue+0x33/0x40
 [<ffffffff8137fe8e>] queue_unplugged+0x2e/0x160
 [<ffffffff81381fd8>] blk_flush_plug_list+0x1d8/0x240
 [<ffffffff81798171>] io_schedule_timeout+0x81/0xf0
 [<ffffffff810f1c4d>] ? trace_hardirqs_on+0xd/0x10
 [<ffffffff817985f4>] wait_for_completion_io+0xd4/0x110
 [<ffffffff810d2f00>] ? wake_up_state+0x20/0x20
 [<ffffffff813891a5>] __blkdev_issue_zeroout+0x215/0x250
 [<ffffffff8179855b>] ? wait_for_completion_io+0x3b/0x110
 [<ffffffff813892a1>] blkdev_issue_zeroout+0xc1/0xd0
 [<ffffffff812e820d>] ? ext4_ext_find_extent+0x23d/0x2d0
 [<ffffffff812e704c>] ext4_ext_zeroout.isra.37+0x4c/0x60
 [<ffffffff812ebad5>] ext4_ext_handle_uninitialized_extents+0x5d5/0xf20
 [<ffffffff812e820d>] ? ext4_ext_find_extent+0x23d/0x2d0
 [<ffffffff812ecbcd>] ext4_ext_map_blocks+0x77d/0x11b0
 [<ffffffff81023119>] ? sched_clock+0x9/0x10
 [<ffffffff812bd01d>] ext4_map_blocks+0x2dd/0x530
 [<ffffffff812c0253>] ? ext4_writepages+0x4b3/0x1020
 [<ffffffff812c04b9>] ext4_writepages+0x719/0x1020
 [<ffffffff811b1221>] do_writepages+0x21/0x50
 [<ffffffff811a46c9>] __filemap_fdatawrite_range+0x59/0x60
 [<ffffffff811a47cd>] filemap_write_and_wait_range+0x2d/0x70
 [<ffffffff812b6b2a>] ext4_sync_file+0xba/0x4d0
 [<ffffffff8125a121>] do_fsync+0x51/0x80
 [<ffffffff8125a410>] SyS_fsync+0x10/0x20
 [<ffffffff817a6f29>] system_call_fastpath+0x16/0x1b

Comment 24 poma 2014-02-17 13:24:48 UTC
Test media - 'boot-fix-dma-debug-overlap-v2.iso',
http://goo.gl/UJSfVn
sha256sum:
6d6b36fdcb0a0ff662ff6a27048d6d5f35ac211c34439f75bba1d524b3507e82  boot-fix-dma-debug-overlap-v2.iso

Contains 'kernel-3.14.0-0.rc2.git4.1.fc21.x86_64' 
based on Rawhide 'kernel-3.14.0-0.rc2.git4.1.fc21'  
http://koji.fedoraproject.org/koji/buildinfo?buildID=498404
with the addition of Dan's 'fix-dma-debug-overlap-v2.patch'  
"Fix dma debug v2: account for cachelines and read-only mappings in overlap tracking" 
http://marc.info/?l=linux-netdev&m=139233546723342&q=raw

All tests are PASSED.

Comment 25 poma 2014-02-17 13:27:24 UTC
Created attachment 864085 [details]
IDE disk - ata_piix - dmesg - OK

Comment 26 poma 2014-02-17 13:28:42 UTC
Created attachment 864086 [details]
SATA disk - ahci - dmesg - OK

Comment 27 poma 2014-02-17 13:29:51 UTC
Created attachment 864087 [details]
SCSI disk - sym53c8xx - dmesg - OK

Comment 28 poma 2014-02-17 13:30:53 UTC
Created attachment 864088 [details]
VirtIO SCSI disk - virtio_scsi - dmesg - OK

Comment 29 poma 2014-02-17 13:32:18 UTC
Created attachment 864089 [details]
USB disk - usb_storage - dmesg - OK

Comment 30 Stanislaw Gruszka 2014-02-17 14:49:56 UTC
Josh, please apply below patch as fix for this bug (appropriate to rawhide only):

http://marc.info/?l=linux-kernel&m=139233546223338&w=2

Comment 31 Josh Boyer 2014-02-17 21:00:20 UTC
I'll grab this first thing tomorrow morning.  Thanks.

Comment 32 satellitgo 2014-02-18 00:54:54 UTC
f21 (rawhide) Mate X86_64 KOJ 20140216 LIVE cd install to HD-Occurs on boot installed system

Comment 33 satellitgo 2014-02-18 00:57:08 UTC
(In reply to satellit from comment #32)
> f21 (rawhide) Mate X86_64 KOJ 20140216 LIVE cd install to HD-Occurs on boot
> installed system

BZ finds https://bugzilla.redhat.com/show_bug.cgi?id=1061465  (Duplicate)

Comment 34 Josh Boyer 2014-02-18 13:36:53 UTC
Patch applied in git.  Thanks.


Note You need to log in before you can comment on or make changes to this bug.