Bug 106284 - redhat-config-printer-tui does not even start
Summary: redhat-config-printer-tui does not even start
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-printer   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-04 21:18 UTC by Gerald Teschl
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version: 0.6.77-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 10:48:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of printconf-tui --Xexport (5.58 KB, text/plain)
2003-10-06 15:55 UTC, Gerald Teschl
no flags Details

Description Gerald Teschl 2003-10-04 21:18:31 UTC
[root@soliton root]# redhat-config-printer-tui
Initializing alchemist edit environment ...
Initializing linux printing database ...
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-printer-tui", line 8, in ?
    printconf_tui.startup_and_find_cmd()
  File "/usr/share/printconf/util/printconf_tui.py", line 2345, in
startup_and_find_cmd
    main.cmd_handlers[cmd]()
  File "/usr/share/printconf/util/printconf_tui.py", line 1989, in tui_main_run
    qld_run()
  File "/usr/share/printconf/util/printconf_tui.py", line 1844, in qld_run
    qld_build()
  File "/usr/share/printconf/util/printconf_tui.py", line 1950, in qld_build
    qld.queue_list_box.append(
  File "/usr/share/printconf/util/printconf_conf.py", line 992, in queue_details
    details = "ipp://%s:%d%s" % (q_data['ipp_server'],
TypeError: an integer is required





Version-Release number of selected component (if applicable):
redhat-config-printer-0.6.75-1

Comment 1 Tim Waugh 2003-10-06 13:06:20 UTC
Please provide the output of 'printconf-tui --Xexport'.  Thanks.

Comment 2 Gerald Teschl 2003-10-06 15:54:01 UTC
It's quite strange, now it starts up (and I don't remember changing anything).
However, all the borders are "a's with hats on them' and it just quits
after drawing the printer lists and the buttons.

Comment 3 Gerald Teschl 2003-10-06 15:55:10 UTC
Created attachment 94949 [details]
output of printconf-tui --Xexport

Comment 4 Tim Waugh 2003-10-07 11:33:34 UTC
I think your IPP queue must have been deleted.  Anyway, I have fixed the cause
of the traceback in CVS.


Note You need to log in before you can comment on or make changes to this bug.