Bug 1062847 - dnf man page errors
Summary: dnf man page errors
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 20
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-08 08:40 UTC by Andre Robatino
Modified: 2014-02-17 21:03 UTC (History)
4 users (show)

Fixed In Version: dnf-0.4.14-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-17 21:03:11 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andre Robatino 2014-02-08 08:40:32 UTC
Description of problem:
The beginning of the dnf man page lists "dist-sync" and "distribution-sync" as available commands. However, it appears that the correct names are "distro-sync" and "distribution-synchronization" (like yum).

I left the Summary deliberately vague in case someone else spots other errors and wants to add them to this bug.

Version-Release number of selected component (if applicable):
dnf-0.4.13-2.fc20.noarch (currently updates-testing, same issue spotted in Rawhide)

Comment 1 Ales Kozumplik 2014-02-10 08:18:44 UTC
Fixed by 1f30821 upstream, thanks for the report.

Comment 2 Fedora Update System 2014-02-13 08:26:02 UTC
dnf-0.4.14-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.14-1.fc20

Comment 3 Fedora Update System 2014-02-14 07:57:05 UTC
Package dnf-0.4.14-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.14-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2471/dnf-0.4.14-1.fc20
then log in and leave karma (feedback).

Comment 4 Andre Robatino 2014-02-14 11:53:31 UTC
Verified fixed in dnf-0.4.14-1.fc20. I noticed that down the page, it says that distribution-synchronization is a deprecated alias for distro-sync (reasonable since the former is way too long). But bash-completion completes "dnf di[TAB]" to "dnf distribution-synchronization", and won't complete "dnf distro[TAB]" at all. Should that be considered a bug (in bash-completion)?

Comment 5 Ales Kozumplik 2014-02-17 06:32:20 UTC
Yes, open a bz for that please.

Comment 6 Andre Robatino 2014-02-17 12:06:22 UTC
https://bugzilla.redhat.com/show_bug.cgi?id=1065959

Comment 7 Fedora Update System 2014-02-17 21:03:11 UTC
dnf-0.4.14-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.