Bug 106286 - CONFIG_ZLIB_INFLATE /DEFLATE broke
CONFIG_ZLIB_INFLATE /DEFLATE broke
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-04 18:05 EDT by raxet
Modified: 2015-01-04 17:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-16 19:27:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description raxet 2003-10-04 18:05:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030918

Description of problem:
1. Doing custom kernel build using make xconfig generates on save:

ERROR - Attempting to write value for unconfigured variable (CONFIG_ZLIB_INFLATE).
ERROR - Attempting to write value for unconfigured variable (CONFIG_ZLIB_DEFLATE).

2. After make dep, make clean, then make bzImage generates the following:

kallsyms pass 1
ld -m elf_i386 -T /usr/src/linux-2.4.22-1.2086.nptl/arch/i386/vmlinux.lds -e
stext arch/i386/kernel/head.o arch/i386/kernel/init_task.o init/main.o
init/version.o init/do_mounts.o --start-group arch/i386/kernel/kernel.o
arch/i386/mm/mm.o kernel/kernel.o mm/mm.o fs/fs.o ipc/ipc.o  drivers/acpi/acpi.o
drivers/cpufreq/cpufreq.o drivers/char/char.o drivers/block/block.o
drivers/misc/misc.o drivers/net/net.o drivers/char/drm/drm.o drivers/net/fc/fc.o
drivers/net/appletalk/appletalk.o drivers/net/tokenring/tr.o
drivers/net/wan/wan.o drivers/atm/atm.o drivers/ide/idedriver.o
drivers/cdrom/driver.o drivers/pci/driver.o drivers/net/pcmcia/pcmcia_net.o
drivers/net/wireless/wireless_net.o drivers/pnp/pnp.o drivers/video/video.o
drivers/media/media.o drivers/md/mddev.o drivers/isdn/vmlinux-obj.o
crypto/crypto.o drivers/sensors/sensor.o net/network.o
/usr/src/linux-2.4.22-1.2086.nptl/arch/i386/lib/lib.a
/usr/src/linux-2.4.22-1.2086.nptl/lib/lib.a
/usr/src/linux-2.4.22-1.2086.nptl/arch/i386/lib/lib.a --end-group -o .tmp_vmlinux1
fs/fs.o(.text+0x30ad5): In function `isofs_put_super':
: undefined reference to `unload_nls'
fs/fs.o(.text+0x3196f): In function `isofs_read_super':
: undefined reference to `load_nls'
fs/fs.o(.text+0x31991): In function `isofs_read_super':
: undefined reference to `load_nls_default'
fs/fs.o(.text+0x31b81): In function `isofs_read_super':
: undefined reference to `unload_nls'
fs/fs.o(.text+0x341ea): In function `wcsntombs_be':
: undefined reference to `utf8_wctomb'
fs/fs.o(.text+0x347cc): In function `zisofs_readpage':
: undefined reference to `zlib_inflateInit_'
fs/fs.o(.text+0x34881): In function `zisofs_readpage':
: undefined reference to `zlib_inflate'
fs/fs.o(.text+0x3492f): In function `zisofs_readpage':
: undefined reference to `zlib_inflateEnd'
fs/fs.o(.text.init+0xeeb): In function `zisofs_init':
: undefined reference to `zlib_inflate_workspacesize'
make[1]: *** [kallsyms] Error 1
make[1]: Leaving directory `/usr/src/linux-2.4.22-1.2086.nptl'
make: *** [vmlinux] Error 2

No work around.

Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2086.nptl

How reproducible:
Always

Steps to Reproduce:
1. Use make xconfig, selected no changes
2. Save - error #1
3. Do make dep, make clean, then after make bzImage
4. Error #2 above
    

Actual Results:  make bzImage failed

Expected Results:  bzImage created

Additional info:
Comment 1 raxet 2003-10-05 16:31:11 EDT
This is apparently only a function of make xconfig. Make menuconfig resolves the
problem.
Comment 2 Dave Jones 2003-10-21 21:31:53 EDT
Cant reproduce locally with current sources. Fixed ?

Note You need to log in before you can comment on or make changes to this bug.