Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: WildFly fails on boot with: ========================================================================= JBoss Bootstrap Environment JBOSS_HOME: /usr/share/wildfly JAVA: java JAVA_OPTS: -server -XX:+UseCompressedOops -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true ========================================================================= 10:16:11,912 INFO [org.jboss.modules] (main) JBoss Modules version 1.3.0.Beta3 10:16:12,131 INFO [org.jboss.msc] (main) JBoss MSC version 1.2.0.Beta1 10:16:12,206 INFO [org.jboss.as] (MSC service thread 1-7) JBAS015899: WildFly 8.0.0.CR1 "WildFly" starting 10:16:12,670 ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:112) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.server.ServerService.boot(ServerService.java:331) [wildfly-server-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:256) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51] Caused by: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load module org.jboss.as.ejb3 at org.jboss.as.controller.parsing.ExtensionXml.parseExtensions(ExtensionXml.java:155) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_4(StandaloneXml.java:434) [wildfly-server-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:145) [wildfly-server-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:107) [wildfly-server-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper.jar:1.1.0.Final] at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper.jar:1.1.0.Final] at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:104) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] ... 3 more Caused by: java.util.concurrent.ExecutionException: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load module at java.util.concurrent.FutureTask.report(FutureTask.java:122) [rt.jar:1.7.0_51] at java.util.concurrent.FutureTask.get(FutureTask.java:188) [rt.jar:1.7.0_51] at org.jboss.as.controller.parsing.ExtensionXml.parseExtensions(ExtensionXml.java:147) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] ... 9 more Caused by: javax.xml.stream.XMLStreamException: JBAS014674: Failed to load module at org.jboss.as.controller.parsing.ExtensionXml.loadModule(ExtensionXml.java:196) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.parsing.ExtensionXml.access$000(ExtensionXml.java:69) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java:127) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.parsing.ExtensionXml$1.call(ExtensionXml.java:124) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at java.util.concurrent.FutureTask.run(FutureTask.java:262) [rt.jar:1.7.0_51] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_51] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_51] at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51] at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads.jar:2.1.0.Final] Caused by: org.jboss.modules.ModuleLoadException: Error loading module from /usr/share/wildfly/modules/system/layers/base/org/wildfly/clustering/ejb/spi/main/module.xml at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:155) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:132) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.LocalModuleFinder$1.run(LocalModuleFinder.java:154) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.LocalModuleFinder$1.run(LocalModuleFinder.java:148) [jboss-modules.jar:1.3.0.Beta3] at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.7.0_51] at org.jboss.modules.LocalModuleFinder.findModule(LocalModuleFinder.java:148) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleLoader.findModule(ModuleLoader.java:455) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:358) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:305) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.addPaths(Module.java:1016) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.link(Module.java:1386) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.relinkIfNecessary(Module.java:1414) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleLoader.loadModule(ModuleLoader.java:242) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.as.controller.parsing.ExtensionXml.loadModule(ExtensionXml.java:178) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] ... 8 more Caused by: org.jboss.modules.xml.XmlPullParserException: Failed to add resource root 'wildfly-clustering-ejb-spi-8.0.0.CR1.jar' at path 'wildfly-clustering-ejb-spi-8.0.0.CR1.jar' (position: END_TAG seen ... <resource-root path="wildfly-clustering-ejb-spi-8.0.0.CR1.jar"/>... @31:73) caused by: java.io.FileNotFoundException: /usr/share/wildfly/modules/system/layers/base/org/wildfly/clustering/ejb/spi/main/wildfly-clustering-ejb-spi-8.0.0.CR1.jar (No such file or directory) at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:721) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:570) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:392) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:219) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:153) [jboss-modules.jar:1.3.0.Beta3] ... 21 more 10:16:12,681 FATAL [org.jboss.as.server] (Controller Boot Thread) JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details. Version-Release number of selected component (if applicable): wildfly-8.0.0-0.16.CR1.fc20.noarch
wildfly-8.0.0-0.17.CR1.fc20 has been submitted as an update for Fedora 20. https://admin.fedoraproject.org/updates/wildfly-8.0.0-0.17.CR1.fc20
wildfly starts with fixed wildfly-clustering-ejb-spi-8.0.0.CR1.jar but lots of errors and warnings appear on log. ========================================================================= JBoss Bootstrap Environment JBOSS_HOME: /usr/share/wildfly JAVA: java JAVA_OPTS: -server -XX:+UseCompressedOops -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true ========================================================================= 01:42:59,188 INFO [org.jboss.modules] (main) JBoss Modules version 1.3.0.Beta3 01:42:59,391 INFO [org.jboss.msc] (main) JBoss MSC version 1.2.0.Beta1 01:42:59,460 INFO [org.jboss.as] (MSC service thread 1-6) JBAS015899: WildFly 8.0.0.CR1 "WildFly" starting 01:43:00,209 INFO [org.jboss.as.server.deployment.scanner] (DeploymentScanner-threads - 1) JBAS015003: Found TwitForge.war in deployment directory. To trigger deployment create a file called TwitForge.war.dodeploy 01:43:00,223 INFO [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http) 01:43:00,226 INFO [org.xnio] (MSC service thread 1-8) XNIO version 3.2.0.Beta3 01:43:00,233 INFO [org.xnio.nio] (MSC service thread 1-8) XNIO NIO Implementation Version 3.2.0.Beta3 01:43:00,246 INFO [org.jboss.remoting] (MSC service thread 1-8) JBoss Remoting version 4.0.0.Beta1 01:43:00,260 INFO [org.jboss.as.clustering.infinispan] (ServerService Thread Pool -- 33) JBAS010280: Activating Infinispan subsystem. 01:43:00,275 INFO [org.jboss.as.security] (ServerService Thread Pool -- 46) JBAS013171: Activating Security Subsystem 01:43:00,288 INFO [org.jboss.as.naming] (ServerService Thread Pool -- 41) JBAS011800: Activating Naming Subsystem 01:43:00,290 INFO [org.jboss.as.connector.logging] (MSC service thread 1-10) JBAS010408: Starting JCA Subsystem (IronJacamar 1.1.2.Final) 01:43:00,291 INFO [org.jboss.as.webservices] (ServerService Thread Pool -- 50) JBAS015537: Activating WebServices Extension 01:43:00,293 INFO [org.jboss.as.jsf] (ServerService Thread Pool -- 39) JBAS012615: Activated the following JSF Implementations: [main] 01:43:00,303 INFO [org.jboss.as.security] (MSC service thread 1-2) JBAS013170: Current PicketBox version=4.0.18.Final 01:43:00,328 INFO [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 28) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3) 01:43:00,334 INFO [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-5) JBAS010417: Started Driver service with driver-name = h2 01:43:00,351 INFO [org.wildfly.extension.undertow] (MSC service thread 1-10) JBAS017502: Undertow 1.0.0.Beta30 starting 01:43:00,351 INFO [org.wildfly.extension.undertow] (ServerService Thread Pool -- 49) JBAS017502: Undertow 1.0.0.Beta30 starting 01:43:00,358 INFO [org.jboss.as.naming] (MSC service thread 1-16) JBAS011802: Starting Naming Service 01:43:00,359 INFO [org.jboss.as.mail.extension] (MSC service thread 1-16) JBAS015400: Bound mail session [java:jboss/mail/Default] 01:43:00,365 WARN [org.jboss.modules] (ServerService Thread Pool -- 49) Failed to define class org.wildfly.clustering.web.infinispan.session.InfinispanSessionManagerFactoryBuilder in Module "org.wildfly.clustering.web.infinispan:main" from local module loader @22c249c5 (finder: local module finder @1793657 (roots: /usr/share/wildfly/modules,/usr/share/wildfly/modules/system/layers/base)): org.jboss.modules.ModuleLoadError: Error loading module from /usr/share/wildfly/modules/system/layers/base/org/wildfly/clustering/web/api/main/module.xml at org.jboss.modules.ModuleLoadException.toError(ModuleLoadException.java:78) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.getPathsUnchecked(Module.java:1372) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.loadModuleClass(Module.java:543) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:189) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:443) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:431) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:373) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:118) [jboss-modules.jar:1.3.0.Beta3] at java.lang.ClassLoader.defineClass1(Native Method) [rt.jar:1.7.0_51] at java.lang.ClassLoader.defineClass(ClassLoader.java:800) [rt.jar:1.7.0_51] at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:345) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:423) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:261) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:76) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.loadModuleClass(Module.java:548) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:189) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:443) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:431) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:373) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:118) [jboss-modules.jar:1.3.0.Beta3] at java.lang.Class.forName0(Native Method) [rt.jar:1.7.0_51] at java.lang.Class.forName(Class.java:270) [rt.jar:1.7.0_51] at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:363) [rt.jar:1.7.0_51] at java.util.ServiceLoader$1.next(ServiceLoader.java:445) [rt.jar:1.7.0_51] at org.wildfly.clustering.web.session.SessionManagerFactoryBuilderValue.load(SessionManagerFactoryBuilderValue.java:44) at org.wildfly.clustering.web.session.SessionManagerFactoryBuilderValue.<init>(SessionManagerFactoryBuilderValue.java:36) at org.wildfly.clustering.web.undertow.session.SessionManagerAdapterFactoryBuilder.<init>(SessionManagerAdapterFactoryBuilder.java:48) at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) [rt.jar:1.7.0_51] at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57) [rt.jar:1.7.0_51] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) [rt.jar:1.7.0_51] at java.lang.reflect.Constructor.newInstance(Constructor.java:526) [rt.jar:1.7.0_51] at java.lang.Class.newInstance(Class.java:374) [rt.jar:1.7.0_51] at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:373) [rt.jar:1.7.0_51] at java.util.ServiceLoader$1.next(ServiceLoader.java:445) [rt.jar:1.7.0_51] at org.wildfly.extension.undertow.session.DistributableSessionManagerFactoryBuilderValue.load(DistributableSessionManagerFactoryBuilderValue.java:45) at org.wildfly.extension.undertow.session.DistributableSessionManagerFactoryBuilderValue.<init>(DistributableSessionManagerFactoryBuilderValue.java:37) at org.wildfly.extension.undertow.UndertowSubsystemAdd.performBoottime(UndertowSubsystemAdd.java:144) at org.jboss.as.controller.AbstractBoottimeAddStepHandler.performRuntime(AbstractBoottimeAddStepHandler.java:69) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractAddStepHandler$1.execute(AbstractAddStepHandler.java:75) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:591) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:469) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.completeStepInternal(AbstractOperationContext.java:273) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.executeOperation(AbstractOperationContext.java:268) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.ParallelBootOperationStepHandler$ParallelBootTask.run(ParallelBootOperationStepHandler.java:343) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_51] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_51] at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51] at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads.jar:2.1.0.Final] Caused by: org.jboss.modules.xml.XmlPullParserException: Failed to add resource root 'wildfly-clustering-web-api-8.0.0.CR1.jar' at path 'wildfly-clustering-web-api-8.0.0.CR1.jar' (position: END_TAG seen ... <resource-root path="wildfly-clustering-web-api-8.0.0.CR1.jar"/>... @28:73) caused by: java.io.FileNotFoundException: /usr/share/wildfly/modules/system/layers/base/org/wildfly/clustering/web/api/main/wildfly-clustering-web-api-8.0.0.CR1.jar (그런 파일이나 디렉터리가 없습니다) at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:721) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:570) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:392) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:219) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:153) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:132) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.LocalModuleFinder$1.run(LocalModuleFinder.java:154) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.LocalModuleFinder$1.run(LocalModuleFinder.java:148) [jboss-modules.jar:1.3.0.Beta3] at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.7.0_51] at org.jboss.modules.LocalModuleFinder.findModule(LocalModuleFinder.java:148) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleLoader.findModule(ModuleLoader.java:455) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:358) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:305) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.addPaths(Module.java:1016) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.link(Module.java:1386) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.getPaths(Module.java:1347) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.getPathsUnchecked(Module.java:1370) [jboss-modules.jar:1.3.0.Beta3] ... 46 more 01:43:00,391 ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 49) JBAS014612: Operation ("add") failed - address: ([("subsystem" => "undertow")]): java.util.ServiceConfigurationError: org.wildfly.extension.undertow.session.DistributableSessionManagerFactoryBuilder: Provider org.wildfly.clustering.web.undertow.session.SessionManagerAdapterFactoryBuilder could not be instantiated: org.jboss.modules.ModuleLoadError: Error loading module from /usr/share/wildfly/modules/system/layers/base/org/wildfly/clustering/web/api/main/module.xml at java.util.ServiceLoader.fail(ServiceLoader.java:224) [rt.jar:1.7.0_51] at java.util.ServiceLoader.access$100(ServiceLoader.java:181) [rt.jar:1.7.0_51] at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:377) [rt.jar:1.7.0_51] at java.util.ServiceLoader$1.next(ServiceLoader.java:445) [rt.jar:1.7.0_51] at org.wildfly.extension.undertow.session.DistributableSessionManagerFactoryBuilderValue.load(DistributableSessionManagerFactoryBuilderValue.java:45) at org.wildfly.extension.undertow.session.DistributableSessionManagerFactoryBuilderValue.<init>(DistributableSessionManagerFactoryBuilderValue.java:37) at org.wildfly.extension.undertow.UndertowSubsystemAdd.performBoottime(UndertowSubsystemAdd.java:144) at org.jboss.as.controller.AbstractBoottimeAddStepHandler.performRuntime(AbstractBoottimeAddStepHandler.java:69) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractAddStepHandler$1.execute(AbstractAddStepHandler.java:75) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:591) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:469) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.completeStepInternal(AbstractOperationContext.java:273) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.executeOperation(AbstractOperationContext.java:268) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.ParallelBootOperationStepHandler$ParallelBootTask.run(ParallelBootOperationStepHandler.java:343) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_51] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_51] at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51] at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads.jar:2.1.0.Final] Caused by: org.jboss.modules.ModuleLoadError: Error loading module from /usr/share/wildfly/modules/system/layers/base/org/wildfly/clustering/web/api/main/module.xml at org.jboss.modules.ModuleLoadException.toError(ModuleLoadException.java:78) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.getPathsUnchecked(Module.java:1372) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.loadModuleClass(Module.java:543) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:189) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:443) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:431) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:373) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:118) [jboss-modules.jar:1.3.0.Beta3] at java.lang.ClassLoader.defineClass1(Native Method) [rt.jar:1.7.0_51] at java.lang.ClassLoader.defineClass(ClassLoader.java:800) [rt.jar:1.7.0_51] at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:345) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:423) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:261) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:76) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.loadModuleClass(Module.java:548) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:189) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:443) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:431) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:373) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:118) [jboss-modules.jar:1.3.0.Beta3] at java.lang.Class.forName0(Native Method) [rt.jar:1.7.0_51] at java.lang.Class.forName(Class.java:270) [rt.jar:1.7.0_51] at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:363) [rt.jar:1.7.0_51] at java.util.ServiceLoader$1.next(ServiceLoader.java:445) [rt.jar:1.7.0_51] at org.wildfly.clustering.web.session.SessionManagerFactoryBuilderValue.load(SessionManagerFactoryBuilderValue.java:44) at org.wildfly.clustering.web.session.SessionManagerFactoryBuilderValue.<init>(SessionManagerFactoryBuilderValue.java:36) at org.wildfly.clustering.web.undertow.session.SessionManagerAdapterFactoryBuilder.<init>(SessionManagerAdapterFactoryBuilder.java:48) at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) [rt.jar:1.7.0_51] at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57) [rt.jar:1.7.0_51] at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45) [rt.jar:1.7.0_51] at java.lang.reflect.Constructor.newInstance(Constructor.java:526) [rt.jar:1.7.0_51] at java.lang.Class.newInstance(Class.java:374) [rt.jar:1.7.0_51] at java.util.ServiceLoader$LazyIterator.next(ServiceLoader.java:373) [rt.jar:1.7.0_51] ... 15 more Caused by: org.jboss.modules.xml.XmlPullParserException: Failed to add resource root 'wildfly-clustering-web-api-8.0.0.CR1.jar' at path 'wildfly-clustering-web-api-8.0.0.CR1.jar' (position: END_TAG seen ... <resource-root path="wildfly-clustering-web-api-8.0.0.CR1.jar"/>... @28:73) caused by: java.io.FileNotFoundException: /usr/share/wildfly/modules/system/layers/base/org/wildfly/clustering/web/api/main/wildfly-clustering-web-api-8.0.0.CR1.jar (그런 파일이나 디렉터리가 없습니다) at org.jboss.modules.ModuleXmlParser.parseResourceRoot(ModuleXmlParser.java:721) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseResources(ModuleXmlParser.java:570) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseModuleContents(ModuleXmlParser.java:392) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseDocument(ModuleXmlParser.java:219) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:153) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleXmlParser.parseModuleXml(ModuleXmlParser.java:132) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.LocalModuleFinder$1.run(LocalModuleFinder.java:154) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.LocalModuleFinder$1.run(LocalModuleFinder.java:148) [jboss-modules.jar:1.3.0.Beta3] at java.security.AccessController.doPrivileged(Native Method) [rt.jar:1.7.0_51] at org.jboss.modules.LocalModuleFinder.findModule(LocalModuleFinder.java:148) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleLoader.findModule(ModuleLoader.java:455) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleLoader.loadModuleLocal(ModuleLoader.java:358) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.ModuleLoader.preloadModule(ModuleLoader.java:305) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.addPaths(Module.java:1016) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.link(Module.java:1386) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.getPaths(Module.java:1347) [jboss-modules.jar:1.3.0.Beta3] at org.jboss.modules.Module.getPathsUnchecked(Module.java:1370) [jboss-modules.jar:1.3.0.Beta3] ... 46 more 01:43:00,469 WARN [org.jboss.as.webservices] (ServerService Thread Pool -- 50) JBAS015506: Cannot load WS deployment aspects from /META-INF/stack-specific-deployment-aspects.xml 01:43:00,472 ERROR [org.jboss.as.controller.management-operation] (ServerService Thread Pool -- 31) JBAS014612: Operation ("add") failed - address: ([ ("subsystem" => "ejb3"), ("passivation-store" => "infinispan") ]): java.lang.NullPointerException at org.jboss.as.ejb3.cache.distributable.DistributableCacheFactoryBuilderService.<init>(DistributableCacheFactoryBuilderService.java:71) at org.jboss.as.ejb3.cache.distributable.DistributableCacheFactoryBuilderService.<init>(DistributableCacheFactoryBuilderService.java:58) at org.jboss.as.ejb3.subsystem.PassivationStoreAdd.install(PassivationStoreAdd.java:92) at org.jboss.as.ejb3.subsystem.PassivationStoreAdd.performRuntime(PassivationStoreAdd.java:64) at org.jboss.as.controller.AbstractAddStepHandler$1.execute(AbstractAddStepHandler.java:75) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.executeStep(AbstractOperationContext.java:591) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.doCompleteStep(AbstractOperationContext.java:469) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.completeStepInternal(AbstractOperationContext.java:273) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.AbstractOperationContext.executeOperation(AbstractOperationContext.java:268) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at org.jboss.as.controller.ParallelBootOperationStepHandler$ParallelBootTask.run(ParallelBootOperationStepHandler.java:343) [wildfly-controller-8.0.0.CR1.jar:8.0.0.CR1] at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_51] at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_51] at java.lang.Thread.run(Thread.java:744) [rt.jar:1.7.0_51] at org.jboss.threads.JBossThread.run(JBossThread.java:122) [jboss-threads.jar:2.1.0.Final] 01:43:00,729 INFO [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-3) JBAS010400: Bound data source [java:jboss/datasources/ExampleDS] 01:43:00,756 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) "JBAS014784: Failed executing subsystem ejb3 boot operations" 01:43:00,756 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) "JBAS014784: Failed executing subsystem undertow boot operations" 01:43:00,757 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) JBAS014613: Operation ("parallel-subsystem-boot") failed - address: ([]) - failure description: "\"JBAS014784: Failed executing subsystem ejb3 boot operations\"" 01:43:00,784 INFO [org.jboss.as.server.deployment.scanner] (MSC service thread 1-15) JBAS015012: Started FileSystemDeploymentService for directory /usr/share/wildfly/standalone/deployments 01:43:00,794 INFO [org.jboss.as.remoting] (MSC service thread 1-11) JBAS017100: Listening on 127.0.0.1:9999 01:43:00,803 ERROR [org.jboss.as.domain.http.api.undertow] (MSC service thread 1-14) JBAS015102: Unable to load console module for slot main, disabling console 01:43:00,836 ERROR [org.jboss.as.controller.management-operation] (Controller Boot Thread) JBAS014613: Operation ("add") failed - address: ([("subsystem" => "webservices")]) - failure description: {"JBAS014771: Services with missing/unavailable dependencies" => ["jboss.ws.config is missing [jboss.web.common.server]"]} 01:43:00,859 ERROR [org.jboss.as.controller.client] (Controller Boot Thread) JBAS014781: Step handler org.jboss.as.logging.LoggingOperations$CommitOperationStepHandler@3184f81f for operation {"operation" => "add","address" => [("subsystem" => "logging")],"add-logging-api-dependencies" => undefined,"use-deployment-logging-config" => undefined} at address [("subsystem" => "logging")] failed handling operation rollback -- java.lang.RuntimeException: JBAS011565: Failed to write configuration file /usr/share/wildfly/standalone/configuration/logging.properties 01:43:00,862 INFO [org.jboss.as.controller] (Controller Boot Thread) JBAS014774: Service status report JBAS014775: New missing/unsatisfied dependencies: service jboss.web.common.server (missing) dependents: [service jboss.ws.config] 01:43:00,972 INFO [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management 01:43:00,972 INFO [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990 01:43:00,973 ERROR [org.jboss.as] (Controller Boot Thread) JBAS015875: WildFly 8.0.0.CR1 "WildFly" started (with errors) in 2018ms - Started 141 of 186 services (1 services failed or missing dependencies, 60 services are lazy, passive or on-demand)
I cannot reproduce this. See below for logs. I guess you still use the 8.0.0-0.16.CR1 version. Please update to 8.0.0-0.17.CR1 (manually - it's not yet available in updates-testing) and bump the karma to push it to stable. bash-4.2# rpm -q wildfly wildfly-8.0.0-0.17.CR1.fc20.noarch bash-4.2# /usr/share/wildfly/bin/standalone.sh ========================================================================= JBoss Bootstrap Environment JBOSS_HOME: /usr/share/wildfly JAVA: java JAVA_OPTS: -server -XX:+UseCompressedOops -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true ========================================================================= 19:58:34,787 INFO [org.jboss.modules] (main) JBoss Modules version 1.3.0.Beta3 19:58:35,008 INFO [org.jboss.msc] (main) JBoss MSC version 1.2.0.Beta1 19:58:35,074 INFO [org.jboss.as] (MSC service thread 1-6) JBAS015899: WildFly 8.0.0.CR1 "WildFly" starting 19:58:35,933 INFO [org.jboss.as.server] (Controller Boot Thread) JBAS015888: Creating http management service using socket-binding (management-http) 19:58:35,935 INFO [org.xnio] (MSC service thread 1-6) XNIO version 3.2.0.Beta3 19:58:35,940 INFO [org.xnio.nio] (MSC service thread 1-6) XNIO NIO Implementation Version 3.2.0.Beta3 19:58:35,953 INFO [org.jboss.remoting] (MSC service thread 1-6) JBoss Remoting version 4.0.0.Beta1 19:58:35,992 INFO [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool -- 28) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3) 19:58:36,015 INFO [org.jboss.as.clustering.infinispan] (ServerService Thread Pool -- 33) JBAS010280: Activating Infinispan subsystem. 19:58:36,020 INFO [org.jboss.as.naming] (ServerService Thread Pool -- 41) JBAS011800: Activating Naming Subsystem 19:58:36,022 INFO [org.jboss.as.jsf] (ServerService Thread Pool -- 39) JBAS012615: Activated the following JSF Implementations: [main] 19:58:36,024 INFO [org.jboss.as.security] (ServerService Thread Pool -- 46) JBAS013171: Activating Security Subsystem 19:58:36,047 INFO [org.jboss.as.webservices] (ServerService Thread Pool -- 50) JBAS015537: Activating WebServices Extension 19:58:36,052 INFO [org.jboss.as.security] (MSC service thread 1-8) JBAS013170: Current PicketBox version=4.0.18.Final 19:58:36,061 INFO [org.jboss.as.connector.logging] (MSC service thread 1-5) JBAS010408: Starting JCA Subsystem (IronJacamar 1.1.2.Final) 19:58:36,083 INFO [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-4) JBAS010417: Started Driver service with driver-name = h2 19:58:36,126 INFO [org.wildfly.extension.undertow] (MSC service thread 1-4) JBAS017502: Undertow 1.0.0.Beta30 starting 19:58:36,128 INFO [org.wildfly.extension.undertow] (ServerService Thread Pool -- 49) JBAS017502: Undertow 1.0.0.Beta30 starting 19:58:36,129 INFO [org.jboss.as.naming] (MSC service thread 1-5) JBAS011802: Starting Naming Service 19:58:36,132 INFO [org.jboss.as.mail.extension] (MSC service thread 1-3) JBAS015400: Bound mail session [java:jboss/mail/Default] 19:58:36,270 INFO [org.wildfly.extension.undertow] (ServerService Thread Pool -- 49) JBAS017527: Creating file handler for path /usr/share/wildfly/welcome-content 19:58:36,290 INFO [org.wildfly.extension.undertow] (MSC service thread 1-2) JBAS017525: Started server default-server. 19:58:36,294 INFO [org.wildfly.extension.undertow] (MSC service thread 1-2) JBAS017531: Host default-host starting 19:58:36,313 WARN [org.jboss.as.webservices] (ServerService Thread Pool -- 50) JBAS015506: Cannot load WS deployment aspects from /META-INF/stack-specific-deployment-aspects.xml 19:58:36,409 INFO [org.wildfly.extension.undertow] (MSC service thread 1-1) JBAS017519: Undertow HTTP listener default listening on /127.0.0.1:8080 19:58:36,610 INFO [org.jboss.ws.common.management] (MSC service thread 1-4) JBWS022052: Starting JBoss Web Services - Stack CXF Server 4.2.0.Final 19:58:36,743 INFO [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-5) JBAS010400: Bound data source [java:jboss/datasources/ExampleDS] 19:58:36,766 ERROR [org.jboss.as.domain.http.api.undertow] (MSC service thread 1-4) JBAS015102: Unable to load console module for slot main, disabling console 19:58:36,768 INFO [org.jboss.as.remoting] (MSC service thread 1-1) JBAS017100: Listening on 127.0.0.1:9999 19:58:36,768 INFO [org.jboss.as.server.deployment.scanner] (MSC service thread 1-5) JBAS015012: Started FileSystemDeploymentService for directory /usr/share/wildfly/standalone/deployments 19:58:36,958 INFO [org.jboss.as] (Controller Boot Thread) JBAS015961: Http management interface listening on http://127.0.0.1:9990/management 19:58:36,958 INFO [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990 19:58:36,959 INFO [org.jboss.as] (Controller Boot Thread) JBAS015874: WildFly 8.0.0.CR1 "WildFly" started in 2411ms - Started 184 of 232 services (78 services are lazy, passive or on-demand) ^C19:58:39,064 INFO [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-8) JBAS010409: Unbound data source [java:jboss/datasources/ExampleDS] 19:58:39,066 INFO [org.wildfly.extension.undertow] (MSC service thread 1-7) JBAS017532: Host default-host stopping 19:58:39,074 INFO [org.jboss.as.connector.deployers.jdbc] (MSC service thread 1-7) JBAS010418: Stopped Driver service with driver-name = h2 19:58:39,075 INFO [org.wildfly.extension.undertow] (MSC service thread 1-1) JBAS017521: Undertow HTTP listener default suspending 19:58:39,076 INFO [org.wildfly.extension.undertow] (MSC service thread 1-1) JBAS017520: Undertow HTTP listener default stopped, was bound to /127.0.0.1:8080 19:58:39,079 INFO [org.wildfly.extension.undertow] (MSC service thread 1-2) JBAS017506: Undertow 1.0.0.Beta30 stopping 19:58:39,084 INFO [org.jboss.as] (MSC service thread 1-8) JBAS015950: WildFly 8.0.0.CR1 "WildFly" stopped in 25ms bash-4.2#
If you're sure you upgraded to the correct version, please give me the output of following commands: rpm -q wildfly rpm -V wildfly And provide the exact steps how you run wildfly on your system. Thanks!
Package wildfly-8.0.0-0.17.CR1.fc20: * should fix your issue, * was pushed to the Fedora 20 testing repository, * should be available at your local mirror within two days. Update it with: # su -c 'yum update --enablerepo=updates-testing wildfly-8.0.0-0.17.CR1.fc20' as soon as you are able to. Please go to the following url: https://admin.fedoraproject.org/updates/FEDORA-2014-2210/wildfly-8.0.0-0.17.CR1.fc20 then log in and leave karma (feedback).
wildfly-8.0.0-0.17.CR1.fc20 has been pushed to the Fedora 20 stable repository. If problems still persist, please make note of it in this bug report.