Bug 106290 - WebDAV is broken in Fedora 2 (and it seems gnome 2.4 in general)
WebDAV is broken in Fedora 2 (and it seems gnome 2.4 in general)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-vfs2 (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Alexander Larsson
: MoveUpstream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-04 20:20 EDT by Alan Cox
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 18:09:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2003-10-04 20:20:12 EDT
Description of problem:

The http: handlers take the URL quoted, remove the trailing "/" (wrong for http and
iffy for dav) and issue a PROPFIND. Apache DAV replies with a 301 content
redirection message which the DAV detection then treats as a "no DAV" error. It
then retrieves the 
URL via GET and sees a redirect message. It then fetches the redirected URL  **BUT**
displays the redirection URL text not the correct URL text.

How reproducible:
100%

Steps to Reproduce:
1. Set up a DAV subdirectory on apache
2. Try and use nautilus with it
3.  Now try using the KDE file manager with it to prove its a client side bug
    
Actual results:
For https:// nautilus doesn't support it at all
For http:// the behaviour described is seen
With KDE or Windows systems accessing the same DAV folder it just works. Ditto
with davfs2.

Expected results:
Working DAV

Additional info:
This problem doesn't show up with the Microsoft DAV server side as it replies to
the PROPFIND without issuing a redirect.

As a footnote it seems the whole http:// support is rather buggy - I've also had
nautilus crashes while trying to debug this. I may have a look at writing a
proper dav: VFS module using neon, since neon already provides 99% of the needed
code including SSL.

Regardless of that the redirect bug needs fixing - it shouldnt treat redirect as
a propfind test failure and it shouldnt show the wrong page. It probably
shouldnt trim the trailing "/" either.
Comment 1 Alexander Larsson 2003-10-07 10:49:07 EDT
I think we have the webdav redirect bug in Gnome bugzilla somewhere.

Note You need to log in before you can comment on or make changes to this bug.