Bug 106291 - Change in zlib.h prevents R application from compiling
Summary: Change in zlib.h prevents R application from compiling
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: zlib   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-05 02:22 UTC by Marc Schwartz
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-08 16:51:56 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marc Schwartz 2003-10-05 02:22:33 UTC
Description of problem:
The latest version of zlib (1.2.0.7) has a change in zlib.h which results in the
inability to compile R, which is a GPL math/stats application
(http://www.r-project.org).

The change is on lines 31 and 32 of zlib.h where _ZLIB_H has been changed to
ZLIB_H (note the dropping of the initial '_').

One of R's header files checks for the presence of _ZLIB_H as part of a
conditional compilation check. The change in the DEFINE causes R's compilation
to break since the check fails.

A note has been posted to the zlib.org developers for follow up on this change.
Based upon that feedback, comments will be sent to the R Core developers with
recommendations for any changes required.


Version-Release number of selected component (if applicable):
zlib-devel-1.2.0.7-1.i386.rpm

How reproducible:
Every time

Steps to Reproduce:
1. ./configure
2. make
3.
    
Actual results:
R's compilation stops when the expected DEFINE is not found

Expected results:
Full compilation

Additional info:
It is likely that no changes will be required on this from the Fedora developers
and that the likely change will be required on the R side, pending feedback from
zlib.org.

Thanks.

Marc Schwartz

Comment 1 Jeff Johnson 2003-10-08 16:51:56 UTC
Fixed (by reverting to old zlib-1.1.4 zlib.h convention) in zlib-1.2.0.7-2.
Note that zlib-1.2.1 may still be different than this patch.


Note You need to log in before you can comment on or make changes to this bug.