Bug 1062954 - strongswan-pki segfaults
Summary: strongswan-pki segfaults
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: strongswan
Version: el6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Pavel Šimerda (pavlix)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-09 08:36 UTC by Andreas Bierfert
Modified: 2014-03-29 19:18 UTC (History)
3 users (show)

Fixed In Version: strongswan-5.1.2-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-29 19:18:20 UTC
Type: Bug


Attachments (Terms of Use)
Upstream strongSwan patch that fixes pki tool segfault (583 bytes, patch)
2014-02-26 01:43 UTC, Michael Rasmussen
no flags Details | Diff

Description Andreas Bierfert 2014-02-09 08:36:53 UTC
Description of problem:
strongswan-pki segfaults in command.c:143

cmds[registered] = command;

Version-Release number of selected component (if applicable):
5.1.1-4.el6.x86_64


How reproducible:
Always

Steps to Reproduce:
1. strongswan-pki

(gdb) run

Starting program: /usr/bin/strongswan-pki 

[Thread debugging using libthread_db enabled]

openssl FIPS mode(0) - disabled 

 

Program received signal SIGSEGV, Segmentation fault.

0x0000000000401bb1 in command_register (command=...) at command.c:143

143                        cmds[registered] = command;

Missing separate debuginfos, use: debuginfo-install
gmp-4.3.1-7.el6_2.2.x86_64 libgcc-4.4.7-4.el6.x86_64

(gdb) bt
#0  0x0000000000401bb1 in command_register (command=...) at command.c:143
#1  0x0000000000402126 in command_dispatch (c=1, v=0x7fffffffe678) at command.c:248
#2  0x000000392421ed1d in __libc_start_main (main=0x4017b0 <main>, argc=1, ubp_av=0x7fffffffe678, init=<value optimized out>, fini=<value optimized out>, rtld_fini=<value optimized out>, stack_end=0x7fffffffe668) at libc-start.c:226
#3  0x00000000004016b9 in _start ()

(gdb) print command
$1 = {call = 0x401eb0 <help>, op = 104 'h', cmd = 0x409bb4 "help",
description = 0x409bb9 "show usage information", line = {0x0, 0x0, 0x0, 0x0,
0x0, 0x0, 0x0, 0x0, 0x0, 0x0}, options = {{name = 0x0, op = 0 '\000', arg = 0, desc = 0x0} <repeats 32 times>}}

(gdb) print &command
$2 = (command_t *) 0x7fffffffdea0

Comment 1 Michael Rasmussen 2014-02-26 00:51:16 UTC
It looks like this issue was identified and fixed upstream and is planned for release in strongSwan 5.1.2.

http://wiki.strongswan.org/issues/452

Comment 2 Michael Rasmussen 2014-02-26 01:43:22 UTC
Created attachment 867706 [details]
Upstream strongSwan patch that fixes pki tool segfault

I applied this to the strongswan-5.1.1-4.el6.x86_64 source rpm and built it on a CentOS 6.5 x64 machine. It compiled without errors and installs.

When I run the command "strongswan pki --gen --outform pem", I got a properly formatted PEM RSA key.

Comment 3 Fedora Update System 2014-03-15 16:59:57 UTC
strongswan-5.1.2-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/strongswan-5.1.2-2.el6

Comment 4 Fedora Update System 2014-03-17 05:59:39 UTC
Package strongswan-5.1.2-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing strongswan-5.1.2-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0881/strongswan-5.1.2-2.el6
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-03-19 20:21:28 UTC
Package strongswan-5.1.2-3.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing strongswan-5.1.2-3.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0881/strongswan-5.1.2-3.el6
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-03-24 23:19:47 UTC
Package strongswan-5.1.2-4.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing strongswan-5.1.2-4.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0881/strongswan-5.1.2-4.el6
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-03-29 19:18:20 UTC
strongswan-5.1.2-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.