Bug 1063124 - Fail to boot windows 2012/win8.1/win8 x86_64 guest with '-cpu SandyBridge/Opteron_G4' with hv_relaxed flag
Summary: Fail to boot windows 2012/win8.1/win8 x86_64 guest with '-cpu SandyBridge/Opt...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm
Version: 6.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
Jiri Herrmann
URL:
Whiteboard:
: 1069082 (view as bug list)
Depends On:
Blocks: 1269194 1134550 1359965
TreeView+ depends on / blocked
 
Reported: 2014-02-10 05:03 UTC by Xu Han
Modified: 2019-06-13 07:57 UTC (History)
27 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
Guests with recent Windows systems in some cases fail to boot if "hv_relaxed" is used Attempting to boot KVM guests with the following operating systems currently fails with an "error code: 0x0000001E" message if the value of the "-cpu" option is `SandyBridge` or `Opteron_G4` and the "hv_relaxed" option is used. * 64-bit Windows 8 or later * 64-bit Windows Server 2012 or later To work around this problem, do not use "hv_relaxed".
Clone Of:
Environment:
Last Closed: 2017-01-26 15:23:00 UTC
Target Upstream Version:


Attachments (Terms of Use)
screen shot of errors (11.27 KB, image/png)
2014-02-10 05:09 UTC, Xu Han
no flags Details
screenshot of BSOD on rhel 6.8 (11.41 KB, image/png)
2015-11-11 09:21 UTC, Guo, Zhiyi
no flags Details
screen shot of errors (14.58 KB, image/png)
2016-11-14 06:37 UTC, Yiqian Wei
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1069082 0 high CLOSED win2012r2 guest show "Error Code: 0x0000001E" during installation 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1139928 0 high CLOSED win2012r2 guest would be black screen when booting vm 2021-02-22 00:41:40 UTC
Red Hat Bugzilla 1279726 0 high CLOSED windows 10_64 guest failed to boot w/ hv_relaxed 2021-02-22 00:41:40 UTC

Internal Links: 1069082 1139928 1279726

Description Xu Han 2014-02-10 05:03:52 UTC
Description of problem:
Fail to boot windows 2012 guest on rhel6 host with '-cpu SandyBridge,hv_relaxed', error code: 0x0000001E.
1. tested on same model rhel7 host with same command line did not hit this issue.
2. with '-cpu Westmere,hv_relaxed' did not hit this issue.

Version-Release number of selected component (if applicable):
qemu-kvm-0.12.1.2-2.420.el6.x86_64
kernel-2.6.32-440.el6.x86_64
Guest: windows 2012 64bit

How reproducible:
always

Steps to Reproduce:
1. boot win2012 guest with '-cpu SandyBridge,hv_relaxed'
# /usr/libexec/qemu-kvm -nodefaults -M rhel6.5.0 -m 4G -cpu SandyBridge,hv_relaxed -smp 8,threads=2,cores=2,sockets=2 -nodefconfig -qmp tcp:0:5550,server,nowait -rtc base=utc,clock=host,driftfix=slew -vga cirrus -boot order=cd,menu=on -vnc :0 -drive file=win2012-64-rhel6.qcow2,if=none,id=guest-img,cache=none,aio=native,rerror=stop,werror=stop -device ide-drive,drive=guest-img,id=os-disk,bootindex=1

Actual results:
boot failed.

Expected results:
guest could be boot with no errors.

Additional info:
# cat /proc/cpuinfo 
processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 58
model name	: Intel(R) Core(TM) i7-3770 CPU @ 3.40GHz
stepping	: 9
cpu MHz		: 3401.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 0
cpu cores	: 4
apicid		: 0
initial apicid	: 0
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx f16c rdrand lahf_lm ida arat epb xsaveopt pln pts dts tpr_shadow vnmi flexpriority ept vpid fsgsbase smep erms
bogomips	: 6784.31
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:

# lscpu 
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                8
On-line CPU(s) list:   0-7
Thread(s) per core:    2
Core(s) per socket:    4
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 58
Stepping:              9
CPU MHz:               1600.000
BogoMIPS:              6784.31
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              8192K
NUMA node0 CPU(s):     0-7

Comment 1 Xu Han 2014-02-10 05:09:00 UTC
Created attachment 861232 [details]
screen shot of errors

Comment 3 Vadim Rozenfeld 2014-04-17 11:31:21 UTC
Does it work well with '-cpu SandyBridge' only, without hv_relaxed flag?

Thanks,
Vadim.

Comment 4 Xu Han 2014-04-18 07:22:41 UTC
(In reply to Vadim Rozenfeld from comment #3)
> Does it work well with '-cpu SandyBridge' only, without hv_relaxed flag?

It works well with '-cpu SandyBridge' only. e.g:
# qemu-kvm \
   -nodefaults -M rhel6.5.0 -m 2G \
   -cpu SandyBridge \
   -smp 4,threads=2,cores=2,sockets=1 -nodefconfig -vga cirrus -vnc :0 \
   -cdrom /root/en_windows_server_2012_x64_dvd_915478.iso

But happened with 'hv_relaxed' flag append.

qemu-kvm-0.12.1.2-2.424.el6.x86_64
kernel-2.6.32-459.el6.x86_64

Comment 5 Vadim Rozenfeld 2014-04-18 09:21:28 UTC
(In reply to Xu Han from comment #4)
> (In reply to Vadim Rozenfeld from comment #3)
> > Does it work well with '-cpu SandyBridge' only, without hv_relaxed flag?
> 
> It works well with '-cpu SandyBridge' only. e.g:
> # qemu-kvm \
>    -nodefaults -M rhel6.5.0 -m 2G \
>    -cpu SandyBridge \
>    -smp 4,threads=2,cores=2,sockets=1 -nodefconfig -vga cirrus -vnc :0 \
>    -cdrom /root/en_windows_server_2012_x64_dvd_915478.iso
> 
> But happened with 'hv_relaxed' flag append.
> 
> qemu-kvm-0.12.1.2-2.424.el6.x86_64
> kernel-2.6.32-459.el6.x86_64

thanks for your prompt reply.
Vadim

Comment 6 Xu Han 2014-06-19 08:25:57 UTC
Also hit this issue on Win8.0 and Win8.1 64 bit guest. The 32 bit version works well with "-cpu 'SandyBridge',+sep,hv_relaxed".

Comment 7 Ronen Hod 2014-09-10 10:30:02 UTC
Since it doesn't happen in RHEL7, maybe some kind of bisect can help. Vadim, do you suspect any specific RHEL7 patches that fixed it?

Comment 8 Vadim Rozenfeld 2014-09-22 11:37:42 UTC
(In reply to Ronen Hod from comment #7)
> Since it doesn't happen in RHEL7, maybe some kind of bisect can help. Vadim,
> do you suspect any specific RHEL7 patches that fixed it?

Probably yes.
Let's go through cpu flags to check if there is any difference between RHEL6.6 and RHEL7

Comment 10 Vadim Rozenfeld 2015-01-25 02:21:43 UTC
*** Bug 1069082 has been marked as a duplicate of this bug. ***

Comment 11 Qunfang Zhang 2015-05-04 09:19:44 UTC
Also hit this issue with "-cpu 'Opteron_G4',hv_relaxed", remove the hv_relaxed flag, works well.

Comment 13 Vadim Rozenfeld 2015-11-05 07:29:19 UTC
Can we try reproducing the problem on rhel 7.2?

Comment 14 Xueqiang Wei 2015-11-10 06:09:18 UTC
(In reply to Vadim Rozenfeld from comment #13)
> Can we try reproducing the problem on rhel 7.2?


Not hit this issue on rhel 7.2:
SandyBridge platform: (windows2012/win8.1)
kernel-3.10.0-327.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7
qemu-kvm-1.5.3-105.el7

Opteron_G4 platform: (windows2012/win8.1)
kernel-3.10.0-327.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7
qemu-kvm-1.5.3-105.el7

Comment 15 Vadim Rozenfeld 2015-11-10 06:27:18 UTC
(In reply to Xueqiang Wei from comment #14)
> (In reply to Vadim Rozenfeld from comment #13)
> > Can we try reproducing the problem on rhel 7.2?
> 
> 
> Not hit this issue on rhel 7.2:
> SandyBridge platform: (windows2012/win8.1)
> kernel-3.10.0-327.el7.x86_64
> qemu-kvm-rhev-2.3.0-31.el7
> qemu-kvm-1.5.3-105.el7
> 
> Opteron_G4 platform: (windows2012/win8.1)
> kernel-3.10.0-327.el7.x86_64
> qemu-kvm-rhev-2.3.0-31.el7
> qemu-kvm-1.5.3-105.el7

Thank you. 
Closing the bug, based on this comment.

Comment 16 Chao Yang 2015-11-10 06:35:21 UTC
(In reply to Vadim Rozenfeld from comment #15)
> (In reply to Xueqiang Wei from comment #14)
> > (In reply to Vadim Rozenfeld from comment #13)
> > > Can we try reproducing the problem on rhel 7.2?
> > 
> > 
> > Not hit this issue on rhel 7.2:
> > SandyBridge platform: (windows2012/win8.1)
> > kernel-3.10.0-327.el7.x86_64
> > qemu-kvm-rhev-2.3.0-31.el7
> > qemu-kvm-1.5.3-105.el7
> > 
> > Opteron_G4 platform: (windows2012/win8.1)
> > kernel-3.10.0-327.el7.x86_64
> > qemu-kvm-rhev-2.3.0-31.el7
> > qemu-kvm-1.5.3-105.el7
> 
> Thank you. 
> Closing the bug, based on this comment.

Vadim,

Would you please tell more why this bug is closed with resolution CURRENTRELEASE? This is bug against RHEL 6 product and apparently this bug is reproducible on RHEL 6 per latest Comment 11.

Comment 17 Vadim Rozenfeld 2015-11-10 07:28:32 UTC
(In reply to Chao Yang from comment #16)
> (In reply to Vadim Rozenfeld from comment #15)
> > (In reply to Xueqiang Wei from comment #14)
> > > (In reply to Vadim Rozenfeld from comment #13)
> > > > Can we try reproducing the problem on rhel 7.2?
> > > 
> > > 
> > > Not hit this issue on rhel 7.2:
> > > SandyBridge platform: (windows2012/win8.1)
> > > kernel-3.10.0-327.el7.x86_64
> > > qemu-kvm-rhev-2.3.0-31.el7
> > > qemu-kvm-1.5.3-105.el7
> > > 
> > > Opteron_G4 platform: (windows2012/win8.1)
> > > kernel-3.10.0-327.el7.x86_64
> > > qemu-kvm-rhev-2.3.0-31.el7
> > > qemu-kvm-1.5.3-105.el7
> > 
> > Thank you. 
> > Closing the bug, based on this comment.
> 
> Vadim,
> 
> Would you please tell more why this bug is closed with resolution
> CURRENTRELEASE? This is bug against RHEL 6 product and apparently this bug
> is reproducible on RHEL 6 per latest Comment 11.

My fault, bringing it back to assigned. Btw, how does it work on rhel 6.8?

Thanks,
Vadim.

Comment 18 Chao Yang 2015-11-10 09:53:40 UTC
Hi Zhiyi,

Could you help a try and reply to Vadim's questions above?

Comment 19 Guo, Zhiyi 2015-11-11 08:41:31 UTC
Issue can be reproduced on rhel 6.8 and environment briefs:
Platforms: Opteron_G4/SandyBridge
Os:win2012 x64/win8.1 x64
kernel&qemu:2.6.32-583.el6.x86_64, qemu-kvm-0.12.1.2-2.481.el6.x86_64

Issue cannot be reproduced in same environment but change Os to win8.1 x86 version.

Error prompt: error code: 0x0000001E

Comment 20 Vadim Rozenfeld 2015-11-11 09:03:33 UTC
(In reply to Guo, Zhiyi from comment #19)
> Issue can be reproduced on rhel 6.8 and environment briefs:
> Platforms: Opteron_G4/SandyBridge
> Os:win2012 x64/win8.1 x64
> kernel&qemu:2.6.32-583.el6.x86_64, qemu-kvm-0.12.1.2-2.481.el6.x86_64
> 
> Issue cannot be reproduced in same environment but change Os to win8.1 x86
> version.
> 
> Error prompt: error code: 0x0000001E

Thanks,
Can you please share a screenshot, taken when the BSOD happens?

Vadim.

Comment 21 Guo, Zhiyi 2015-11-11 09:21:52 UTC
Created attachment 1092621 [details]
screenshot of BSOD on rhel 6.8

Xu Han has attached the screenshot for BSOD, attach screenshot for rhel 6.8

Comment 22 Vadim Rozenfeld 2015-11-11 10:11:21 UTC
(In reply to Guo, Zhiyi from comment #21)
> Created attachment 1092621 [details]
> screenshot of BSOD on rhel 6.8
> 
> Xu Han has attached the screenshot for BSOD, attach screenshot for rhel 6.8

Thanks.
Now, can you please run the same VM without hv_relaxed flag, trigger BSOD with NMI, and then share generated crash dump file?

Vadim.

Comment 23 Guo, Zhiyi 2015-11-13 02:00:16 UTC
Upload crash dump file to http://fileshare.englab.nay.redhat.com/pub/section2/images_backup/rhel6/bug1063124/

Include Opteron_G4.dmp and SandyBridge.DMP

Comment 24 Gu Nini 2016-01-12 10:53:14 UTC
The bug could be reproduced on win8.1 x86_64 and win10 x86_64 guests with "-cpu 'Haswell',hv_relaxed", please refer to following bug comment for details:

https://bugzilla.redhat.com/show_bug.cgi?id=1204453#c25

The sw versions are as follows:
Host kernel: 2.6.32-595.el6.x86_64
Qemu-kvm-rhev: qemu-kvm-rhev-0.12.1.2-2.483.el6.x86_64
Virtio-win: virtio-win-1.7.5-0.el6.iso

Comment 25 Gu Nini 2016-01-12 11:00:21 UTC
(In reply to Gu Nini from comment #24)
> The bug could be reproduced on win8.1 x86_64 and win10 x86_64 guests with
> "-cpu 'Haswell',hv_relaxed", please refer to following bug comment for
> details:
> 
> https://bugzilla.redhat.com/show_bug.cgi?id=1204453#c25
> 
> The sw versions are as follows:
> Host kernel: 2.6.32-595.el6.x86_64
> Qemu-kvm-rhev: qemu-kvm-rhev-0.12.1.2-2.483.el6.x86_64
> Virtio-win: virtio-win-1.7.5-0.el6.iso

Failed to reproduce the bug on Win7.sp1_x86_64 guest on the same host.

Comment 32 Vadim Rozenfeld 2016-11-12 07:11:51 UTC
can we try it with ignore_msrs kvm's parameter turned on?

Thanks you.
Vadim.

Comment 33 Yiqian Wei 2016-11-14 05:29:28 UTC
Hi Vadim,
Reproduced this issue.
Version:
    qemu-kvm:qemu-kvm-0.12.1.2-2.415.el6.x86_64
    kernel:kernel-2.6.32-663.el6.x86_64
    guest:win2012 64bit
--------------------------------------
Also reproduced this issue with ignore_msrs=Y
The way of turning on ignore_msrs:
echo 1 > /sys/module/kvm/parameters/ignore_msrs
echo "options kvm ignore_msrs=1" | sudo tee /etc/modprobe.d/kvm-ignore-msrs.conf

Test results:
boot failed.

Additional info:
1.boot win2012 guest with '-cpu SandyBridge,hv_relaxed'
/usr/libexec/qemu-kvm \
-nodefaults \
-M rhel6.5.0 \
-m 4G \
-cpu SandyBridge,hv_relaxed \
-smp 8,threads=2,cores=2,sockets=2 \
-nodefconfig \
-qmp tcp:0:5550,server,nowait \
-rtc base=utc,clock=host,driftfix=slew \
-vga cirrus \
-boot order=cd,menu=on \
-vnc :0 \
-monitor stdio \
-drive file=/home/win2012/64bit/bug-1063124,if=none,id=guest-img,cache=none,aio=native,rerror=stop,werror=stop \
-device ide-drive,drive=guest-img,id=os-disk,bootindex=1 \
-cdrom /home/win2012/64bit/en_windows_server_2012_x64_dvd_915478.iso  \
2.# cat /proc/cpuinfo 
processor	: 7
vendor_id	: GenuineIntel
cpu family	: 6
model		: 42
model name	: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
stepping	: 7
microcode	: 41
cpu MHz		: 1600.000
cache size	: 8192 KB
physical id	: 0
siblings	: 8
core id		: 3
cpu cores	: 4
apicid		: 7
initial apicid	: 7
fpu		: yes
fpu_exception	: yes
cpuid level	: 13
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
bogomips	: 6784.63
clflush size	: 64
cache_alignment	: 64
address sizes	: 36 bits physical, 48 bits virtual
power management:
3.# lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                8
On-line CPU(s) list:   0-7
Thread(s) per core:    2
Core(s) per socket:    4
Socket(s):             1
NUMA node(s):          1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 42
Model name:            Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
Stepping:              7
CPU MHz:               1600.000
BogoMIPS:              6784.63
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              256K
L3 cache:              8192K
NUMA node0 CPU(s):     0-7

Comment 34 Yiqian Wei 2016-11-14 06:37:27 UTC
Created attachment 1220284 [details]
screen shot of errors

Comment 35 Yiqian Wei 2016-11-14 06:40:56 UTC
(In reply to Yiqian Wei from comment #33)
> Hi Vadim,
> Reproduced this issue.
> Version:
>     qemu-kvm:qemu-kvm-0.12.1.2-2.415.el6.x86_64
>     kernel:kernel-2.6.32-663.el6.x86_64
>     guest:win2012 64bit
> --------------------------------------
> Also reproduced this issue with ignore_msrs=Y
> The way of turning on ignore_msrs:
> echo 1 > /sys/module/kvm/parameters/ignore_msrs
> echo "options kvm ignore_msrs=1" | sudo tee
> /etc/modprobe.d/kvm-ignore-msrs.conf
> 
> Test results:
> boot failed.
> 
> Additional info:
> 1.boot win2012 guest with '-cpu SandyBridge,hv_relaxed'
> /usr/libexec/qemu-kvm \
> -nodefaults \
> -M rhel6.5.0 \
> -m 4G \
> -cpu SandyBridge,hv_relaxed \
> -smp 8,threads=2,cores=2,sockets=2 \
> -nodefconfig \
> -qmp tcp:0:5550,server,nowait \
> -rtc base=utc,clock=host,driftfix=slew \
> -vga cirrus \
> -boot order=cd,menu=on \
> -vnc :0 \
> -monitor stdio \
> -drive
> file=/home/win2012/64bit/bug-1063124,if=none,id=guest-img,cache=none,
> aio=native,rerror=stop,werror=stop \
> -device ide-drive,drive=guest-img,id=os-disk,bootindex=1 \
> -cdrom /home/win2012/64bit/en_windows_server_2012_x64_dvd_915478.iso  \
> 2.# cat /proc/cpuinfo 
> processor	: 7
> vendor_id	: GenuineIntel
> cpu family	: 6
> model		: 42
> model name	: Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
> stepping	: 7
> microcode	: 41
> cpu MHz		: 1600.000
> cache size	: 8192 KB
> physical id	: 0
> siblings	: 8
> core id		: 3
> cpu cores	: 4
> apicid		: 7
> initial apicid	: 7
> fpu		: yes
> fpu_exception	: yes
> cpuid level	: 13
> wp		: yes
> flags		: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat
> pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm
> constant_tsc arch_perfmon pebs bts rep_good xtopology nonstop_tsc aperfmperf
> pni pclmulqdq dtes64 monitor ds_cpl vmx smx est tm2 ssse3 cx16 xtpr pdcm
> pcid sse4_1 sse4_2 x2apic popcnt tsc_deadline_timer aes xsave avx lahf_lm
> ida arat epb xsaveopt pln pts dtherm tpr_shadow vnmi flexpriority ept vpid
> bogomips	: 6784.63
> clflush size	: 64
> cache_alignment	: 64
> address sizes	: 36 bits physical, 48 bits virtual
> power management:
> 3.# lscpu
> Architecture:          x86_64
> CPU op-mode(s):        32-bit, 64-bit
> Byte Order:            Little Endian
> CPU(s):                8
> On-line CPU(s) list:   0-7
> Thread(s) per core:    2
> Core(s) per socket:    4
> Socket(s):             1
> NUMA node(s):          1
> Vendor ID:             GenuineIntel
> CPU family:            6
> Model:                 42
> Model name:            Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz
> Stepping:              7
> CPU MHz:               1600.000
> BogoMIPS:              6784.63
> Virtualization:        VT-x
> L1d cache:             32K
> L1i cache:             32K
> L2 cache:              256K
> L3 cache:              8192K
> NUMA node0 CPU(s):     0-7

Retest----the latest version of qemu-kvm
host version:
qemu-kvm-0.12.1.2-2.496.el6.x86_64
kernel-2.6.32-663.el6.x86_64
--------------------
Test results:
boot failed.

Comment 36 Amnon Ilan 2017-01-12 10:10:24 UTC
Comment from Vadim: 
I managed to reproduce and partially debug this issue.The crash itself happens inside of HvlEnlightenProcessorfunction when kernel tries to access unsupported Hyper-VMSRs. The simplest work around for this issue will notto specify hv_relaxed flag at all for all Windows gueststarting form Win8/WS2012. Recent Windows platforms will deactivate 101 BSOD if hypervisor flag is present (even if hv_relaxed has not been specified).Vadim.

Comment 37 Amnon Ilan 2017-01-12 10:15:19 UTC
Based on comment#36 let's update our docs to not use the hv_relaxed in RHEL6 for Windows8/2012 and newer.

QE, can you verifiy it by running stress tests and check that you do not get BSOD 101 with Windows8/2012/10/2016 when the hv_relaxed is not set.

Comment 38 juzhang 2017-01-12 12:25:17 UTC
(In reply to Amnon Ilan from comment #37)
> Based on comment#36 let's update our docs to not use the hv_relaxed in RHEL6
> for Windows8/2012 and newer.
> 
> QE, can you verifiy it by running stress tests and check that you do not get
> BSOD 101 with Windows8/2012/10/2016 when the hv_relaxed is not set.

Hi Yiwei,

Could you have a try?

Best Regards,
Junyi

Comment 39 Yiqian Wei 2017-01-16 10:40:00 UTC
test version

qemu-kvm:qemu-kvm-0.12.1.2-2.501.el6.x86_64
kernel:kernel-2.6.32-663.el6.x86_64
virtio-win:virtio-win-1.8.0-1.el6.noarch
guest:win2012 64bit

a.boot win2012 guest with '-cpu SandyBridge' and run stress tests in guest.

Test results:
guest not get BSOD 101.

b.boot win2012 guest with '-cpu SandBridge,hv_relaxed'

Test results:
boot failed.

Additional info:
1./usr/libexec/qemu-kvm \
-nodefaults \
-M rhel6.5.0 \
-m 4G \
-cpu SandyBridge,enforce \
-smp 8,threads=2,cores=2,sockets=2 \
-nodefconfig \
-qmp tcp:0:5551,server,nowait \
-rtc base=utc,clock=host,driftfix=slew \
-vga cirrus \
-boot order=cd,menu=on \
-vnc :1 \
-usbdevice tablet \
-monitor stdio \
-drive file=/home/win2012/64bit/bz1063124,if=none,id=drive-virtio-disk0,format=qcow2,cache=none \
-device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 \
-netdev tap,id=hostnet0,vhost=on \
-device virtio-net-pci,netdev=hostnet0,id=net0,mac=52:54:00:aa:c3:8a,bus=pci.0,addr=0x8 \
-fda  /usr/share/virtio-win/virtio-win_amd64.vfd \


Note You need to log in before you can comment on or make changes to this bug.