Bug 106323 - Bootsplash patch
Bootsplash patch
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-05 14:57 EDT by Jason Luka
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 12:38:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Bootsplash patch (80.54 KB, patch)
2003-10-05 14:58 EDT, Jason Luka
no flags Details | Diff

  None (edit)
Description Jason Luka 2003-10-05 14:57:40 EDT
Attaching patch to add bootsplash support to kernel.  This patch allows an image
to be placed behind the console, starting as soon the kernel loads.
Comment 1 Jason Luka 2003-10-05 14:58:20 EDT
Created attachment 94939 [details]
Bootsplash patch
Comment 2 Behdad Esfahbod 2003-10-06 23:50:08 EDT
Is it going to be incorporated?  Seems very promising.
Comment 3 Arjan van de Ven 2003-10-07 03:46:06 EDT
actually it doesn't look promising....
Comment 4 Jason Luka 2003-10-07 08:11:30 EDT
I haven't had any problems getting it to work as of now.  It will however,
require a few minor changes.

1) The actual bootsplash screens need to be selected and drawn (one for each
screen resolution).  I'm using the default with the Linux penguin right now.
2) The 'splashutils' rpm will need to be built.  (Not a big problem)
3) mkinitrd will have to add the bootsplash screens to the initrd, so an
arbitrary location for the config and splash files will have to be selected.
4) Bootsplash screens and config need to be included with the kernel-source.
4) (optional) A shell script (which I have one written) to load a shutdown
splash screen, or a small adjustment to rc.sysinit.
Comment 5 Alan Cox 2004-06-21 12:38:11 EDT
It breaks several video card setups because it uses the vesa graphical
consoles.

Note You need to log in before you can comment on or make changes to this bug.