Bug 1063245 - Error setting up base repository
Error setting up base repository
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-10 06:01 EST by Alexander Todorov
Modified: 2014-03-17 06:53 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-17 06:53:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (13.77 KB, text/plain)
2014-02-10 06:01 EST, Alexander Todorov
no flags Details
console.log (45.85 KB, text/plain)
2014-02-10 06:02 EST, Alexander Todorov
no flags Details
program.log (23.06 KB, text/plain)
2014-02-10 06:02 EST, Alexander Todorov
no flags Details
sys.log (73.61 KB, text/plain)
2014-02-10 06:02 EST, Alexander Todorov
no flags Details

  None (edit)
Description Alexander Todorov 2014-02-10 06:01:11 EST
Created attachment 861347 [details]
anaconda.log

Description of problem:

While performing automated installation configured to use NFS installation source I see anaconda stuck at the first spoke with message "Error setting up base repository".

I can mount the same NFS location just fine from my laptop. 

Same error happens with http repo as well. 


In the logs I see:

06:54:56,969 DEBUG anaconda: Entered spoke: SourceSpoke
06:54:56,977 DEBUG anaconda: Setting up repos: []
06:54:58,852 DEBUG anaconda: Left spoke: SourceSpoke
06:54:58,852 INFO anaconda: Running Thread: AnaPayloadMDThread (140112203994880)
06:54:59,168 INFO anaconda: spoke is not ready: <pyanaconda.ui.gui.spokes.software.SoftwareSelectionSpoke object at 0x7f6e84189610>
06:54:59,176 INFO anaconda: spoke is not ready: <pyanaconda.ui.gui.spokes.source.SourceSpoke object at 0x7f6e6b879cd0>
06:54:59,177 INFO anaconda: setting <pyanaconda.ui.gui.spokes.source.SourceSpoke object at 0x7f6e6b879cd0> status to: Setting up installation source...
06:55:00,072 INFO anaconda: setting <pyanaconda.ui.gui.spokes.source.SourceSpoke object at 0x7f6e6b879cd0> status to: Downloading package metadata...
06:55:00,081 INFO anaconda: Thread Done: AnaPayloadMDThread (140112203994880)
06:55:00,174 INFO anaconda: setting <pyanaconda.ui.gui.spokes.source.SourceSpoke object at 0x7f6e6b879cd0> status to: Error downloading package metadata...
06:55:00,182 INFO anaconda: spoke is ready: <pyanaconda.ui.gui.spokes.source.SourceSpoke object at 0x7f6e6b879cd0>
06:55:00,223 INFO anaconda: spoke is ready: <pyanaconda.ui.gui.spokes.source.SourceSpoke object at 0x7f6e6b879cd0>



Version-Release number of selected component (if applicable):
anaconda-21.20-1.fc21.x86_64.rpm
Comment 1 Alexander Todorov 2014-02-10 06:02:00 EST
Created attachment 861348 [details]
console.log
Comment 2 Alexander Todorov 2014-02-10 06:02:12 EST
Created attachment 861349 [details]
program.log
Comment 3 Alexander Todorov 2014-02-10 06:02:20 EST
Created attachment 861350 [details]
sys.log
Comment 6 David Shea 2014-02-20 14:45:16 EST
06:55:00,174 INFO anaconda: setting <pyanaconda.ui.gui.spokes.source.SourceSpoke object at 0x7f6e6b879cd0> status to: Error downloading package metadata...

Looks like yum was unable to download the package metadata.
Comment 7 Richard W.M. Jones 2014-03-04 07:18:52 EST
I see this as well (using an http source).

I'm using a proxy, and I can see, in the proxy logs, that it
is downloading info files just fine:

1393935410.569    860 192.168.0.121 TCP_MISS/200 1718 GET http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/i386/os/.treeinfo - DIRECT/209.132.181.24 text/plain
1393935410.621      0 192.168.0.121 TCP_MEM_HIT/200 4781 GET http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/i386/os/repodata/repomd.xml - NONE/- text/xml
1393935429.618      0 192.168.0.121 TCP_MEM_HIT/200 1726 GET http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/i386/os//.treeinfo - NONE/- text/plain
1393935429.655      0 192.168.0.121 TCP_MEM_HIT/200 4781 GET http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/i386/os/repodata/repomd.xml - NONE/- text/xml
Comment 8 Richard W.M. Jones 2014-03-04 07:21:41 EST
Just a note about comment 7:

That's from two attempts to set the URL.

No other files are downloaded apart from those two.  So if yum is
starting up, it's not even accessing the network.
Comment 9 Richard W.M. Jones 2014-03-04 07:51:41 EST
Same on 64 bit Rawhide.  The squid logs are:

1393936897.999 1116344 192.168.0.87 TCP_MISS/200 262619623 GET http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os//LiveOS/squashfs.img - DIRECT/209.132.181.24 application/octet-stream
1393936898.310    270 192.168.0.87 TCP_MISS/404 670 GET http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os//images/updates.img - DIRECT/209.132.181.24 text/html
1393936898.584    223 192.168.0.87 TCP_MISS/404 670 GET http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os//images/product.img - DIRECT/209.132.181.24 text/html
1393936918.172      0 192.168.0.88 TCP_MEM_HIT/200 1595 GET http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os//.treeinfo - NONE/- text/plain
1393936918.909    585 192.168.0.88 TCP_MISS/200 4777 GET http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/repodata/repomd.xml - DIRECT/209.132.181.23 text/xml
Comment 10 Alexander Todorov 2014-03-17 06:53:42 EDT
With anaconda 21.27-1 and todays Rawhide snapshot I have one system which completed the install and a few others which seem to have gone past the package installation step (running %post scripts or failed due to other reasons). Closing.

Note You need to log in before you can comment on or make changes to this bug.