Bug 1063289 - [QE] (6.3.0) Wrong handling of --debug argument by standalone.[sh|bat] scripts
Summary: [QE] (6.3.0) Wrong handling of --debug argument by standalone.[sh|bat] scripts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Scripts and Commands
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: DR2
: EAP 6.3.0
Assignee: Tomaz Cerar
QA Contact: Petr Kremensky
URL:
Whiteboard:
Depends On:
Blocks: 1072227 1072228
TreeView+ depends on / blocked
 
Reported: 2014-02-10 12:24 UTC by Petr Kremensky
Modified: 2017-10-10 00:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1072227 (view as bug list)
Environment:
Last Closed: 2014-08-06 14:36:04 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1064763 0 unspecified CLOSED [QE] (6.4.z) standalone.sh fails to start server with debug argument on solaris 10 and HP-UX hosts 2021-02-22 00:41:40 UTC
Red Hat Issue Tracker WFLY-2261 0 Major Resolved standalone.sh --debug without port number not working 2016-06-01 13:06:48 UTC

Internal Links: 1064763

Description Petr Kremensky 2014-02-10 12:24:27 UTC
Description of problem:
 Standalone server start script is handling --debug argument in wrong manner. Port 8787 should be used by default, but it isn't.

Version-Release number of selected component (if applicable):
 EAP 6.2.0

How reproducible:
 Always

Steps to Reproduce:
 1. Navigate into $EAP_HOME/bin directory.
 2. Run: standalone.[sh|bat] --debug 

Actual results:
- shell script
 Server fail to with following error:
 ERROR [stderr] (main) JBAS015801: Invalid option ''
- batch script
 random empty port is used

Expected results:
 Server will start with debugger attached to 8787 port.

Additional info:
 Workaround: always specify the port number.

Comment 1 Permaine Cheung 2014-02-10 14:12:30 UTC
Brian, please look into this. Thanks!

Comment 4 Brian Stansberry 2014-03-04 19:56:16 UTC
*** Bug 1064763 has been marked as a duplicate of this bug. ***

Comment 5 Petr Kremensky 2014-03-07 07:39:10 UTC
The issue still exists for standalone.bat script. Running 
>standalone.bat --debug
won't use default (8787). Different port is used every time.

Comment 6 Jeff Mesnil 2014-03-07 09:03:00 UTC
I don't have access to a Windows box to fix the standalone.bat script.

Comment 7 Petr Kremensky 2014-07-09 08:04:31 UTC
Verified on EAP 6.3.0.ER9.

Closing this one as I found BZ928888 which is covering the batch scripts. Solaris/Hp-ux should be covered by BZ1064763.

RHEL is working fine.


Note You need to log in before you can comment on or make changes to this bug.