Bug 10633 - network not configured for smc-ultra
Summary: network not configured for smc-ultra
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-07 13:57 UTC by Michael Redinger
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-24 14:58:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael Redinger 2000-04-07 13:57:53 UTC
Using the "normal" (grafical) install method, the network is not
configured  (skipped) if I use a SMC Ultra (ISA) card. When I do use a PCI
network card, the network is configured (ie. I do get the appropriate
dialog).
I do suppose that this is also true for other ISA network card.
As this did work in previous Red Hat version (you were asked what network
card you have), I suppose this is a bug.

Comment 1 jonathan 2000-04-11 12:51:59 UTC
I am seeing similar behaviour for old NE2000 clone ISA cards.

Comment 2 Jay Turner 2000-04-24 14:58:59 UTC
This is actually not a bug.  The network configuration screen is skipped if the
installer does not "see" a network card.  Since the installer is not capable of
auto-probing ISA cards, it is not seeing the NIC.  The workaround for the
ISA-card problem is to boot the installer with "linux isa" which will prompt the
user to identify the ISA cards which are in the system and then the installer
will configure support for them.

Comment 3 jonathan 2000-06-02 23:54:44 UTC
Since this used to work in earlier RH installers, and the change was not
documented in the RH Install Guide (that I can see), and the workaround was
also not presented there, this is surely at *minimum* a documentation bug?

I'd argue that it would probably make more sense for the installer to ask a
question, something like

"No PCI network card detected.  Is an ISA network card installed?"

and do the ISA dialogue if Yes is selected.

Relying on (undocumented?) new command line parameters is surely not exactly
clear positive progress towards a more user-friendly installation process?

Jonathan <jonathan@xc.org>



Note You need to log in before you can comment on or make changes to this bug.