Bug 106366 - colorls.sh aliases do not load in GNOME terminal
Summary: colorls.sh aliases do not load in GNOME terminal
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: setup   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-06 15:23 UTC by Adam H. Pendleton
Modified: 2014-03-17 02:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 04:20:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Changes in etc to properly change ls colors (1.76 KB, patch)
2004-04-15 00:14 UTC, tswan
no flags Details | Diff

Description Adam H. Pendleton 2003-10-06 15:23:51 UTC
Description of problem:
The aliases described in /etc/profile.d/colols.sh do not get loaded at login,
nor when script is run through bash.  However, if another bash process is
started (e.g., 'bash', 'script'), the aliases load correctly.

Version-Release number of selected component (if applicable):

coreutils-5.0-20

How reproducible:

always

Steps to Reproduce:
1. Run GNOME terminal.
2. ll
3. sh -x /etc/profile.d/colorls.sh
4. ll
5. bash
6. ll
7. exit
8. script
9. alias
    
Actual results:

Aliases are not loaded in intial GNOME terminal, even though it appears that
they should be.

Expected results:

alias ll='ls -l --color=tty'

Additional info:

Comment 1 Tim Waugh 2003-10-13 12:47:26 UTC
Looks like a bashrc problem.

Comment 2 Bill Nottingham 2003-10-13 19:56:13 UTC
Are you logging in via GDM?

Comment 3 Adam H. Pendleton 2003-10-13 21:38:56 UTC
Yes I am loggin in via GDM.  I think this bug was fixed in the second-to-last
round of updates, but I can't confirm this until tomorrow (10/14/03).  I will
provide more information then.

Comment 4 tswan 2004-04-15 00:14:28 UTC
Created attachment 99435 [details]
Changes in etc to properly change ls colors

--color=tty is an invalid argument for ls.  The proper argument is
--color=always.

This file shows the changes necessary for /etc/DIR_COLORS,
/etc/profile.d/colorls.sh /etc/profile.d/colorls.csh. It also adds color
support for putty terminals should that be desired.

Comment 5 Bill Nottingham 2004-04-15 04:20:10 UTC
ls --color=tty *is* valid. 'always' is almost always wrong - think
redirection.

Please reopen if this persists with FC1, or FC2 test.


Note You need to log in before you can comment on or make changes to this bug.