Bug 106372 - post-install process exception aborts install
post-install process exception aborts install
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
high Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2003-10-06 11:55 EDT by Don Russell
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 01:27:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
This is the file from "save crasg info to floppy" when exception happened (24.11 KB, text/plain)
2003-10-06 11:57 EDT, Don Russell
no flags Details
anacdump text file in zip format (unzip size is approx 1.4MB) (151.52 KB, application/octet-stream)
2003-10-12 16:47 EDT, Don Russell
no flags Details
X.log file created upon initial boot from CD1 (1.41 KB, text/plain)
2003-10-21 00:54 EDT, Don Russell
no flags Details
anaconda.log (4.33 KB, text/plain)
2003-10-21 00:58 EDT, Don Russell
no flags Details
syslog after initial boot from CD1 (8.21 KB, text/plain)
2003-10-21 01:10 EDT, Don Russell
no flags Details
created after initial boot from CD1 (3.83 KB, text/plain)
2003-10-21 01:25 EDT, Don Russell
no flags Details
messages file (29.07 KB, text/plain)
2003-10-21 14:04 EDT, Don Russell
no flags Details
dmesg file (6.89 KB, text/plain)
2003-10-21 14:04 EDT, Don Russell
no flags Details
install.log file in zipped format, unzipped size is just over 1MByte (29.33 KB, text/plain)
2003-10-21 17:07 EDT, Don Russell
no flags Details
install.log file in zipped format (unzipped size is just over 1MByte) (29.33 KB, application/octet-stream)
2003-10-21 17:10 EDT, Don Russell
no flags Details

  None (edit)
Description Don Russell 2003-10-06 11:55:02 EDT
Description of problem: "post-install process" exception caused install to 

Version-Release number of selected component (if applicable):

How reproducible:
I did not try to reproduce it yet.

Steps to Reproduce:
1. Insert CD1, boot from CD
2. Follow instructions, replacing CDs as required
Actual results:
After 3rd CD, "post install process" started, then got an exception.

Expected results:
Expected process to continue with installing grub etc...

Additional info:
See attached dump file. Saved to floppy as part of the exception handler...
Comment 1 Don Russell 2003-10-06 11:57:35 EDT
Created attachment 94950 [details]
This is the file from "save crasg info to floppy" when exception happened
Comment 2 Don Russell 2003-10-06 17:47:12 EDT
I should have mentioned I installed this as a "new installation", reformating 
hard disk 2 as part of the "automatic partititioning".
Comment 3 Michael Fulbright 2003-10-09 11:14:36 EDT
The log you attached is truncated - please confirm the entire file was attached.
Comment 4 Don Russell 2003-10-09 11:28:50 EDT
Yes, that's the entire file.
Note that the last part of the file does not have CRLF, it's just a list of all
the individual packages... the last is xosview: 0, 

Also, this brings up another point.... when I was prompted to put in a floppy
disk, the prompt said all data on the diskette would be lost.... that didn't
happen. When I took the disk out it still had a bunch of other files from
previous use. 

Let me know if there's any information you need... I can try the install again
later today if necessary.

Comment 5 Don Russell 2003-10-12 16:47:09 EDT
Created attachment 95122 [details]
anacdump text file in zip format (unzip size is approx 1.4MB)

I tried the install again... here's what I did, step by step...
Boot from CD1
   (Did not detect my monitor (IBM P96) properly (Redhat 9 does))
   (I entered horiz and vert frequencies manually as per monitor specs (Horiz:
30-107KHz; Vert: 48-120Hz 
   (Did not detect mouse properly; it selected 3button USB; it is actually a
Logitect Wheel Mouse (Model M/N M-BD58))
Tip said to select MS Intellimouse... so I selected that manually)
OK, on with the install...
Install Workstation
Auto partition
   remove all Linux partitions
   do NOT use hda
   DO use hdd
   GRUB on /dev/hda (default)
No firewall
US English only
Install default software
While installing packages, an exception occured:
Last message: Iinstalling gnome-desktop-devel-2.4.0-1.i386
Mouse stopped working (cursor was "text-insert" cursor over the text of the
exception details)
Keyboard was KO, I used TAB to select "save to floppy"
(Used a newly-formatted floppy because the message abot "it will remove all
data" doesn't seem to be accurate based on my last report)
Required power off/on to reboot
Reboots to grub> prompt
I reinstalled RH9... no problems with RH9
Comment 6 Don Russell 2003-10-12 23:25:38 EDT
I installed "Fedora code test 2" on my laptop and the install went OK. I
verified that the last package to be installed was the

That means the exception happened with the "post-install" process, as originally
posted. This time I was able to get a more complete anacdump file because I made
sure the diskette was blank first. (So, that's another bug... the "save crash
info to floppy" code does not erase the diskette even though the messages says
it will.)
Comment 7 Jeremy Katz 2003-10-14 15:51:02 EDT
Can you please verify your media by booting with 'linux mediacheck'?
Comment 8 Don Russell 2003-10-14 16:20:32 EDT
I didn't use that option at boot time, but I did select the "test media" choices
during the beginning of the install. (All three disks passed)

Is that sufficient, or do you want me to use the option you specified?

Also, with the release of test3 yesterday, I was going to try that to see if the
problem "went away"....

Comment 9 Jeremy Katz 2003-10-16 14:47:25 EDT
Looking at this, there are a lot of errors from rpm in your install.log (the
floppy was in fact formatted, there just happens to be more than 1.44 megs of
stuff!) -- is it possible that your hard drive has any sort of hardware problems?
Comment 10 Don Russell 2003-10-16 15:04:13 EDT
I am not aware of any problems with either of the hard disks in the system.
However, a minor point of frustration is any time I reboot the machine, it hangs
with GRUB displayed in the top left of the screen, followed by a blinking cursor.

CTL-ALT-DEL then reboots again and I see the message regarding loading stage 2,
and the GRUB menu appears.
This behavior was prior to any Fedora Core images... and I always attributed it
to the unused hard disk powering down and then some sort of timing problem at
boot up, waiting for the disk to spin up again... (Only one hard disk is in use
at a time, depending on which system I boot up)

Hard disk (hda) has an MS Windows 2000 Pro installation on it, and GRUB
The second hard disk I use for testing new things, like Fedore Core.

As for reformatting the diskette...
My initial attempt (see beginning of comments here) had the same trouble, and a
very truncated crash file was writen... it did NOT reformat the floppy because
when I loked at it on a Windows machine, there were other files on it from some
previous use. 

So, I formatted the floppy so I would be sure to have an empty one available for
another Fedora test install crash.... and that's the zip file I uploaded the
other day.

Comment 11 Don Russell 2003-10-16 20:03:20 EDT
I tried installing FCT3 onto this machine.....
It did not crash but I did see a lot of rpmdb errors... 
It did not boot up using the graphical boot, and at the point it would start X,
I got a message saying:

INIT: Id: "x" respawning too fast: disabled for 5 minutes

When I pressed enter I could log in as root.... 
I did a shutdown -r now which resulted in the same thing....

I tried to ftp /var/log/messages to somewhere but it said ftp was an unknown
command.... then I tried to copy the file to the floppy drive... but I don't
know how mount it... :-(

Comment 12 Jeremy Katz 2003-10-20 16:12:48 EDT
Can you try booting with 'ide=nodma' and see if that helps?
Comment 13 Don Russell 2003-10-20 17:17:49 EDT
I just completed the install using 
boot: linux ide=nodma

The install was much slower (expected) but it appeared tp make it all the way 

The exception did not happen (though I beleive that was fixed by correcting my 
IDE wiring/installation: I had my second IDE hard disk as "slave", with the CD-
ROM as "master". Though I don't think this should matter, the PC manual says a 
second hard disk MUST be master, and the factory-installed CD-ROM has to be 
changed to slave and connected to the "SLAVE" connector of thwe ATA100 cable.

Anyway.... when I tried to create a "boot diskette", I got an error saying "An 
error occurred creating the boot disk"...  I then said no boot disk, and 

With firstboot... things appeared to start up OK, but then did not go into 
graphical mode.

I was trying to copy someof the install log files to the floppy disk, but I 
don't know what the correct commands are... :-(

Comment 14 Don Russell 2003-10-20 17:30:47 EDT
I also have to say.... when the system was shutting down to do the firstboot, I 
got screenfuls of errors:

rpmdb fatal region error detected; run recovery

I suspect that's the root cause of these problems... the install is failing, 
even though there is no indication of anything wrong during the actual install 
Comment 15 Jeremy Katz 2003-10-20 17:34:41 EDT
Did you see the rpmdb errors even when booting with ide=nodma? 
Comment 16 Don Russell 2003-10-20 17:41:17 EDT
Yes, even when I used ide=nodma I got the rpmdb errors. :-(

The disk is 120GB, I dedicate the entire disk to Fedora and always let 
it "remove all linux partitions" and reformat automatically.

Comment 17 Jeremy Katz 2003-10-20 17:48:46 EDT
This is the only report I've seen of this and anaconda's not doing anything at
all that should be dependent on hardware here, so the only thing I can think of
is that somehow the kernel is hitting problems.
Comment 18 Don Russell 2003-10-20 18:03:19 EDT
It is very consistent.... I have tried reintsalling many, many time this past 
week end.

after firstboot, I look at /var/log/install.log and see everything running 
along nicely until it tries to install groff.... that's where the problems 
begin, and continue....

So, I think that's the stem to other problems further on.... the REAL problem 
is these rpmdb errors that happen during the package installation.

I thought I'd try installing without groff.. but I dno't really know what groff 
is, or where to find it in the package list to de-select it...

Comment 19 Don Russell 2003-10-21 00:54:52 EDT
Created attachment 95331 [details]
X.log file created upon initial boot from CD1

This file was created when I boot from CD1 to begin an installation.
At the first graphic screen at the start of the install, I pressed CTL-ALT-F2
and copied this file to a floppy disk so I could upload it here.
Comment 20 Don Russell 2003-10-21 00:58:36 EDT
Created attachment 95332 [details]

anaconda.log file taken at the same time as X.log above.... I don't see
anything unusual here...
Comment 21 Don Russell 2003-10-21 01:10:20 EDT
Created attachment 95335 [details]
syslog after initial boot from CD1

My concern here is the "late redistration" of the ide driver.... that did not
happen on another machine where FCT3 installed successfully.
Comment 22 Don Russell 2003-10-21 01:25:08 EDT
Created attachment 95338 [details]
created after initial boot from CD1

I'm including this file thinking it might provide some clues to why the
graphical boot doesn't work, but I really think the root of all the problems is
the rpmdb errors during package installation.
Comment 23 Dave Jones 2003-10-21 08:51:16 EDT
There's nothing in the log that stands out as a kernel problem. The IDE hardware
in question is quite commonplace, and we'd be seeing a lot more reports of
corruption if something was wrong with the piix driver.

The only thing I can think of is a hardware problem.
Try a run of memtest86, check the PSU is strong enough, check sufficient cooling
in the case/cpu etc.
Comment 24 Don Russell 2003-10-21 12:05:11 EDT
OK, I'll see if I can run the memory test, but it seems odd that the failure 
occurs very consistently. the rpm errors ALWAYS occur during the installation 
of groff-1.18.1-29.i386

If this is an "environmental condition caused failure", it'd expect much more 

Yes, the machine is adequately cooled etc....

I'll also see if I can get the /root/install.log file and post it here.... 
Comment 25 Don Russell 2003-10-21 13:34:05 EDT
I booted from CD1 and ran the memtest86 test.... it passed with no errors.

How can I get the /root/install.log file copied to a floppy disk? I booted the 
system, logged in as root, then...

mount /dev/fd0
cp /root/install.log /dev/fd0

it asked if I wanted to overwrite ... I said yes.... then I come back to my 
working windows system (dual boot) and windows complains that the diskette is 
not formatted.

Comment 26 Don Russell 2003-10-21 14:04:02 EDT
Created attachment 95353 [details]
messages file

"messages" file, shows some possible problem with IDE... late registration?
Comment 27 Don Russell 2003-10-21 14:04:51 EDT
Created attachment 95354 [details]
dmesg file

and the dmesg file .....
Comment 28 Dave Jones 2003-10-21 15:52:42 EDT
#25 - umount before you eject the disk

#26 - Shouldn't be a problem.
Comment 29 Don Russell 2003-10-21 17:07:37 EDT
Created attachment 95358 [details]
install.log file  in zipped format, unzipped size is just over 1MByte

Install was doing fine until it reached groff.... seems like everything after
that point choked. That's probably why I'm having all these other problems...
Comment 30 Don Russell 2003-10-21 17:10:06 EDT
Created attachment 95359 [details]
install.log file in zipped format (unzipped size is just over 1MByte)

The install was going along nicely until it hit groff.... then it choked and
never recovered. This is probably the root of all my other problems.

(I'm sending this again, because at first I uploaded it as "plain text", but
now it's zipped...)
Comment 31 Don Russell 2003-10-21 19:57:22 EDT
Just for fun, I tried installing a different distro... Mandrake Linux 9.1 
installed with no problems at all.

I think it's fair to use that as proof the hardware is OK.

Comment 32 Don Russell 2003-10-22 15:19:17 EDT
I just noticed the component says "kernel"....

Do you really think this is a kernel problem? I don't have a lot of experience 
here, but I think this is an anaconda (installation) problem.

The symptoms don't manifest themselves until firstboot, but if you look at 
the /root/install.log file (attached in zip format) you see the install starts 
failing with groff and never recovers.

And if you look at the X.log file created after the initial boot from CD1, it's 
having troubles there too...

Is this because the video is a RIVA TNT2 card with nvidia drivers? From what 
I'v been reading of nvidia, it seems I shouildn't waste my time trying to get 
Fedora beta running on this machine...

Comments? :-)
Comment 33 Ryan Yee 2004-01-29 22:53:19 EST
You know, I have the exact same problem with Red Hat 9. During the 
installation i pressed ctrl+alt+F1, i see a screen full of "rpmdb: 
fatal region error; run recovery". Not to mention when the 
installation completed, before having the computer restart, i would 
see the errors. I did in fact install Mandrake on the same computer 
after the failure with RH9 and it DID work! So it must be something 
else, not the hardware. (I was installing on the secondary master 
hard drive, a Western Digital 40GB dedicated to Linux)

When i booted up after the installation, I also couldn't get into the 

My specs:
Soyo P4YIS2 Motherboard w/ latest FW
Pentium 4 1.7Ghz
120GB SE (Windows XP Pro)
40GB (Linux)
Gainward Geforce 4 Ti4800se
Sony 52/24/52
Pioneer 106d DVD-/+RW

Keep in mind Mandrake 9.2 installation was fine and error free.
Comment 34 Eric H 2004-11-30 14:26:53 EST
I also get this exact same problem, I posted my stats to bug #139146
which I saw before this one.
Comment 35 Dave Jones 2005-04-16 01:27:55 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.