Bug 1063741 - gnome-terminal / vte very slow when doing 'cat' of a large text file
Summary: gnome-terminal / vte very slow when doing 'cat' of a large text file
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: vte
Version: 6.5
Hardware: x86_64
OS: Linux
high
high
Target Milestone: rc
: ---
Assignee: Zeeshan Ali
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords: EasyFix, Upstream
Depends On:
Blocks: 994246
TreeView+ depends on / blocked
 
Reported: 2014-02-11 11:16 UTC by Luca Villa
Modified: 2018-12-05 17:15 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2014-06-09 06:56:42 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0638 normal SHIPPED_LIVE vte bug fix update 2014-06-09 10:56:15 UTC
Red Hat Knowledge Base (Solution) 719533 None None None Never
GNOME Bugzilla 721944 None None None Never

Description Luca Villa 2014-02-11 11:16:44 UTC
Description of problem:

gnome-terminal is very slow when doing cat of a large text file.

e.g. with a ~16M text file:

[root@desktop ~]# time cat dnf.log 
[snip]
real	0m29.199s
user	0m0.000s
sys	0m0.307s

Version-Release number of selected component (if applicable):
- vte-0.25.1-8.el6_4

How reproducible:
always

Steps to Reproduce:
1. cat bigtext.txt
2.
3.

Actual results:
it takes a long time to finish the cat 

Expected results:
It should be much faster

Additional info:
This is an old regression in vte fixed upstream:

https://bugzilla.gnome.org/show_bug.cgi?id=721944

https://git.gnome.org/browse/vte/commit/?h=vte-0-36&id=2b4f4f1eea9dd87e27142ee02c973ce7ae9afd3c

When applying the fix above to RHEL gnome-terminal, it performs much better with a ~10x boost.

Comment 7 errata-xmlrpc 2014-06-09 06:56:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0638.html


Note You need to log in before you can comment on or make changes to this bug.