Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 1063864 - Backport of HornetQ-1278 into JBoss EAP
Backport of HornetQ-1278 into JBoss EAP
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: HornetQ (Show other bugs)
6.1.0
All All
medium Severity high
: DR2
: EAP 6.3.0
Assigned To: Clebert Suconic
Martin Svehla
Russell Dickenson
:
Depends On: 998823 1064596
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-11 09:57 EST by Tom Ross
Modified: 2014-08-06 10:40 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In older versions of JBoss EAP 6, Scheduled Delivery Handling did a full cycle of serial search on a List for Scheduled Deliveries. This could cause performance issues as the system could use high CPU resources to proceed with many scheduled deliveries under load. This release of the product has implemented a sorted list and proper search up to the expired times. The list search now runs much faster without the high CPU burden.
Story Points: ---
Clone Of: 998823
Environment:
Last Closed: 2014-08-06 10:40:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker HORNETQ-1278 Major Closed Full scheduledReferences traversal in every call to ScheduledDeliveryHandlerImpl$ScheduledDeliveryRunnable.run() 2017-10-17 03:37 EDT

  None (edit)
Description Tom Ross 2014-02-11 09:57:38 EST
+++ This bug was initially created as a clone of Bug #998823 +++

Description of problem:
Back port of HornetQ-1047 into SOA 5.3.1

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from JBoss JIRA Server on 2013-08-23 21:30:38 BST ---

Justin Bertram <jbertram@redhat.com> updated the status of jira HORNETQ-1047 to Resolved
Comment 1 Clebert Suconic 2014-02-12 15:37:21 EST
https://github.com/hornetq/hornetq/pull/1532
Comment 2 Kabir Khan 2014-04-04 10:47:27 EDT
Setting to ON_QA since upgrade should fix this
Comment 4 Martin Svehla 2014-04-22 03:20:23 EDT
Verified with EAP 6.3.0.ER1 / HornetQ 2.3.18

Note You need to log in before you can comment on or make changes to this bug.