Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
When running `netstat -n -A inet`, the application aborts execution with error message
Version-Release number of selected component (if applicable):
net-tools-2.0-0.15.20131004git.el7.x86_64
How reproducible:
Alwyas
Steps to Reproduce:
1. netstat -n -A inet
Actual results:
Active Internet connections (w/o servers)
Proto Recv-Q Send-Q Local Address Foreign Address State
tcp 0 0 192.168.122.125:22 192.168.122.1:51954 ESTABLISHED
netstat: no support for `AF INET (sctp)' on this system.
Expected results:
echo $?
0
Additional info:
running `modprobe sctp` makes the error go away.
Created attachment 861915[details]
Patch
Here is the patch, took from 1.60 version and adjusted to fit RHEL7 2.0 version. It suppresses the error message.
I noticed this message shows up in Fedora version too.
Thinking about it, it seems that adding "If the sctp module is not added to the kernel..." into manpage is actually pointless, because with the patch it no longer prints that message. So adding comment into man page and fixing the source are both excluding each other.
This request was resolved in Red Hat Enterprise Linux 7.0.
Contact your manager or support representative in case you have further questions about the request.