Bug 1063934 - [RFE] ss: sctp sockets are not listed
[RFE] ss: sctp sockets are not listed
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: iproute (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Phil Sutter
Jaroslav Aster
Ioanna Gkioka
: FutureFeature
Depends On: 1223783 1361728
Blocks: 1113520 1205796 1301628 1313485 976269 1039625 1110700 1191021 1279974 1393481
  Show dependency treegraph
 
Reported: 2014-02-11 11:21 EST by Hubert Kario
Modified: 2018-06-11 14:07 EDT (History)
16 users (show)

See Also:
Fixed In Version: iproute-3.10.0-79.el7
Doc Type: Enhancement
Doc Text:
*ss* now supports SCTP sockets list Previously, the *netstat* utility provided a list of Stream Control Transmission Protocol (SCTP) sockets. With this update, the *ss* utility is able to display the same list.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 17:32:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2171 normal SHIPPED_LIVE iproute bug fix and enhancement update 2017-08-01 14:40:13 EDT

  None (edit)
Description Hubert Kario 2014-02-11 11:21:44 EST
Description of problem:
When there's a sctp server running on system, `ss` doesn't list it in its output.
Trying to specify `sctp` protocol explicitly also fails.

Version-Release number of selected component (if applicable):
iproute-3.10.0-11.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. modprobe sctp; yum install -y lksctp-tools
2. sctp_darn -H 0 -P 2500 -l
3. ss -an | grep 2500

4. ss -n -A sctp

Actual results:
*no output*

and for 4.:
ss: "sctp" is illegal socket table id

Expected results:
Infor about server running on port 2500

Additional info:
# netstat -na | grep 2500
sctp                0.0.0.0:2500                                    LISTEN
Comment 1 Petr Šabata 2014-02-18 09:10:50 EST
`ss' currently doesn't support SCTP at all.  Marking as FutureFeature.
Comment 5 Petr Šabata 2014-07-23 06:08:36 EDT
There's a usable procfs interface.  Requesting devel ack.
Comment 16 Phil Sutter 2016-01-21 10:59:22 EST
Discussion regarding sctp_diag kernel interface has started already, so it should be possible to accomplish this for RHEL7.3.
Comment 21 Phil Sutter 2016-07-29 18:30:52 EDT
Patch series implementing sctp_diag support in 'ss' has been sent upstream:

http://marc.info/?l=linux-netdev&m=146983127501267&w=2

Please note though that it requires a few kernel changes for full functionality, tracked in Bug 1361728.
Comment 22 Phil Sutter 2016-09-05 16:13:13 EDT
Sadly, upstream has not accepted the submitted patch yet, which is why this ticket was left untouched for so long. On the other hand, it is not a good idea to import a large change like this one at this point, especially since it didn't see any upstream testing at all yet.
Comment 24 Phil Sutter 2016-12-02 02:46:40 EST
Finally, upstream accepted my patches:

commit 5dec02d7b4b70128a661bab1ff991c605ba28b3f
Author: Phil Sutter <phil@nwl.cc>
Date:   Wed Nov 9 12:12:23 2016 +0100

    include: Add linux/sctp.h
    
    Add sanitized UAPI linux/sctp.h header file.
    
    Signed-off-by: Phil Sutter <phil@nwl.cc>

commit f89d46ad63f6f606f777da964205bc53b2197cfa
Author: Phil Sutter <phil@nwl.cc>
Date:   Wed Nov 9 12:12:24 2016 +0100

    ss: Add support for SCTP protocol
    
    This makes use of the sctp_diag interface recently added to the kernel.
    
    Joint work with Xin Long who provided the PoC implementation which I
    merely polished up a bit.
    
    Signed-off-by: Phil Sutter <phil@nwl.cc>
Comment 27 Jaroslav Aster 2017-03-06 07:53:51 EST
Hi Phil,

I found one, simple, documentation issue. There is no mention about sctp in -A option in ss man-page and ss help, where all socket types are listed. I think, it should be there. Would be possible to fix it?
Comment 28 Phil Sutter 2017-03-09 11:21:15 EST
Hi Jaroslav,

(In reply to Jaroslav Aster from comment #27)
> I found one, simple, documentation issue. There is no mention about sctp in
> -A option in ss man-page and ss help, where all socket types are listed. I
> think, it should be there. Would be possible to fix it?

Good catch, thanks! I've quickly prepared a patch for upstream and submitted
it:

http://marc.info/?l=linux-netdev&m=148907572801154&w=2

Thanks, Phil
Comment 34 errata-xmlrpc 2017-08-01 17:32:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2171
Comment 35 Christian Kujau 2018-06-11 14:07:14 EDT
Arrived here because of bug 1544898 ("ss indiscriminately loads sctp kernel modules") - does anyone know why the latter is locked?

Note You need to log in before you can comment on or make changes to this bug.