Bug 1064106 - Copy Trans times out with large enough documents
Copy Trans times out with large enough documents
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-CopyTrans (Show other bugs)
3.2
Unspecified Unspecified
high Severity high
: ---
: 3.3
Assigned To: Carlos Munoz
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-11 21:58 EST by Carlos Munoz
Modified: 2014-03-20 01:47 EDT (History)
5 users (show)

See Also:
Fixed In Version: 3.3.0-SNAPSHOT (20140218-0947)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-20 01:47:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Munoz 2014-02-11 21:58:48 EST
Description of problem:
When running copy trans against a large document, it is possible that the process will fail due to a transaction timeout error.

Version-Release number of selected component (if applicable):
3.2.x

How reproducible:
Sometimes - If the document is large enough.

Steps to Reproduce:
1. Upload or push a large document.
2. Run copy trans on the version (UI), or let the client run copy trans.

Actual results:
If the document is large enough, it will fail due to a transaction timeout.

Expected results:
Copy trans finishes successfully.
Comment 1 Carlos Munoz 2014-02-11 22:17:39 EST
Made copy trans operate on batches so that even large documents are handled properly. There is still very small possibility of a batch taking way too long and timing out the transaction, but it is very low.

See:
https://github.com/zanata/zanata-server/pull/372
Comment 2 Damian Jansen 2014-02-17 21:30:32 EST
43 minutes in and still going (ETA 1 day, 6 hours, 23 mins)

Verified at 1bf60cc19d6941929f586c3e8d62390fbb41644d
Comment 7 Sean Flanigan 2014-03-20 01:47:43 EDT
Closing VERIFIED bugs for Zanata server 3.3.2.

Note You need to log in before you can comment on or make changes to this bug.