Bug 1064227 - task list in Webadmin - jobs disappear while still running
Summary: task list in Webadmin - jobs disappear while still running
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Oved Ourfali
QA Contact: movciari
URL:
Whiteboard: infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-12 09:27 UTC by Oved Ourfali
Modified: 2014-03-31 12:29 UTC (History)
5 users (show)

Fixed In Version: ovirt-3.4.0-beta3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:29:01 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24361 None None None Never
oVirt gerrit 26056 None NEW core: task list in Webadmin - jobs disappear while still running Never

Description Oved Ourfali 2014-02-12 09:27:25 UTC
Description of problem:
Some jobs are being removed from the task list after a few minutes, even while the are still running.

Version-Release number of selected component (if applicable):
3.4 Beta

How reproducible:
Always

Steps to Reproduce:
1. Run a long job with more than one step, one should be async step
2. Monitor the task list

Actual results:
The job is deleted after a few minutes

Expected results:
The job should stay there until it is completed

Additional info:
I debugged the issue and it turns out that the stored procedure that removes jobs periodically, removes jobs that has steps that don't have an async task behind them, instead of removing only jobs that don't have ANY step that doesn't have an async task behine it.

Comment 1 Sandro Bonazzola 2014-02-19 12:26:29 UTC
This bug is referenced in ovirt-engine-3.4.0-beta3 logs. Moving to ON_QA

Comment 2 Sandro Bonazzola 2014-03-31 12:29:01 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.