Bug 106429 - nvidia module oopses kernel 2.6
nvidia module oopses kernel 2.6
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-06 21:23 EDT by Lars G
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars G 2003-10-06 21:23:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030925
Firebird/0.7

Description of problem:
when loading nvidia.ko driver module kernel-2.6.0-0.test6.1.49 oopses with

---------------------------------------------------------------------------------------------
Oct  7 00:31:01 myhost kernel: 0: nvidia: loading NVIDIA Linux x86 nvidia.o
Kernel Module  1.0-4496  Wed Jul 16 19:03:09 PDT 2003
Oct  7 00:31:01 myhost kernel: Unable to handle kernel paging request at virtual
address 69746e65
Oct  7 00:31:01 myhost kernel:  printing eip:
Oct  7 00:31:01 myhost kernel: f9d81c01
Oct  7 00:31:01 myhost kernel: *pde = 00000000
Oct  7 00:31:01 myhost kernel: Oops: 0000 [#1]
Oct  7 00:31:01 myhost kernel: CPU:    0
Oct  7 00:31:01 myhost kernel: EIP:    0060:[<f9d81c01>]    Tainted: P
Oct  7 00:31:01 myhost kernel: EFLAGS: 00010246
Oct  7 00:31:01 myhost kernel: EIP is at os_mem_cmp+0x11/0x30 [nvidia]
Oct  7 00:31:01 myhost kernel: eax: f6fddf5c   ebx: c02d3350   ecx: 444d4163  
edx: 69746e65
Oct  7 00:31:01 myhost kernel: esi: f6fddf5c   edi: 69746e65   ebp: f6fddf6c  
esp: f6fddf3c
Oct  7 00:31:02 myhost kernel: ds: 007b   es: 007b   ss: 0068
Oct  7 00:31:02 myhost kernel: Process modprobe (pid: 1296, threadinfo=f6fdc000
task=f76c12b0)
Oct  7 00:31:02 myhost kernel: Stack: f9ddaf80 00000001 f9c58e39 f6fddf5c
f9d882e0 0000000c f771c38b 00000001
Oct  7 00:31:02 myhost kernel:        68747541 69746e65 444d4163 c0133be9
f6fddf74 f9c58e90 f6fddf7c f9c5afd8
Oct  7 00:31:02 myhost kernel:        c02d3338 f98830d8 00000000 f9d975c0
000000c3 f9a74000 4015d008 c02d3350 
Oct  7 00:31:02 myhost kernel: Call Trace:
Oct  7 00:31:02 myhost kernel:  [<f9c58e39>] __nvsym00760+0x49/0x98 [nvidia]
Oct  7 00:31:02 myhost kernel:  [<c0133be9>] pm_register+0x29/0xa0
Oct  7 00:31:02 myhost kernel:  [<f9c58e90>] __nvsym00763+0x8/0x50 [nvidia]
Oct  7 00:31:02 myhost kernel:  [<f9c5afd8>] rm_init_rm+0x8/0xc [nvidia]
Oct  7 00:31:02 myhost kernel:  [<f98830d8>] nvidia_init_module+0xd8/0x178 [nvidia]
Oct  7 00:31:02 myhost kernel:  [<c0132714>] sys_init_module+0xe4/0x1f0
Oct  7 00:31:02 myhost kernel:  [<c010adb7>] syscall_call+0x7/0xb
Oct  7 00:31:02 myhost kernel:
Oct  7 00:31:02 myhost kernel: Code: f3 a6 8b 34 24 8b 7c 24 04 0f 97 c0 0f 92
c2 83 c4 08 28 d0
---------------------------------------------------------------------------------------------

vanilla kernel 2.6-test6-bk8 works fine.
so maybe its something with the redhat specific patches




Version-Release number of selected component (if applicable):
kernel-2.6.0-0.test6.1.49

How reproducible:
Always

Steps to Reproduce:
1. compile kernel sources
2. install nvidia driver with patches for 2.6 from minion.de
3. 
    

Actual Results:  kernel oops


Expected Results:  no oops

Additional info:
Comment 1 Arjan van de Ven 2003-10-07 03:44:00 EDT

*** This bug has been marked as a duplicate of 73733 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:59 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.