Bug 106433 - RFE: support for "RESTRICTED" WEP keyword
RFE: support for "RESTRICTED" WEP keyword
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: 87718
  Show dependency treegraph
 
Reported: 2003-10-06 21:51 EDT by Steve Ward
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-13 06:14:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Ward 2003-10-06 21:51:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031003

Description of problem:
Currently the GUI tool does not support "shared key" configurations for 802.11b
networks.

It is possible to enter the appropriate values in the sysconfig area and have
the appropriate action taken.  It does not appear possible to make the GUI tool
accept this format.

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.6-1

How reproducible:
Always

Steps to Reproduce:
Try to configure a WLAN card to run on a "shared key only" AP.
    

Actual Results:  only generates appropriate script for use on "public" AP.

Expected Results:  Should generate script usable to configure "shared key"
encryption

Additional info:
Comment 1 Daniel L. Rall 2006-11-14 17:39:52 EST
Unbelievable.  I just spent COUNTLESS HOURS looking for a way to establish a
connection to my base station (which is configured to use Shared WEP key).  I
finally stumbled upon a web page
<http://www.cs.cornell.edu/~scs49/install_linux.html> which pointed to this
ancient post
<http://www.redhat.com/archives/rhl-beta-list/2003-July/msg00848.html>
containing the configuration information I needed to get Shared WEP working.

Please either fix the UI of system-config-network to support this option, or
discontinue its use in favor of something like NetworkManager
<http://www.gnome.org/projects/NetworkManager/> (which already seems to ship
with FC5).
Comment 2 Igor Jagec 2006-11-16 05:10:04 EST
Thanks Daniel, it works. I can't wait to see some enhanced network managment 
tool because system-config-network really lack for some important features.

Note You need to log in before you can comment on or make changes to this bug.