Bug 106441 - No Paste menu option in context menu
No Paste menu option in context menu
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
http://bugzilla.gnome.org/show_bug.cg...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-07 00:11 EDT by Behdad Esfahbod
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 13:40:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Behdad Esfahbod 2003-10-07 00:11:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/1.0

Description of problem:
Just select and copy some text, in another application, then right click on an
input box in a form in epiphany (not address bar), as you can see there's no
Paste option!  But now press shift-insert, the text would be pasted.  It's quite
confusing.

Moreover:

Select some text in a page in epiphany, copy it by ctrl+insert, then
paste it in a text box in the same page by pressing shift+insert, it
works.  Now select some other text in the same page by RIGHT-CLICK and
selecting COPY, now try pasting it in the text box in the same page by
pressing shift+insert, you get the old text pasted!!  So
right-click->copy is not doing anything.  (Well, the addressbar works,
as it's a simple gtk widget).

I don't know if the same problem is in mozilla too.

Upstream bug in bugzilla.gnome.org:
http://bugzilla.gnome.org/show_bug.cgi?id=123993



Version-Release number of selected component (if applicable):
epiphany-1.0-1

How reproducible:
Always

Steps to Reproduce:
1. See the bug text.
2.
3.
    

Additional info:
Comment 1 Christopher Blizzard 2003-10-09 13:40:17 EDT
Looks like this was fixed in galeon head, but I'm not going to back-port it.
Comment 2 Behdad Esfahbod 2003-10-09 16:07:44 EDT
I assume you mean epiphany, not galeon.  Yeah?
Comment 3 Christopher Blizzard 2003-10-09 16:42:20 EDT
Woops, yes.  "What I meant, not what I said."  :)

Note You need to log in before you can comment on or make changes to this bug.