Bug 1064550 - update of python-boto breaks euca2ools
update of python-boto breaks euca2ools
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-boto (Show other bugs)
el6
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Garrett Holmstrom
Fedora Extras Quality Assurance
:
: 1067546 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-12 15:02 EST by Lukas Bezdicka
Modified: 2014-03-06 16:06 EST (History)
5 users (show)

See Also:
Fixed In Version: python-boto-2.25.0-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-16 06:18:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Bezdicka 2014-02-12 15:02:01 EST
Description of problem:
With new python-boto euca2ools fail with should be of type string errors.

Version-Release number of selected component (if applicable):
python-boto-2.23.0-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. update python-boto
2. run euca-describe-images -o <awsid>
3. fail

Actual results:
fail

Expected results:
it should work fine

Additional info:
This patch fixes the issue:
https://github.com/boto/boto/pull/2094
Comment 1 Fedora Update System 2014-02-12 17:35:58 EST
python-boto-2.25.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/FEDORA-2014-2310/python-boto-2.25.0-2.fc20
Comment 2 Fedora Update System 2014-02-12 17:36:20 EST
python-boto-2.25.0-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2014-2255/python-boto-2.25.0-2.fc19
Comment 3 Fedora Update System 2014-02-12 17:36:55 EST
python-boto-2.25.0-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0516/python-boto-2.25.0-2.el6
Comment 4 Fedora Update System 2014-02-12 17:37:06 EST
python26-boto-2.25.0-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0504/python26-boto-2.25.0-2.el5
Comment 5 Fedora Update System 2014-02-16 06:18:54 EST
python-boto-2.25.0-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Attila Fazekas 2014-02-20 16:49:32 EST
*** Bug 1067546 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2014-02-22 13:07:39 EST
python-boto-2.25.0-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2014-02-22 13:17:51 EST
python-boto-2.25.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2014-03-06 16:06:36 EST
python26-boto-2.25.0-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.