Bug 1064628 - In Editor's Document list View, statistics are not updated immediately
Summary: In Editor's Document list View, statistics are not updated immediately
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Component-Logic   
(Show other bugs)
Version: development
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ---
: 3.3
Assignee: Alex Eng
QA Contact: Zanata-QA Mailling List
URL:
Whiteboard:
Keywords:
: 1056893 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 01:47 UTC by Ding-Yi Chen
Modified: 2014-03-20 05:47 UTC (History)
5 users (show)

Fixed In Version: 3.3.0-SNAPSHOT (20140214-1347)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-20 05:47:11 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1056893 None None None Never

Internal Trackers: 1056893

Description Ding-Yi Chen 2014-02-13 01:47:37 UTC
Description of problem:

After you complete translated, the statistics in document list view have not update.

Step to reproduce:
1. Complete translated a project (or find a project that fully translated)
2. Clear a translation
3. Retranslate the cleared translation to make the translation 100% Completed again
4. Click Documents (LOCALE) to go to document list view

Actural:
On the statistics of document list shows 99%(0.12hrs) Words
Clicking the stats by Messages did not change either the percentage,
nor the unit of translation (Message)

Expected:
On the statistics of document list should show 100%(0.0hrs) Words
Clicking the stats by Messages should change both the percentage (if applicable),
and unit of translation (Message)

Version-Release number of selected component (if applicable):
Zanata 3.3.0-SNAPSHOT (20140213-0020)
commit d4627b2ebb39f845d


How reproducible:
Always

Step to reproduce:
1. Complete translated a project (or find a project that fully translated)
2. Clear a translation
3. Retranslate the cleared translation to make the translation 100% Completed again
4. Click Documents (LOCALE) to go to document list view

Actural results:
On the statistics of document list shows 99%(0.12hrs) Words
Clicking the stats by Messages did not change either the percentage,
nor the unit of translation (Message)

Expected results:
On the statistics of document list should show 100%(0.0hrs) Words
Clicking the stats by Messages should change both the percentage (if applicable),
and unit of translation (Message)

Additional info:

Comment 1 Sean Flanigan 2014-02-13 06:32:11 UTC
Do the stats fix themselves on F5?

Comment 2 Alex Eng 2014-02-13 22:14:23 UTC
F5 will fix the problem. The issue here is the live update of project statistic as translation are being done.

Comment 3 Alex Eng 2014-02-13 23:02:42 UTC
Pull request:
https://github.com/zanata/zanata-server/pull/375

Comment 4 Ding-Yi Chen 2014-02-13 23:58:12 UTC
Yes, reload with Ctrl-R and F5 does update the stats correctly.

Comment 5 Damian Jansen 2014-02-14 05:50:03 UTC
Verified at 9c46eb0cc798a1883e066057221a503690c6c6a2

Comment 6 Damian Jansen 2014-02-19 01:57:03 UTC
*** Bug 1056893 has been marked as a duplicate of this bug. ***

Comment 7 Sean Flanigan 2014-03-20 05:47:11 UTC
Closing VERIFIED bugs for Zanata server 3.3.2.


Note You need to log in before you can comment on or make changes to this bug.