Bug 106470 - Kernel OOPS with gdth module
Summary: Kernel OOPS with gdth module
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 2.1
Hardware: i686 Linux
high
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-07 14:04 UTC by Achim Leubner
Modified: 2007-11-30 22:06 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-07 14:06:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Achim Leubner 2003-10-07 14:04:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
On a dual processor machine with Intel Integrated RAID controller using Red 
Hat Enterprise 3.0 Public Beta with the "gdth" module loaded, I get 
segmentation fault during:
1. Shutdown/halt or "rmmod gdth"(basically calling gdth_flush())
2. Accessing the "gdth" information from the /proc filesystem, with 
say "cat /proc/scsi/gdth/0".

The problem was already reported in bug #66867, but it occurs again in this 
kernel version.


Version-Release number of selected component (if applicable):
kernel-2.4.21-1.1931.2.399.entsmp

How reproducible:
Always

Steps to Reproduce:
1. Install operating system with an Intel Integrated RAID controller
2. Access controller information from /proc, i.e. "cat /proc/scsi/gdth/0".
3.
    

Actual Results:  Kernel OOPS.

Expected Results:  Displaying controller information.

Additional info:

It's a problem in scsi_get_host_dev(). See bug #66867 for a detailed 
description.

Comment 1 Arjan van de Ven 2003-10-07 14:06:31 UTC
this is the forth dupe of this


Note You need to log in before you can comment on or make changes to this bug.