Bug 1064717 - Gnome-Software app is almost useless - as replacement for packagekit UI
Summary: Gnome-Software app is almost useless - as replacement for packagekit UI
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-13 07:12 UTC by abyss.7
Modified: 2014-08-07 14:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-07 14:07:12 UTC


Attachments (Terms of Use)

Description abyss.7 2014-02-13 07:12:11 UTC
1. It doesn't allow to install custom package, e.g. the package 'dnf' isn't found with Software.

2. It doesn't do updates for a weeks, while the `yum check-update` definitely shows there is something to update.

3. It always requires rebooting despite the updated packages - even Windows doesn't do that nowadays(?)

Can this app be replaced - as default - by the previous front-end for PackageKit?

Comment 1 Thomas L. Shinnick 2014-02-26 02:35:29 UTC
My example is the more capable command-line vim editor package, vim-enhanced.  How does one use the default and *only* GUI 'software' tool installed in Fedora 20 to get this particular package installed?

gnome-software offers only one 'Vim', and entirely without any hints as to what that will give you.  Installing it apparently gives you the GTK Xwindows version.

Oh, and along with the happy-horseshit "we're all up-to-date" right after install of a 3 month old Fedora release!  Oh, yeah, confidence builder right there!  (yum update found 1056 somethings to update, huh!)

How did the community allow a fundamental capability like GUI-based package management to be so disabled?  Along with (as I searched for WTF is going on?) murmurings of "we don't need that steenking yum thing".  

You have put the 'danger' back into Fedora's reputation.  At this point I don't know how I could recommend it to even bleeding edge developers.  And I've been recommending Fedora since y'all forced me off RedHat Linux.  I am hugely dismayed at this.

Comment 2 Adam Williamson 2014-08-07 14:07:12 UTC
Thanks for the report!

GNOME Software has a specific scope: it's designed to be a tool for installing graphical applications. It's not intended as a general-purpose graphical package manager for all package management use cases.

All the specific issues reported here are basically as designed:

1. dnf is not a graphical application, it's not the sort of thing Software is designed to work with. It's intentional that Software does not offer it.

2. This again is intentional; it will offer security updates immediately, but it's intentionally scheduled to check for and offer non-security updates at relatively infrequent intervals, the idea being you don't have to deal with constant notifications and changes and reboots, but you just get the updates 'grouped' every week or so.

3. This isn't exactly intentional, but it's a known issue that isn't trivial to fix. It's almost impossible to reliably know which updates actually require the system to be restarted at present, so Software errs strongly on the side of caution. The long term plan to fix this requires various other bits of functionality to be implemented so Software can know pretty reliably when a reboot is not required; that's being worked on already, and doesn't need a bug report in downstream Fedora.

So the high level answer here is that Software isn't the thing you want to use; it's not designed for you. We don't claim that Software covers all use cases, and Fedora certainly contains other both graphical and non-graphical package managers - obviously you can use yum and dnf from the console, and a graphical tool that's more designed for this kind of use case would be yumex, for example.


Note You need to log in before you can comment on or make changes to this bug.