Bug 106489 - LTC4790-IPV6 scope address incorrectly generated
LTC4790-IPV6 scope address incorrectly generated
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
s390 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-07 14:16 EDT by Jeffrey Bisti
Modified: 2007-11-30 17:06 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:34:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Bisti 2003-10-07 14:16:00 EDT
The following has be reported by IBM LTC:  
IPV6 scope address incorrectly generated
Hardware Environment:
z/990

Software Environment:
31 and 64 bit rhel3 as vm guests

Steps to Reproduce:
1. insmod ipv6
2. ifconfig eth36

Actual Results:
eth36     Link encap:Ethernet  HWaddr 00:02:55:09:E7:D9
          inet addr:9.12.21.174  Bcast:9.12.21.255  Mask:255.255.255.0
  ---->   inet6 addr: fe80::202:55ff:fe09:e7d9/64 Scope:Link
          UP BROADCAST RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:3417 errors:0 dropped:0 overruns:0 frame:0
          TX packets:264 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:356200 (347.8 Kb)  TX bytes:26599 (25.9 Kb)
          Interrupt:16


Expected Results:
      something like:           vv vv 
          inet6 addr: fe80::2:5500:2109:e7d9/64 Scope:Link
          or                    vv vv 
          inet6 addr: fe80::2:5500:7a09:e7d9/64 Scope:Link                     

Additional Information:
 The unique identifier that gets passed from the osa isn't being incorporated
into the ipv6 address. The address should be something like fe80::2:55[unique
id]09:e7d9/64. Also, it looks like the mac address isn't being read into the
address correctly (fe80::202:55... being generated instead of fe80::2:55...). 

IPv6 addresses that are configured onto the interface do not seem to take
effect. I cannot reach the system on any IPv6 addresses, configured or
autoconfigured, while I am able to communicate over IPv6 interfaces on non-rhel
systems.
Comment 1 Phil Knirsch 2003-10-17 04:44:26 EDT
Is this by chance a qeth interface? If so, then it most likely doesn't work
because we had to disable the IPV6 feature in the qeth driver as the driver used
kernel_symbols which were not exported.

Read ya, Phil
Comment 2 Jeffrey Bisti 2003-10-17 10:20:48 EDT
Yes it is a qdio interface. 
Comment 3 Bill Goodrich 2003-10-28 17:25:52 EST
Subject: [Bug 4790]  - RH106489  IPV6 scope address incorrectly generated
Importance: normal
References: <4790.bugzilla@linux.ibm.com>
In-Reply-To: <4790.bugzilla@linux.ibm.com>
X-Bugzilla-Reason: AssignedTo QAcontact
X-Bugzilla-Family: zSeries Development
Message-Id: <20031010131541.9E0FC93B68@smtp.linux.ibm.com>
Date: Fri, 10 Oct 2003 09:15:41 -0400 (EDT)

Do not reply to this note.  It was sent by a machine.  Instead append your
comments to the bug at the URL below.

https://bugzilla.linux.ibm.com/show_bug.cgi?id=4790


jbisti@us.ibm.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|IPV6 scope address          |RH106489  IPV6 scope address
                   |incorrectly generated       |incorrectly generated 
Comment 4 Phil Knirsch 2004-04-22 09:35:53 EDT
Have you given the latest kernel a try? It has updated qeth drivers
which might contain a fix for the problem you reported.

Read ya, Phil
Comment 5 Bob Johnson 2004-08-11 15:45:50 EDT
Need info, IBM can you test ?
Comment 6 Bob Johnson 2004-08-22 21:13:06 EDT
Been in IBM's court since 4/22. Bill, Ingolf, can you provide some
assitance here ?
Comment 7 Helen Fischer 2004-08-23 09:53:03 EDT
I tried this again on and received the same results:

kernel level:  2.4.21-18.EL

Results of ifconfig:
eth1      Link encap:Ethernet  HWaddr 00:04:AC:7C:AA:CA
          inet addr:192.168.70.40  Bcast:192.168.70.255   
Mask:255.255.255.0
          inet6 addr: fe80::204:acff:fe7c:aaca/64 Scope:Link
          UP BROADCAST RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:1520 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:118506 (115.7 Kb)  TX bytes:1120 (1.0 Kb)
          Interrupt:29
Comment 8 IBM Bug Proxy 2004-09-26 20:15:43 EDT
----- Additional Comments From fischerh@us.ibm.com  2004-09-26 20:14 EDT -------
I tried this on RHEL4 - beta 1.  The IPV6 link address is not generated 
correctly .  In addition, we are unable to run IPV6 traffic over qeth devices. 
Kernel level is 2.6.8-1.528.2.5.  

eth0      Link encap:Ethernet  HWaddr 00:09:6B:1A:00:C7
          inet addr:192.168.70.144  Bcast:192.168.70.255  Mask:255.255.255.0
          inet6 addr: fe80::209:6bff:fe1a:c7/64 Scope:Link 
Comment 9 Oliver Paukstadt 2004-10-26 11:58:29 EDT
Same problem here.
We are not able to run ipv6 over vswitch.
q lan detail shows no ipv6 addresses registered with that guest.
ipv4 adresses are shown (and work) and ipv6 works if we use other
enterprise distributions.
kernel is 2.4.21-20.EL.
Comment 10 Pete Zaitcev 2005-05-13 13:56:49 EDT
As far as I know, IPv6 is not supported on qeth in RHEL 3.
Even if we manage to get addresses generated right, it won't
exchange packets correctly. Jan, do you have a comment?

Please do not mix the RHEL 4 into this bug.
Comment 11 RHEL Product and Program Management 2007-10-19 15:34:17 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.