Bug 1065401 - [RHEVH] [TUI] TUI displays column "Manged by:" incorrectly
Summary: [RHEVH] [TUI] TUI displays column "Manged by:" incorrectly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-vdsm
Version: 3.3.0
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
: 3.5.2
Assignee: Douglas Schilling Landgraf
QA Contact: Jiri Belka
URL:
Whiteboard: node
Depends On:
Blocks: 1184995
TreeView+ depends on / blocked
 
Reported: 2014-02-14 15:11 UTC by Martin Pavlik
Modified: 2016-02-10 20:05 UTC (History)
12 users (show)

Fixed In Version: ovirt-node-plugin-vdsm-0.1.1-15.el6ev
Doc Type: Bug Fix
Doc Text:
Previously, the "Managed by" column displayed the Manager URL incorrectly in the Red Hat Enterprise Virtualization Hypervisor user interface. Now, the system recognizes and correctly displays the protocol used during the registration (http or https), and does not display a URL and PORT if the data is not available.
Clone Of:
Environment:
Last Closed: 2015-02-26 15:34:01 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
screenshot 1 (255.89 KB, image/png)
2014-02-14 15:11 UTC, Martin Pavlik
no flags Details
logs (424.36 KB, application/x-compressed-tar)
2014-02-14 15:12 UTC, Martin Pavlik
no flags Details
log_collector (12.36 MB, application/x-xz)
2014-02-14 15:16 UTC, Martin Pavlik
no flags Details
rhevh-3.5 (57.93 KB, image/png)
2015-02-26 14:52 UTC, Martin Pavlik
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 26410 0 None None None Never
oVirt gerrit 31483 0 master MERGED init: Split management_server if user used "addr:port" Never
oVirt gerrit 33352 0 node-3.0 ABANDONED init: Split management_server if user used "addr:port" Never

Description Martin Pavlik 2014-02-14 15:11:30 UTC
Created attachment 863311 [details]
screenshot 1

Description of problem:
TUI displays column "Manged by:" incorrectly (see screenshot 1)

there is multiple problems with display of column managed by in TUI

TUI shows: Managed by: oVirt engine http://mp-rhevm33.rhev.lab.eng.brq.redhat.com:None

Problem 1) host is added into over secure connection 

so it should be displayed as 
https://mp-rhevm33.rhev.lab.eng.brq.redhat.com 
not 
http://mp-rhevm33.rhev.lab.eng.brq.redhat.com


2) there is suffix :None in the end of the URL
either there should be no suffix or it should be filled with something meaningful like port number 

e.g. https://mp-rhevm33.rhev.lab.eng.brq.redhat.com:443

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Hypervisor release 6.5 (20140213.0.el6ev)

How reproducible:
100%

Steps to Reproduce:
1. install RHEVH (I used PXE install)
2. add rhevh to RHEVM
3. connect to rhevh TUI

Actual results:
see descrtiption

Expected results:
see descrtiption

Additional info:

[root@dell-r210ii-06 ~]# cat /etc/vdsm/vdsm.conf
[addresses]
management_port = 54321

[vars]
ssl = true

Comment 1 Martin Pavlik 2014-02-14 15:12:40 UTC
Created attachment 863314 [details]
logs

Comment 2 Martin Pavlik 2014-02-14 15:16:21 UTC
Created attachment 863315 [details]
log_collector

Comment 3 Douglas Schilling Landgraf 2014-04-03 16:20:41 UTC
(In reply to Martin Pavlik from comment #0)
> Created attachment 863311 [details]
> screenshot 1
> 
> Description of problem:
> TUI displays column "Manged by:" incorrectly (see screenshot 1)
> 
> there is multiple problems with display of column managed by in TUI
> 
> TUI shows: Managed by: oVirt engine
> http://mp-rhevm33.rhev.lab.eng.brq.redhat.com:None
> 
> Problem 1) host is added into over secure connection 
> 
> so it should be displayed as 
> https://mp-rhevm33.rhev.lab.eng.brq.redhat.com 
> not 
> http://mp-rhevm33.rhev.lab.eng.brq.redhat.com
> 

Ok, attached patch.

> 
> 2) there is suffix :None in the end of the URL
> either there should be no suffix or it should be filled with something
> meaningful like port number 
> 
> e.g. https://mp-rhevm33.rhev.lab.eng.brq.redhat.com:443
> 

We already fixed that one in another patch/bugzilla:
https://bugzilla.redhat.com/show_bug.cgi?id=1057453
http://gerrit.ovirt.org/#/c/24421/

Comment 4 Jiri Belka 2014-05-14 12:06:02 UTC
fail ovirt-node-plugin-vdsm-0.1.1-19.el6ev.noarch/Red Hat Enterprise Virtualization Hypervisor release 6.5 (20140513.0.el6ev)

I still see plaintext http in Status tab:

Managed by:  oVirt Engine                               
http://jb-rhevm34.rhev.lab.eng.brq.redhat.com

Comment 5 Jiri Belka 2014-05-14 12:06:50 UTC
The host was added into RHEVM via 'management_server' kernel option for PXE installation.

Comment 6 Fabian Deutsch 2014-05-14 12:15:06 UTC
Bug 1088875 is possibly a dupe of this bug.

Comment 7 Einav Cohen 2014-06-02 17:36:03 UTC
removing UserExperience Keyword - no user experience design advice is needed here, this is just a bug in the displayed data.

Comment 8 Douglas Schilling Landgraf 2014-06-03 07:20:38 UTC
Hi Fabian,

As we talked, can you please double check if node is not splitting such info when we provide management_server=IP_ADDRESS:PORT during autoinstall?

Comment 10 Fabian Deutsch 2014-06-29 10:14:56 UTC
Douglas, can you remember how and where the management_server variable is read from the cmdline and saved somewhere?

Comment 11 Douglas Schilling Landgraf 2014-07-01 20:47:59 UTC
Howdy Fabian,

(In reply to Fabian Deutsch from comment #10)
> Douglas, can you remember how and where the management_server variable is
> read from the cmdline and saved somewhere?

From my findings:

scripts/ovirt-init-functions.sh.in I do believe it will read: /etc/ovirt-commandline.d/vdsm-reg 

<snip>
           # check the params to be ignored before adding to bootparams
            varname=${i%=*}
            if ! grep -qw $varname /etc/ovirt-commandline.d/* 2>/dev/null; then
                bootparams="$bootparams $i"
            else
                i=${i#$varname=}
                eval $varname=$i
                plugin_vars="$plugin_vars $varname"
            fi
</snip>

Then:
=========
 log "Updating $OVIRT_DEFAULTS"
    tmpaug=$(mktemp)
    for p in $params $plugin_vars; do
        PARAM=$(uc $p)
        value=$(ptr $p)
        if [ -n "$value" -o $p = 'init' -o $p = 'upgrade' -o $p = 'install' ]; then
            log "Updating OVIRT_$PARAM to '$value'"
            echo "set /files$OVIRT_DEFAULTS/OVIRT_$PARAM '\"$value\"'" \
                >> $tmpaug
        fi
    done 

ovirt.log shows:
================
<snip>
Updating /etc/default/ovirt
Updating OVIRT_BOOTIF to 'eth0'
Updating OVIRT_INIT to '/dev/sda'
..
OVIRT_MANAGEMENT_SERVER to '192.168.100.228:8080'
<snip> 

To summary, if user uses in the autoinstall the format IP:PORT as showed above we won't split OVIRT_MANAGEMENT_SERVER and the OVIRT_MANAGEMENT_PORT won't be set. TUI will show server as '192.168.100.228:8080'. Does it make sense?

Thanks!

Comment 12 Douglas Schilling Landgraf 2014-09-10 14:13:29 UTC
Moving to assigned since the patch must be moved to a different part of source.

Comment 13 Douglas Schilling Landgraf 2014-09-24 19:57:51 UTC
Hi,

Moving to POST as this patch is available in 3.5 and master branches. For patching node-3.0 branch requires the 3.4.z flag (patch also ready - gerrit 33352).

Comment 16 Fabian Deutsch 2015-02-26 13:13:46 UTC
Does this bug still exist in the 3.5 RHEV-H images?

Comment 17 Martin Pavlik 2015-02-26 14:52:13 UTC
Created attachment 995664 [details]
rhevh-3.5

bug seems to be gone in Red Hat Enterprise Virtualization Hypervisor 7.0 (20150127.0.el7ev)

see attached screenshot

Comment 18 Fabian Deutsch 2015-02-26 15:34:01 UTC
Thanks Martin, closing this according to comment 17


Note You need to log in before you can comment on or make changes to this bug.