Bug 106553 - Mouse scrolling has intermittent problems in Package Group Selection Screen
Mouse scrolling has intermittent problems in Package Group Selection Screen
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Michael Fulbright
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-08 07:40 EDT by Arindam Dey
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-14 17:26:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arindam Dey 2003-10-08 07:40:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
During the installation if we select any of the two categories "Minimal" or
"Everything" under the "Miscellaneous" section in the "Package Group Selection"
screen the mouse scrolling becomes erratic.

Upon deslecting this option and upon selecting individual categories the mouse
scrolling immediately becomes ok. The scrolling also becomes ok if the mouse is
placed over the scroll bar without clicking the mouse button when a category
under "Miscellaneous" is chosen  and then the mouse wheel is scrolled.

My card, mouse etc is detected as follows by Anaconda

Graphics Card - SiS 630
Monitor Type - Unknown - earlier in RH 8 or was it 7.3 it used to detect it as a
ddcprobed monitor.RH 9 onwards this behaviour has changed. ok ok deviating from
the bug sorry..
Mouse Type - Generic - Wheel Mouse ( PS/2 )

Version-Release number of selected component (if applicable):
anaconda-9.0.94-0.2003092219.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1. Start the Fedora install and select all the default options (or any other
options in the screens before "Package Group Selection" it is immaterial) in the
screens till "Package Group Selection".
2. On the "Package Group Selection" screen scroll down to the bottom and select
"Everything" or "Minimal".
3. Try using the wheel of the mouse vigorously.

Actual Results:  On intensive scrolling using the mouse wheel the display inside
the window freezes and the scroll mouse cannot be used remaining functionality
of the mouse is as expected.

Expected Results:  The display should scroll normally as it does when other
categories are selected.

Additional info:

The below mentioned problem may have some significance to the above problem so I
am mentioning it here. The below happened on the exact same hardware setup under
RH8, RH9. Fedora test1 and test2.

During installation mouse is detected as Generic Wheel Mouse (PS/2). Everything
is configured perfectly. After installation GUI comes up and I can login etc.

But after GUI comes up if I go to any console (Ctrl-Alt-F[1-6]) the mouse starts
behaving erratically. Merely attempting to move the mouse causes it to do random
selections on the screen and it pastes the stuff also sometimes as if mouse
wheel is i thnkbeing pressed.

Restarting GPM without changing ANY configs repairs the problem. Switching back
between the graphics and console screen causes the problem to appear again.
Essentially evrytime I come to the console from GUI I have to restart GPM.

I realise that this should be filed as a seperate bug and a reference passed
here but I could not figure out under what I should file this bug. I mean gpm, X
etc. 

If another bug should be filed for this purpose kindly tell me under which
category and I will be glad to do it.

Oh and for X I am using the default sis driver, I have not tampered with the
default XF86Config.
Comment 1 Jeremy Katz 2003-10-14 17:26:18 EDT
This is due to a gtk bug (filed upstream, don't remember the bug number off-hand)

Note You need to log in before you can comment on or make changes to this bug.