Bug 1065629 - [fix available] RTF import probable regression with non-english BigMachines exports
Summary: [fix available] RTF import probable regression with non-english BigMachines e...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice
Version: 6.5
Hardware: x86_64
OS: All
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Michael Stahl
QA Contact: Desktop QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-15 09:23 UTC by Benjamin Masse
Modified: 2015-03-23 01:08 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
RHEL 6.4 CSB
LibreOffice 4.x
BigMachines
Last Closed: 2014-10-14 04:49:57 UTC


Attachments (Terms of Use)
German screenshot (32.13 KB, image/png)
2014-02-15 09:23 UTC, Benjamin Masse
no flags Details
Spanish screenshot (32.64 KB, image/png)
2014-02-15 09:23 UTC, Benjamin Masse
no flags Details
French screenshot (35.36 KB, image/png)
2014-02-15 09:24 UTC, Benjamin Masse
no flags Details
Italian screenshot (29.14 KB, image/png)
2014-02-15 09:25 UTC, Benjamin Masse
no flags Details
UK screenshot (40.22 KB, image/png)
2014-02-15 09:26 UTC, Benjamin Masse
no flags Details
US screenshot (40.49 KB, image/png)
2014-02-15 09:26 UTC, Benjamin Masse
no flags Details
Sample RTF export in French (39.57 KB, application/rtf)
2014-02-15 10:20 UTC, Benjamin Masse
no flags Details
Sample RTF export in UK English (114.71 KB, application/rtf)
2014-02-15 10:38 UTC, Benjamin Masse
no flags Details
Sample RTF export in US English (26.22 KB, application/rtf)
2014-02-15 10:39 UTC, Benjamin Masse
no flags Details
patches that apply on rhel6.5 (23.14 KB, application/gzip)
2014-04-15 12:35 UTC, Michael Stahl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1423 normal SHIPPED_LIVE libreoffice bug fix update 2014-10-14 01:28:46 UTC

Description Benjamin Masse 2014-02-15 09:23:08 UTC
Created attachment 863563 [details]
German screenshot

Description of problem:
RTF exports in non-english languages from CPQ tool BigMachines don't import and display correctly in LibreOffice 4.x when they did correclty in LibreOffice 3.4, see captures in attachment.

Version-Release number of selected component (if applicable):
LibreOffice 4.x

How reproducible:
Everytime a non-english order form or quote form is generated

Steps to Reproduce:
1. Create a quote/order form in BigMachines
2. Select different countries in the drop-down menu under the Proposal Options tab
3. Click the View Editable Form button
4. Open the generated RTF output in LibreOffice 4.x

Actual results:
RH Contact person contact details block display a merged blank block in non-english quote/order forms

Expected results:
RH Contact person contact details displayed correctly, no matter the language.

Additional info:
Tested on RHEL CSB 6.4 with LO rpms, Fedora 20 LO 4.1, Mac OS X LO 4.1 & LO 4.2 with

Comment 1 Benjamin Masse 2014-02-15 09:23:56 UTC
Created attachment 863564 [details]
Spanish screenshot

Comment 2 Benjamin Masse 2014-02-15 09:24:34 UTC
Created attachment 863565 [details]
French screenshot

Comment 3 Benjamin Masse 2014-02-15 09:25:16 UTC
Created attachment 863566 [details]
Italian screenshot

Comment 4 Benjamin Masse 2014-02-15 09:26:13 UTC
Created attachment 863567 [details]
UK screenshot

Comment 5 Benjamin Masse 2014-02-15 09:26:42 UTC
Created attachment 863568 [details]
US screenshot

Comment 7 Benjamin Masse 2014-02-15 10:20:16 UTC
Created attachment 863573 [details]
Sample RTF export in French

Comment 8 Benjamin Masse 2014-02-15 10:38:57 UTC
Created attachment 863575 [details]
Sample RTF export in UK English

Comment 9 Benjamin Masse 2014-02-15 10:39:45 UTC
Created attachment 863576 [details]
Sample RTF export in US English

Comment 10 Michael Stahl 2014-02-18 11:02:57 UTC
so the US and FR documents are written by:
"XMLmind XSL-FO Converter Professional Edition 4.6.1"

whereas the UK one is written by LibreOffice (unknown version)

have submitted a plausible fix for the main problem (missing nested table)
upstream, let's see if Collabora's RTF expert finds it agreeable.

Comment 11 Michael Stahl 2014-03-05 08:59:58 UTC
since i had some time available i did some more investigation of
the attachments, and noticed the following problems:

1. FR: nested table content not imported (main problem)
   
   fixed in upstream master by commits:
   07ef4cf096015f0e427ffd17cd26bb6837e75481
   c8f83ce1dbf5544f6aaa91775db6820a69c3c061

   fixed in upstream 4.2.2.1 release by commits:
   34de0b64b9184a85cd7fb65d0e811b435e90fe24
   c1bbe64bead02e4f525f0fcfe169ab4a54a89fe4

   partially fixed in upstream 4.1.6.1 (content is there but
   the second commit to handle borders is missing) by commit:
   c30a06600a3b002c9eebb819c1b8dcee9d11abe0

2. FR: there is an extra page break at the end of the document

   fixed in upstream master by commit:
   e3f254ab8211fbab7541cde2100a35c875b0c240

   fixed in upstream 4.2.3.1 release by commit:
   153993292cc9f11fed8fcba8de45b0c46d5e0ef2

3. US: PAGEREF field was not properly imported, shows error text

   fixed in upstream master by commit:
   3dc548476c7e88f7a67cc38daf622631a34e34dd

   fixed in upstream 4.2.3.1 release by commit:
   50945ba67bf6dec66b1ed33011316e0fc9197572

4. FR: page footer not properly imported

   was found fixed already in upstream 4.2.0 release, by commit:
   db23f89b76cb61b215bcae5495eadba2b5ceace2

   fixed in upstream 4.1.6.1 release by commit:
   d8a395033c7d0c924ce5898b2e9b301dbde80b44

the fix for the problem 2. appears rather risky to me, and it is just
a minor inconvenience since no data is lost, so i wouldn't put the
fix into RHEL now.

for problems 1./3./4. i've got all fixes backported to the 4.1 branch,
and things appear to be working, so could go into RHEL7, into RHEL6
via re-base or a special build for CSB or whatever.

back-porting to the 4.0.4 release that is currently in RHEL6
requires further investigation.

Comment 12 Michael Stahl 2014-03-05 09:02:13 UTC
i really like bugzilla flags resetting themselves, i really do

Comment 13 RHEL Product and Program Management 2014-03-26 00:12:44 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 15 Michael Stahl 2014-04-15 12:35:17 UTC
Created attachment 886461 [details]
patches that apply on rhel6.5

Comment 18 errata-xmlrpc 2014-10-14 04:49:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1423.html


Note You need to log in before you can comment on or make changes to this bug.