Bug 106569 - Spec file fixes and improvements
Spec file fixes and improvements
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-08 10:21 EDT by Matthias Saou
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-08 17:24:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rhythmbox 0.5.3-3 proposed spec file (3.69 KB, text/plain)
2003-10-08 10:23 EDT, Matthias Saou
no flags Details
rhythmbox 0.5.3-2 to proposed 0.5.3-3 patch (3.30 KB, patch)
2003-10-08 10:24 EDT, Matthias Saou
no flags Details | Diff

  None (edit)
Description Matthias Saou 2003-10-08 10:21:31 EDT
Attached are some fixes and improvements to the spec file for Rhythmbox. Some
things were plain wrong, like the category, the description or the %post
scriptlet not working because of a typo. Some others could be improved, like the
build dependencies (gstreamer, vorbis are clearly needed!) or obsolete things.

I'll attach the new spec file, as well as a diff from the old one for those
interested in seeing the changes in a glance.

I've also added some defines for libid3tag and flac. Those can be removed if
they don't go with the current guidelines.

Version-Release number of selected component :
rhythmbox-0.5.3-2
Comment 1 Matthias Saou 2003-10-08 10:23:14 EDT
Created attachment 95019 [details]
rhythmbox 0.5.3-3 proposed spec file
Comment 2 Matthias Saou 2003-10-08 10:24:19 EDT
Created attachment 95020 [details]
rhythmbox 0.5.3-2 to proposed 0.5.3-3 patch
Comment 3 Jonathan Blandford 2003-10-08 15:28:43 EDT
Mostly reasonable changes, and I'm embarassed about SCHEMES.  I didn't see a
reason to make it ExclusiveArch i386, though.
Comment 4 Matthias Saou 2003-10-08 15:47:06 EDT
I didn't add the ExclusiveArch, it was already there. Maybe something someone
slipped in between 0.5.3-1 (your last %changelog entry) and 0.5.3-2 (the current
rawhide version) without you noticing.
AFAIR, I did get rhythmbox to recompile on ppc just fine, so maybe excluding
explicitely the non-working archs (s390? ia64?) would be better indeed.
Comment 5 Jonathan Blandford 2003-10-08 17:24:54 EDT
Beats me when it was added/removed.  It's not in CVS now, so I'll keep it that
way.  Note that I had to do the libtoolize/aclocal/automake/autoconf dance in
order to get this to build on x86-64.

Note You need to log in before you can comment on or make changes to this bug.