Bug 1065747 - [engine-backend] cannot set domain to maintenance in case there are only unplugged disks located on it
Summary: [engine-backend] cannot set domain to maintenance in case there are only unpl...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Allon Mureinik
QA Contact: Aharon Canan
URL:
Whiteboard: storage
: 969770 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-16 16:29 UTC by Elad
Modified: 2016-02-10 19:16 UTC (History)
6 users (show)

Fixed In Version: ovirt-3.4.0-rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:23:54 UTC
oVirt Team: Storage


Attachments (Terms of Use)
engine.log (614.55 KB, application/x-gzip)
2014-02-16 16:29 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24803 None MERGED core: Disabling an SD with unplugged disk of a VM Never

Description Elad 2014-02-16 16:29:41 UTC
Created attachment 863752 [details]
engine.log

Description of problem:
Engine won't allow to put storage domain to maintenance while having unplugged disks attached to running VMs. We get a CanDoAction failure:

2014-02-16 18:08:37,053 WARN  [org.ovirt.engine.core.bll.storage.DeactivateStorageDomainCommand] (ajp--127.0.0.1-8702-5) [528f48a4] CanDoAction of action DeactivateStorageDomain failed. Reasons:VAR__TYPE__STORAGE_
_DOMAIN,VAR__ACTION__DEACTIVATE,ACTION_TYPE_FAILED_DETECTED_ACTIVE_VMS



Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.7.beta2.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. create a VM with 2 disk attached from 2 different domains and start it
2. deactivate the one of the disks
3. put the domain which the deactivate disk located on to maintenance

Actual results:
Engine blocks the operation with CanDoAction failure even though there are no plugged disks attached to running VMs located on that domain

Expected results:
Engine should allow to put domain to maintenance while there are unplugged disks to running VMs located on it

Additional info:
engine.log

Comment 1 Allon Mureinik 2014-02-17 13:23:00 UTC

*** This bug has been marked as a duplicate of bug 969770 ***

Comment 2 Allon Mureinik 2014-02-26 17:55:31 UTC
*** Bug 969770 has been marked as a duplicate of this bug. ***

Comment 3 Sandro Bonazzola 2014-03-03 14:40:22 UTC
This BZ should be fixed in oVirt 3.4.0 RC

Comment 4 Aharon Canan 2014-03-04 14:30:26 UTC
Verified using 3.4 av2

1. create a VM with 2 disk attached from 2 different domains and start it
2. deactivate the one of the disks
3. put the domain which the deactivate disk located on to maintenance

Comment 5 Sandro Bonazzola 2014-03-31 12:23:54 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.