Bug 106580 - If swap is uninitialised, installer bombs out
If swap is uninitialised, installer bombs out
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-08 11:54 EDT by Graham Leggett
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 17:36:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Graham Leggett 2003-10-08 11:54:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
An attempt was made to transfer a Redhat v9 system from a small drive
to a new bigger drive.

Making this new drive bootable seems to be impossible. Workaround tried: run an
"upgrade" on top of the new drive, which might fix the non existent boot config.

The swap partition is not initialised yet. The installer detects this, and
instead of initialising swap, says "swap is uninitialised, press any key to
reboot" instead.

"Reboot" has to be the dumbest action imaginable at this point. Surely the most
logical course of action is to... um... initialise the swap partition?


Version-Release number of selected component (if applicable):
redhat v9

How reproducible:
Always

Steps to Reproduce:
xxx

Additional info:
Comment 1 Jeremy Katz 2003-10-14 17:25:41 EDT
Initializing it could lead to data corruption if you just have the wrong
partition listed -- rebooting and allowing you to fix up your system to have a
correct fstab is the course of action least likely to have problems.
Comment 2 Graham Leggett 2005-01-24 06:08:48 EST
I have just run into this exact same problem with Fedora Core III, and
yet again I get the message

Error enabling swap device /dev/md3: invalid argument

This most likely means the swap partition cannot be initialised.

Press OK to reboot your system.

Obviously nobody at Redhat actually ever installs Redhat, which leaves
long suffering end users such as myself having to run into stupid
stupid alternate use cases with stupid choices like "reboot". How does
a "reboot" help me fix this problem? It's a brand new virgin system,
what data do I have to lose? Surely *I* as the end user should be
given the choice to reformat the swap filesystem if *I* so choose,
rather than rebooting over and over again every time there is an
error, obviously starting from scratch?

Considering this is the fifth time I've rebooted (LVM in Fedora Core
is entirely non functional, I have since tried to switch it off, but
the system is still screwed), do you honestly think management who are
looking over my shoulder at this system is ever going to consider a
Redhat product if Redhat cannot even get the installer to work properly?

Note You need to log in before you can comment on or make changes to this bug.