Bug 106586 - Wheel mouse scroll up/down generates two X events
Summary: Wheel mouse scroll up/down generates two X events
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-mouse (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-08 18:10 UTC by Raul Acevedo
Modified: 2007-04-18 16:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-10 18:07:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Raul Acevedo 2003-10-08 18:10:07 UTC
Description of problem:
I have a USB wheel mouse that works great, except that wheel up/down generates
TWO X button press/release events, not one.

This means scrolling in Mozilla, gnome-terminal and other applications always
scrolls too much.  In Mozilla, where I have Ctrl-wheel scroll a page, it always
does two pages at a time.

Version-Release number of selected component (if applicable):
XFree86-4.3.0-2

How reproducible:
Always.

Steps to Reproduce:
1.  Run xev.
2.  Move mouse over the xev window, use the wheel to scroll up/down.
    
Actual results:
Two pairs of ButtonPress/ButtonRelease events are occurring for each single scroll.

Expected results:
Only a single pair of button press/release events should happen.

Additional info:
I've tried two USB mice, both standard Dell-issued intellimice.  They have
worked fine on other Dell Red Hat 9 machines.

Comment 1 Mike A. Harris 2003-10-08 23:06:50 UTC
Attach your X server log file, config file, and /var/log/messages file
as uncompressed file attachments using the link below.

Comment 2 Raul Acevedo 2003-10-08 23:30:47 UTC
After looking through some other bugs for RH9/XFree86, I diffed the XF86Config
between this box (with the problem) and another identically configured Dell
machine, and the problem came down to this one difference in the ServerLayout
section:

	InputDevice    "DevInputMice" "AlwaysCore"

If I remove that line, the mouse wheel works correctly.  Based on the comments
in bug #89061, either redhat-config-xfree86 should keep that line out of
XF86Config unless it really needs to be there (e.g. laptops with two mouse
devices), or it's a XFree86 driver bug.

Comment 3 Raul Acevedo 2003-10-08 23:36:07 UTC
Ok, so I tried removing my XF86Config, and running redhat-config-xfree86, and
the resulting XF86Config file didn't have the AlwaysCore option (nor a
SendCoreEvents).  So I'm not sure how it got there in the first place...

Does redhat-config-mouse change XF86Config?  Between this problem and another
one in GNOME that turned out to be nothing, I ran redhat-config-mouse quite a
bit before finalizing on the current, working setting.

Comment 4 Mike A. Harris 2003-10-08 23:44:11 UTC
Not sure, I'm not involved in config tool development. I've Cc'd Brent however
for comment.

Comment 5 Brent Fox 2004-03-10 18:07:25 UTC
Yes, redhat-config-mouse does change XF86Config.  With the 2.6 kernel,
all mice will use the same kernel device (/dev/input/mice), so mouse
configuration becomes a non-issue.  In fact, redhat-config-mouse has
been taken out of the latest Rawhide trees because it isn't needed any
more.


Note You need to log in before you can comment on or make changes to this bug.