Bug 1065882 - [delta] delta rpm download size statistics
Summary: [delta] delta rpm download size statistics
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
low
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 1069785 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 08:17 UTC by Parag Nemade
Modified: 2014-09-30 23:42 UTC (History)
6 users (show)

Fixed In Version: dnf-plugins-core-0.0.8-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-31 23:57:54 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Parag Nemade 2014-02-17 08:17:35 UTC
Description of problem:

Thank you for implementing delta support for dnf. I see that yum used to always give statistics like this
======================================================================
Downloading packages:
updates/20/x86_64/prestodelta                                                                                                                            | 1.5 MB  00:00:02     
Delta RPMs reduced 249 M of updates to 25 M (89% saved)
======================================================================

So this log gives me quick information like how much bandwidth is saved in rpm downloading. The same is not shown by dnf currently. Hence filing a bug for that.

Version-Release number of selected component (if applicable):
dnf-0.4.14-1.fc20.noarch
dnf-plugins-core-0.0.3-1.fc20.noarch


How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:
dnf when enabled deltarpm support is not showing how much bandwidth is saved in rpm downloading.

Expected results:
dnf when enabled deltarpm support should give how much bandwidth is saved in rpm downloading.

Additional info:

Comment 1 Ales Kozumplik 2014-02-17 10:25:22 UTC
While certainly useful, there is nobody to look at this at the moment and it's not pressing AFAIK. Keeping this open on low priority.

Comment 2 Ales Kozumplik 2014-02-17 10:25:48 UTC
Also--would be convenient time to do together with some DRPM processing cleanup.

Comment 3 Andre Robatino 2014-02-26 01:07:19 UTC
*** Bug 1069785 has been marked as a duplicate of this bug. ***

Comment 4 Ales Kozumplik 2014-05-01 20:09:07 UTC
Implemented upstream by 362e93f.

Comment 5 Fedora Update System 2014-05-02 08:33:10 UTC
dnf-0.5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.1-1.fc20

Comment 6 Fedora Update System 2014-05-02 21:05:40 UTC
Package dnf-0.5.1-1.fc20, hawkey-0.4.14-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.5.1-1.fc20 hawkey-0.4.14-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5937/hawkey-0.4.14-1.fc20,dnf-0.5.1-1.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-05-28 12:09:25 UTC
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20

Comment 8 Fedora Update System 2014-05-28 23:49:21 UTC
Package dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.0.8-2.fc20 libsolv-0.6.1-1.git6d968f1.fc20 hawkey-0.4.16-1.fc20 dnf-0.5.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6789/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-05-31 23:57:54 UTC
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.