Bug 1066 - Upgrade should not install obsoleted packages.
Upgrade should not install obsoleted packages.
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-02-07 21:58 EST by Aleksey Nogin
Modified: 2015-01-07 18:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-19 19:10:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 1999-02-07 21:58:31 EST
When I upgraded RH 5.1 to RH 5.2, upgrader installed both
squid and squid-novm packages without paying any attention
to the fact that I already have squid-rhcn that obsoletes
both squid and squid-novm. Upgrade should not install
obsoleted packages or, at least, do not install the packages
when an -rhcn package of equal or newer version exists.
Comment 1 Aleksey Nogin 1999-03-12 13:49:59 EST
I do not understand why this bug report was so silently discarded.
Installing obsoleted packages is a big problem for RHCN - RHCN
maintainer of "something-rhcn" can not prevent RedHat upgrader from
installing an old version of "something" thus screwing up the user's
setup.
Comment 2 Bill Nottingham 1999-03-12 15:30:59 EST
The problem is that you need to be able to install obsoleted
packages, as that was one method used to have multiple
packages with the same purpose. What you at least need
is a 'Conflicts' header in the squid-rhcn package that
conflicts with the official package.
Comment 3 Aleksey Nogin 1999-03-12 15:34:59 EST
I agree. But I am not talking about installing packages "by hands", I
talk about RedHat installer installing obsoleted packages during, say,
5.1 -> 5.2 upgrade _without giving me any chance to privent that_.
Comment 4 Aleksey Nogin 1999-03-12 15:35:59 EST
I agree. But I am not talking about installing packages "by hands", I
talk about RedHat installer installing obsoleted packages during, say,
5.1 -> 5.2 upgrade _without giving me any chance to prevent that_.
Comment 5 Matt Wilson 1999-03-13 17:08:59 EST
You should be able to go into individual package selection and turn
off packages you don't want upgraded.  We simply must install packages
that obsoletes installed packages during upgrade so that an upgraded
system has the functionality that the old package had.  An example is
kbd and console-tools.  Console-tools is superior, kdb is old.  A
upgraded system needs to have console-tools on it, because this is now
the supported package.  If an upgrade is blowing away rhcn packages,
there is something wrong with the versioning.
Comment 6 Aleksey Nogin 1999-03-13 17:25:59 EST
I am afraid you misunderstood me here.
1) In RH 5.2 there was no way to prevent it from installing squid
_and_ squid-novm packages - as I understand it, they were in the list
of the base packages that are always installed
2) I am not talking about installing/not installing the packages that
obsolete the installed package - obviously those have to be installed.
I am talking about not installing packages that are _obsoleted by_ the
installed package.
Comment 7 Preston Brown 1999-03-29 14:38:59 EST
There may be circumstances where a package obsoletes another one, but
then a later version of the package that was obsoleted comes along at
some time in the future and it does need to be installed, even though
there is currently a package installed on the system which claims to
have obsoleted it.  So we are going to have to retain the ability to
install a package over the top of another package which obsoletes it.
Comment 8 Aleksey Nogin 1999-11-07 18:37:59 EST
Such situation may be resolved by either
1) Use versions in the "Obsoletes" tag,
2) Suppose, the official RH has package A and the system being
upgraded has B. If B obsoletes A _and_ A obsoletes B, than go ahead
and install A. But if B obsoletes A and A does not know about B, than
_at least ask_ if the user really wants to have A installed. At least
in the expert mode...
Comment 9 Jay Turner 2000-02-08 07:03:59 EST
Bug has been moved to list of feature requests for future releases.
Comment 10 Michael Fulbright 2000-09-19 19:10:52 EDT
Please reopen this bug if it continues to be a problem with current releases.

Note You need to log in before you can comment on or make changes to this bug.