Bug 106602 - LTC4825-dasd_diag device not recognized
Summary: LTC4825-dasd_diag device not recognized
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: s390 Linux
medium
medium
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-08 19:55 UTC by Duane Beyer
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 19:01:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Duane Beyer 2003-10-08 19:55:45 UTC
The following has be reported by IBM LTC:  
dasd_diag device not recognized
Hardware Environment: z990

Software Environment: RHEL 3 RC1

Steps to Reproduce:
1. VM format device
2. issue reserve command against device
3. added dasd_diag_mod to /sbin/mkinitrd before dasd_fba_mod
4. issue mkinitrd and zipl
5. reboot
6. lsmod shows dasd_diag_mod loaded
7. issue echo add device range=4730 > /proc/dasd/devices
                    
Actual Results: cat /proc/dasd/devices shows 4730 (ECKD)
Console message: end_request: I/O error, dev 5e:14 (dasd), sector 0 
unable to read partition table                    

Expected Results: should show (DIAG)

Additional Information:

Comment 1 Pete Zaitcev 2003-10-08 20:56:01 UTC
Forget it, seriously. For some reason Martin Schwindefsky thinks
it is unsafe to enable disk diagnostics on s390x. It is the same
way in 2.6. So, one part of IBM thinks it cannot be done, another
part of IBM thinks it should be done. I don't want to meddle into it.
NOTABUG.


Comment 2 Pete Zaitcev 2003-10-08 20:56:50 UTC

*** This bug has been marked as a duplicate of 105023 ***

Comment 3 Frank LeFevre 2003-10-13 18:06:43 UTC
Hi, I've read the duplicate record (105023) and that discusses s390x (64bit) 
but says it should work on s390 (31bit). My attempts detailed above were made 
on a s390 (31bit) image. This disk can be used as vdisk space for increased 
performance. Thanks.

Comment 4 Pete Zaitcev 2003-10-14 01:56:24 UTC
I'm on vacation until 10/23, so I am reopening and reassigning
to keep this on radar.


Comment 6 Frank LeFevre 2003-10-16 18:45:06 UTC
No need to keep it open Pete. The device was not getting properly attached to 
the image. Sorry, our error. Works fine on 31bit. Please close.


Note You need to log in before you can comment on or make changes to this bug.