Bug 1066078 - Unable to lock Gnome when using KDM instead of GDM
Unable to lock Gnome when using KDM instead of GDM
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity high
: rc
: 7.0
Assigned To: Florian Müllner
Desktop QE
: Regression, Reopened
: 1058286 (view as bug list)
Depends On: 1070140 1070361
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-17 11:06 EST by Martin
Modified: 2015-05-18 09:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-05 05:22:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
briang: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Martin 2014-02-17 11:06:53 EST
Description of problem:
Unable to lock when using KDM instead of GDM

Version-Release number of selected component (if applicable):
gnome-shell-3.8.4-22.el7.x86_64

How reproducible:
always

Steps to Reproduce:
Try: Ctrl+L or Super+L

Actual results:
nothing happens, no lockscreen

Expected results:
locked screen

Additional info:
Regression, this works in RHEL 6.x
Comment 1 Matthias Clasen 2014-02-17 12:07:23 EST
I consider kdm/gnome a non-supported configuration
Comment 2 RHEL Product and Program Management 2014-02-17 15:07:09 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.
Comment 3 Martin 2014-02-19 05:02:11 EST
I'd like to see opinion from Product Management, they could see this problem from bigger picture.

This is clearly integration issue and regression since RHEL 6.x and also from previous Gnome 3.x releases.

From user point of view and quality assurance, I'd like to see polished user experience and I don't see any reason for breaking previously working functionality/combination/workflow.
Comment 4 Matthias Clasen 2014-02-19 20:43:43 EST
I'd rather question why kdm is included in the release. That came as a surprise to me at some point - it was certainly not in the desktop team plans for RHEL7 to support multiple display managers, and feature development has been done under the assumption that gdm would be the display manager.
Comment 5 Lukáš Tinkl 2014-02-20 08:48:56 EST
I'm a bit surprised as well... kdm probably shouldn't be included in RHEL at all, it's basically dead upstream with several candidates to eventually replace it in the near future (sddm, lightdm)
Comment 6 Lukáš Tinkl 2014-02-20 08:56:05 EST
And for the record, the whole KDE stack is fully ported to use the systemd/logind services, so running the KDE session under gdm should pose no problems at all.
Comment 7 Martin 2014-02-20 09:01:25 EST
(In reply to Lukáš Tinkl from comment #6)
> And for the record, the whole KDE stack is fully ported to use the
> systemd/logind services, so running the KDE session under gdm should pose no
> problems at all.

This is integration problem in Gnome session when using KDM as login manager.
Comment 10 Lukáš Tinkl 2014-02-20 10:09:17 EST
(In reply to Martin Holec from comment #7)
> (In reply to Lukáš Tinkl from comment #6)
> > And for the record, the whole KDE stack is fully ported to use the
> > systemd/logind services, so running the KDE session under gdm should pose no
> > problems at all.
> 
> This is integration problem in Gnome session when using KDM as login manager.

I know, I'm merely pointing out that getting rid of kdm should be no problem at all if we decide so
Comment 11 Matthias Clasen 2014-02-20 13:22:15 EST
*** Bug 1058286 has been marked as a duplicate of this bug. ***
Comment 12 Martin 2014-03-05 05:22:40 EST
KDM has been removed from RHEL7, this bug no longer matters.
Comment 13 Brian Gollaher 2015-05-18 09:19:33 EDT
Closed.

Note You need to log in before you can comment on or make changes to this bug.