Bug 106622 - (NET R8169) MTU size can't change larger than 1500 with ifconfig command
Summary: (NET R8169) MTU size can't change larger than 1500 with ifconfig command
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 3.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-08 21:21 UTC by Toshiyuki Shindo
Modified: 2013-07-03 02:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 19:34:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Toshiyuki Shindo 2003-10-08 21:21:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; T312461; YComp 
5.0.2.6)

Description of problem:
When I used ifconfig command to change MTU size for eth0, I can't change the 
value larger than 1500.

Version-Release number of selected component (if applicable):
RHEL3-RC1 AS

How reproducible:
Always

Steps to Reproduce:
1.type 'ifconfig eth0 mtu 9000
2.
3.
    

Actual Results:  It gives you a message :
SIOCSIFMTU: Invalid argument

Expected Results:  You can change the value of MTU size

Additional info:

Comment 1 Jeff Garzik 2004-01-12 19:48:14 UTC
You need to give a lot more information, such as

* kernel version
* NIC hardware description
* 'lspci' output
* 'dmesg' output

It may be that your hardware doesn't support jumbo MTUs.


Comment 2 bobby 2004-05-05 20:32:07 UTC
Bug: Redhat ifconfig does not allow you to forcefully set the MTU >
1500.  The reason this is bad is that if you have a gigabit ethernet
card on a gig-network you should be able to set it higher for better
throughput.

I am using a gigbit NIC from hawking.  Using drivers r8169.  I saw
some things in the driver source file about giga ethernet but it
wasn't clear and anyway the variable was set to 1536 which doesn't
work either.

Kernel is: 2.4.18-19.7.x


Comment 3 Jeff Garzik 2004-06-14 17:21:50 UTC
I think this would be fixed by updating r8169 driver to latest 2.4.x-BK.


Comment 4 RHEL Product and Program Management 2007-10-19 19:34:11 UTC
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.


Note You need to log in before you can comment on or make changes to this bug.