Bug 106629 - kbd focus should be removed from submit on tests
kbd focus should be removed from submit on tests
Status: CLOSED CURRENTRELEASE
Product: Red Hat Academy
Classification: Retired
Component: Web Application (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Luke Meyer
Bowe Strickland
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-08 18:27 EDT by Bowe Strickland
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-13 15:17:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bowe Strickland 2003-10-08 18:27:45 EDT
Description of problem:
student can accidently hit enter key, and test gets submitted.  

perhaps we even need a second page... 
are you really ready to finish test?
by the way, you havne't answered questions 2 or 8 yet...
Comment 1 Luke Meyer 2003-10-09 09:37:57 EDT
in my browser, at least, no matter where your focus is the return key submits
the test.  the "are you sure" page would probably be the only reasonable
solution to the problem.  not sure whether a javascript popup might even be a
good way to handle this...
Comment 2 Luke Meyer 2003-10-13 11:47:18 EDT
now, for lessons or tests, if you submit the whole page (either via return or
the button at the bottom) there is a javascript check that you answered all
questions, and if not, an option to cancel the submission (and go to the first
missing question).  this specifically should not happen if the user submits and
individual question.

since this is javascript, YMMV per browser, but the worst that is likely to
happen is that the check doesn't work and the user is no worse off than before
(the kind of javascript i like).  if something goes wrong and actually somehow
probihits them from submitting, they can turn off javascript.

this development is currently on webtest.

Note You need to log in before you can comment on or make changes to this bug.