Bug 1066375 - libvirt should provide error msg if both --tunnelled and --listen-address are specified
Summary: libvirt should provide error msg if both --tunnelled and --listen-address are...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jiri Denemark
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 10:04 UTC by zhe peng
Modified: 2015-11-19 05:44 UTC (History)
4 users (show)

Fixed In Version: libvirt-1.2.16-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-19 05:44:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2202 0 normal SHIPPED_LIVE libvirt bug fix and enhancement update 2015-11-19 08:17:58 UTC

Description zhe peng 2014-02-18 10:04:16 UTC
Description of problem:
libvirt should provide error msg if both --tunnelled and --listen-address are specified

Version-Release number of selected component (if applicable):
libvirt-1.1.1-23.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Start a guest for migration.
2. Do a peer-to-peer migration with tunnelled:
# virsh migrate --live --p2p --tunnelled --listen-address 1.2.3.1 rhel7 qemu+ssh://$dst_IP/system --verbose
Migration: [100 %]

Actual results:


Expected results:
libvirt should provide error msg because listen address makes no sense for 'tunnelled' migration.

Additional info:

Comment 2 dyuan 2014-02-19 03:34:57 UTC
Update the flag to 7.1.0 since it's not a regression or blocker.

Comment 3 dyuan 2014-02-25 03:21:03 UTC
Record another issue of error msg for --tunnelled.

migrate with --tunnelled and migrateuri together:
migrate: Unexpected migrateuri for **peer2peer**/direct migration

The error msg should be updated to "Unexpected migrateuri for **tunnelled**/direct migration."

refer to : https://www.redhat.com/archives/libvir-list/2013-May/msg01938.html

Comment 7 Jiri Denemark 2015-05-04 12:11:00 UTC
Patches sent upstream for review: https://www.redhat.com/archives/libvir-list/2015-May/msg00029.html

Comment 8 Jiri Denemark 2015-05-04 13:11:18 UTC
Fixed upstream by v1.2.15-18-gb45ec56..v1.2.15-19-g05cda3d:

commit b45ec56f582742596a01ad1107c21d48d7172e7d
Author: Jiri Denemark <jdenemar@redhat.com>
Date:   Thu Apr 30 15:56:07 2015 +0200

    qemu: Forbid unsupported parameters for tunnelled migration
    
    Neither migrate URI nor lister address make any sense for tunnelled
    migration.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1066375
    https://bugzilla.redhat.com/show_bug.cgi?id=1073233
    
    Signed-off-by: Jiri Denemark <jdenemar@redhat.com>

commit 05cda3d3a42dacf18b48dd3efceef2010270855f
Author: Jiri Denemark <jdenemar@redhat.com>
Date:   Thu Apr 30 14:47:46 2015 +0200

    virsh: Don't check migrate parameters
    
    Just pass anything a user specified to the appropriate API. It's the API
    or libvirtd that should be responsible for checking its parameters.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1066375
    https://bugzilla.redhat.com/show_bug.cgi?id=1073233
    
    Signed-off-by: Jiri Denemark <jdenemar@redhat.com>

Comment 10 zhe peng 2015-07-21 08:43:27 UTC
verify with build:
libvirt-1.2.17-2.el7.x86_64

step:
1:prapare migration env. , start a guest
2:do migration
# virsh migrate --live --p2p --tunnelled --listen-address 1.2.3.1 rhel6 qemu+ssh://$target_ip/system --verbose
error: argument unsupported: listen address is not supported by tunnelled migration

# virsh migrate --live --p2p --tunnelled --migrateuri $target_uri rhel6 qemu+ssh://$target_ip/system --verbose
error: argument unsupported: migration URI is not supported by tunnelled migration

the error msg are correct, move to verified.

Comment 12 errata-xmlrpc 2015-11-19 05:44:36 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2202.html


Note You need to log in before you can comment on or make changes to this bug.