Bug 106652 - Weather applet doesn't resize itself with the panel
Weather applet doesn't resize itself with the panel
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-09 00:12 EDT by Mike Chambers
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-07 19:13:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike Chambers 2003-10-09 00:12:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031003

Description of problem:
When you resize your gnome-panel, the weather-applet doesn't resize with it.  It
stays the same size, therefore the numbers/degrees are below the bottom of the
panel and unreadable.

Version-Release number of selected component (if applicable):
gnome-panel-2.4.0-1 gnome-applets-2.4.1-1

How reproducible:
Always

Steps to Reproduce:
1.Add the Weather Report applet to the gnome panel
2.Increase and decrease the panel size
3.
    

Actual Results:  Panel resizes, but the applet doesn't.

Expected Results:  The applet should resize along with the panel, so the whole
icon/text is still completely on the panel.

Additional info:
Comment 1 Mike Chambers 2003-10-15 08:35:30 EDT
ping...

This bug still exists in FC Test 3.  Any news/comments/ideas on this bug? 
Obviously it's probably low priority but it is a pain to read.
Comment 2 Elton Woo 2003-10-30 11:16:40 EST
I can confirm that the applet does not resize, regardless whether one increases
or decreases the size of the panel.
Comment 3 Mike Chambers 2003-12-26 08:46:06 EST
With FC1, this bug still exists.  The only thing that it does is once
you get to a certain panel size, the temp number goes to the side or
below the weather graphic (sun or clouds, whatever), depending on if
you increase or decrease the panel size.
Comment 4 Tielman de Villiers 2004-01-15 17:04:14 EST
What about an option, like in Redhat 9, where the text is next to the
icon?
Comment 5 Bart Martens 2004-02-14 05:12:05 EST
gnome-panel-2.4.0-3
gnome-applets-2.4.1-1
resolution 1600x1200

The problem of comment #1 occurs when setting the size of the
gnome-panel to a number of pixels between 25 and 32 inclusive. When
the number of pixels is decreased to 24, the behaviour of comment #3
is performed.

My opinion... The solution of comment #4 is a nice-to-have, but it
doesn't remove the faulty behaviour. What is wrong, is that the
behaviour of comment #3 occurs when the *top* of the text reaches the
panel bottom. Obviously, the behaviour of comment #3 should occur when
the *bottom* of the text reaches the bottom of the panel, so that the
text is visible at all panel sizes.
Comment 6 Gregory Gulik 2004-04-01 10:57:38 EST
One related problem I didn't see described is that when the panel is
the default size (48) the weather applet puts the temperature next to
the icon instead of below even though there is plenty of space. 
Putting the temperature below was the default behavior in FC1 and RH9.

However, if you resize the panel at all the temperature then
immediately drops below the weather icon as it should have been in the
first place. 

It does return to the default incorrect behavior after logging out and
back in.
Comment 7 Mike Chambers 2004-05-19 08:11:54 EDT
This problem seems to be fixed, as the sun/clouds/whatever are beside
the number now no matter the size, instead of under.  The only thing I
saw was when increasing the panel size to a number real high, the
icon/applet goes with it to the top and doesn't stay but that's no
biggie.  Who uses a panel that big anyway? LOL

Anyway, going to close this if no one else has any problems?

Note You need to log in before you can comment on or make changes to this bug.