Bug 1066617 - Template is created with no default value for migration downtime
Summary: Template is created with no default value for migration downtime
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: gustavo.pedrosa
QA Contact: bugs@ovirt.org
URL:
Whiteboard: virt
: 1072846 1074253 1075186 (view as bug list)
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-02-18 17:44 UTC by Leonardo Bianconi
Modified: 2014-03-31 12:31 UTC (History)
21 users (show)

Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:31:23 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 24709 0 None MERGED webadmin: [Fix] Template without migration downtime Never
oVirt gerrit 25558 0 None MERGED webadmin: [Fix] Template without migration downtime Never

Description Leonardo Bianconi 2014-02-18 17:44:30 UTC
Description of problem:
Editing a template requires new data for "Use custom migration downtime"

Version-Release number of selected component (if applicable):
3.4

How reproducible:
100%

Steps to Reproduce:
1. Create a Template
2. Edit the Template
3. Click OK so save (there weren't modifications)

Actual results:
The screen does not close, it requires data for "Use custom migration downtime"

Expected results:
Two possibilities: 
1. Field be optional:
Screen closes and save data.

2. The field "Use custom migration downtime" filled with default value when opening it:
Screen closes and save data.

Additional info:

Comment 1 Itamar Heim 2014-02-23 08:28:25 UTC
Setting target release to current version for consideration and review. please
do not push non-RFE bugs to an undefined target release to make sure bugs are
reviewed for relevancy, fix, closure, etc.

Comment 2 Sandro Bonazzola 2014-03-04 09:29:00 UTC
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.

Comment 3 Michal Skrivanek 2014-03-05 09:13:29 UTC
where's a fix in master branch?

Comment 4 gustavo.pedrosa 2014-03-05 16:32:17 UTC
@Michal, we verified the branch master, but this bug only exist in the branch 3.4

Comment 5 Michal Skrivanek 2014-03-06 07:11:19 UTC
As far as I can tell it is missing in master. How did you verify? That specific piece of code is missing and there are no real differences between master and 3.4 yet...

Comment 6 gustavo.pedrosa 2014-03-06 12:04:58 UTC
@Michal, in this two changes:

http://gerrit.ovirt.org/23613 (branch: ovirt-engine-3.4)
http://gerrit.ovirt.org/23328 (branch: master)

The file TemplateVmModelBehavior.java has different modifications:

http://gerrit.ovirt.org/#/c/23613/9/frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/TemplateVmModelBehavior.java (ovirt-engine-3.4)
http://gerrit.ovirt.org/#/c/23328/20/frontend/webadmin/modules/uicommonweb/src/main/java/org/ovirt/engine/ui/uicommonweb/models/vms/TemplateVmModelBehavior.java (master)

The first one (ovirt-engine-3.4) remove the line #173:

getModel().setSelectedMigrationDowntime(this.template.getMigrationDowntime());

And the other (master) keep the line #173.

Comment 7 Michal Skrivanek 2014-03-06 12:09:51 UTC
ah, so it's an incorrect backport of template versions. Omer, please doublecheck

Comment 8 Omer Frenkel 2014-03-06 14:42:00 UTC
right, thanks! i also verified this fix works

Comment 9 Omer Frenkel 2014-03-09 09:35:04 UTC
*** Bug 1072846 has been marked as a duplicate of this bug. ***

Comment 10 Michal Skrivanek 2014-03-10 09:50:54 UTC
this is a basic functionality we need to get working in 3.4 GA

Comment 11 Omer Frenkel 2014-03-12 09:38:42 UTC
*** Bug 1075186 has been marked as a duplicate of this bug. ***

Comment 12 Ilanit Stein 2014-03-13 14:05:40 UTC
*** Bug 1074253 has been marked as a duplicate of this bug. ***

Comment 13 Pavel Novotny 2014-03-19 17:50:48 UTC
I can confirm this issue is resolved in downstream RHEVM av3 (rhevm-3.4.0-0.5.master.el6ev). Verified by automation and also manually.

Comment 14 Sandro Bonazzola 2014-03-31 12:31:23 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.