Bug 106680 - Activation of a pushbutton in a popup menu using only button 3 is not possible.
Activation of a pushbutton in a popup menu using only button 3 is not possible.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-09 10:47 EDT by Frode Tennebø
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-20 14:40:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Frode Tennebø 2003-10-09 10:47:50 EDT
Description of problem:
If I run my Sparc Solaris application (Motif 2.1) with the display set to my RH9 
box (running any WM) I am not able to access the popup menues. I have to hold 
down button 3 (the popup menu appears), move to the desired pushbutton and press 
button 1 to get the desired effect. On Solaris I can just push button 3, move 
and release button 3 to XmNactivateCallback.

Version-Release number of selected component (if applicable):
[root@garvin root]# rpm -q openmotif
openmotif-2.2.2-14

How reproducible:
Always.

Steps to Reproduce:
1. Start Netscape 4.x on a solaris machine with display directed to the RH9 box.
2. Load a page.
3. Press button 3 inside the rendered page.
4. Select "View Page Info" (or whatever)
5. Release button 3.
    
Actual results:
Nothing.

Expected results:
"Page Info" window should pop up.

Additional info:
This actually does not happen when I run Netscape from a RH7.3 machine and 
remote display to the same RH9 machine as above. Running Netscape (or my own 
application) remotely on a Sun box and remote display on a Sun box gives correct 
result.

This could very well be related to something entirely different than Motif on 
the server (since it is basically a client library), but I'm not entirely sure 
that I understand the X11 protocol and I had to put it somewhere.
Comment 1 Thomas Woerner 2004-01-15 09:54:21 EST
This is no openmotif bug. 
Comment 2 Frode Tennebø 2004-01-15 18:22:40 EST
At the time it appeard to be. However, further investigation has led 
me to believe there is a incompatability between XFree86 and X11R6. I 
haven't been able to trace yet, but reopening it might help others 
and remind me that it's still there when I get the time to do it 
myself.
Comment 3 Mike A. Harris 2004-04-20 14:40:05 EDT
What is described in the bug report is just an application problem
and some guesses as to what is at fault.  If you believe this is
an XFree86 bug, please file it in XFree86.org's bugzilla at
http://bugs.xfree86.org with indications of what the bug is, and
then paste the upstream bug URL here and we will review the upstream
bug report resolution.

I see nothing in this report indicating this is an XFree86 bug at
this point, just a tech support problem.

Closing as "NOTABUG"

Note You need to log in before you can comment on or make changes to this bug.