Bug 106684 - getgrnam fails with invalid group and long group line
getgrnam fails with invalid group and long group line
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: glibc (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-09 12:04 EDT by Seth Lepzelter
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version: 2.3.2-90
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-17 14:14:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
simple test code (126 bytes, text/plain)
2003-10-09 12:07 EDT, Seth Lepzelter
no flags Details
group file that causes the problem (1.19 KB, text/plain)
2003-10-09 12:08 EDT, Seth Lepzelter
no flags Details

  None (edit)
Description Seth Lepzelter 2003-10-09 12:04:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.2)
Gecko/20021120 Netscape/7.01

Description of problem:
getgrnam goes into an infinite loop (reading /etc/group over and over) when
(symptom was tar, but a simple test program fails as well).

Version-Release number of selected component (if applicable):
glibc-2.3.2-74

How reproducible:
Always

Steps to Reproduce:
1. look up a non-existant group
2. use the attached group file

Actual Results:  calls to getgrnam never return, read /etc/group indefinitely

Expected Results:  should return NULL

Additional info:
Comment 1 Seth Lepzelter 2003-10-09 12:07:55 EDT
Created attachment 95075 [details]
simple test code
Comment 2 Seth Lepzelter 2003-10-09 12:08:53 EDT
Created attachment 95076 [details]
group file that causes the problem
Comment 3 Seth Lepzelter 2003-10-17 13:38:17 EDT
This appears to be fixed in the 2.3.2-90 release of glibc.
Comment 4 Jakub Jelinek 2003-10-17 14:14:13 EDT
I was wondering why I cannot reproduce it...

Note You need to log in before you can comment on or make changes to this bug.