Bug 10669 - nfs startup problems in 6.2
Summary: nfs startup problems in 6.2
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nfs-utils (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Steve Dickson
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-04-08 21:51 UTC by henny.thomassen
Modified: 2007-04-18 16:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-20 11:30:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description henny.thomassen 2000-04-08 21:51:31 UTC
After upgrading several systems I'm in charge of from version 5.2 to
version 6.2 I failed to mount disks that were exported from the upgraded
systems. The error message I got on the system trying to mount the disk was
similar to:

   mount: RPC: protocol not supported

(I can't reproduce the error now without disabling nfs on the systems,
which I prefer not to do. Please let me know if you want the exact error).

I searched the net for a solution and it turned out that it has to do with
the fact that portmapper hasn't been initialized properly to deal with nfs
mounts as can be seen by the command 'rcpinfo -p' which didn't list either
nfs or mountd.

I was able to workaround the problem by adding the following line to
/etc/rc.d/rc.local:

cd /etc/rc.d/init.d ; for foo in stop start ; do ./portmap $foo ; ./nfs
$foo ; done

But this should be done by default in runlevel 3.

Please let me know if you need more info.

Comment 1 Seth Vidal 2000-07-15 05:08:11 UTC
portmap and nfs really shouldn't be on by default in ANY runlevel.

Check out the /sbin/chkconfig command and that will let you turn on portmap and
nfs by default.



Comment 2 Cristian Gafton 2000-08-09 02:34:52 UTC
assigned to johnsonm

Comment 3 Steve Dickson 2002-12-20 11:30:32 UTC
Unable to reproduce in current release


Note You need to log in before you can comment on or make changes to this bug.