Bug 106698 - Linux System crashed with kernel BUG at slab.c:1943!
Linux System crashed with kernel BUG at slab.c:1943!
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
s390x Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-09 14:09 EDT by Need Real Name
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 18:43:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-10-09 14:09:33 EDT
Description of problem:  Linux guest running RH EL 3 Beta 1 crashed with kernel 
BUG at slab.c:1943!

                                                                              
Red Hat Enterprise Linux release 2.9.5AS (Taroon)                             
Kernel 2.4.21-1.1931.2.349.2.2.ent on an s390x                                
                                                                              
linuxsjj login:                                                               
kernel BUG at slab.c:1943!                                                    
illegal operation: 0001                                                       
CPU:    0    Not tainted                                                      
autofs ctc fsm af_packet ext3 jbd dasd_fba_mod dasd_eckd_mod dasd_mod         
Process more (pid: 889, task: 00000000031f0000, ksp: 00000000031f3ac8, f: 0)  
Krnl PSW : 0400000180000000 0000000000067732                                  
           kmem_cache_reap [kernel] 0x562 (2.4.21-1.1931.2.349.2.2.ent)       
Krnl GPRS: 0000000000000001 00000000031f3ab0 000000000000001b 0000000000000073
           0000000000067730 0000000000395150 0000000000000000 0000000000000000
           00000000000006f2 000000000000682e 00000000000009a8 0000000000a57b20
           0000000000906000 00000000001b27e8 0000000000067730 00000000031f3c58
Krnl ACRS: 00000100 00184920 00000000 00000000                                
           00000001 00000000 00000000 00000000                                
           00000000 00000000 00000000 00000000                                
           00000000 00000000 00000000 00000000                                
Krnl Code: 00 00 58 50 b0 38 e3 c0 c0 00 00 04 b9 16 00 15 b9 08 00 91        
[<00000000000a53fa>] seq_read [kernel] 0x326 (0x31f3da0)                      
[<000000000007c18a>] sys_read [kernel] 0xd2 (0x31f3e50)                       
                                                                              
[<0000000000015722>] sysc_noemu [kernel] 0x10 (0x31f3ef0)                     



Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux release 2.9.5AS (Taroon)  
Kernel 2.4.21-1.1931.2.349.2.2.ent on an s390x     


How reproducible:

I bought up LINUXSJJ earlier and was doing various things.  I issued a 'man 
grep' command and I just hung up (there were no messages on the VM console). I 
closed the 
putty session and reopened it, but was unable to reacquire a connection 
(network issue maybe?)
 
When this happened I rebooted the linux system (IPL 200 CLEAR) and issued some 
more commands.  Below is the last things I did before I hung again.  (Note the 
Segementation fault).  I then switched to the VM console and saw those messages.
 
root@linuxsjj proc]# slabinfo
-bash: slabinfo: command not found
[root@linuxsjj proc]# more slabinfo
Segmentation fault
[root@linuxsjj proc]# ;s
-bash: syntax error near unexpected token `;'
[root@linuxsjj proc]# ls
1   370  734  770  bus         cpuinfo  driver       ioports    ksyms    misc
10  4    743  772  chandev     crypto   execdomains  irq        loadavg  modules
2   5    747  8    chpids      dasd     filesystems  irq_count  locks    mounts
23  6    756  892  cio_ignore  devices  fs           kcore      mdstat   net
3   7    769  9    cmdline     dma      iomem        kmsg       meminfo  partiti
[root@linuxsjj proc]# more slabinfo


Steps to Reproduce:
1.
2.
3.
    
Actual results:


Expected results:


Additional info:
Comment 1 Bill Nottingham 2003-10-09 14:25:37 EDT
Please try a more recent kernel, available via RHN.
Comment 2 Pete Zaitcev 2003-10-12 22:22:07 EDT
I do not remember how to access the "Sushi" RHN channel precisely,
but the TAM should know (for BoA it's Frank).
Comment 3 Need Real Name 2003-10-15 11:56:13 EDT
The reporter will try replicating the problem on Beta 2 if time permits.

Thank you 
Comment 4 Pete Zaitcev 2003-12-22 16:55:05 EST
Emil, this is a very disturbing report, although you are the only
one who reports this. What is the status? Does it reoccur?
If yes, was the traceback the same?

Also, add "-c 8" to the KLOGD_OPTIONS in /etc/sysconfig/syslog.
This will print more to the console. I suspect something may
be missing.

The trust of this investigation currently is the implication of
seq_file. Running "cat /etc/termcap| strace -o xxx more" shows
no access to /proc whatsoever, so I do not see how seq_file
can even be involved. This is suggestive. Also, man by default
uses less(1), not more(1). Ergo: the error was not caused by
"man grep", but instead by someone else who did
"more /proc/something".

We need Emil to identify what /proc file triggers the fault.
Indiscriminate more in /proc is definitely unsupported, but
I am willing to look into this case specifically if it can
be reproduced with something reasonable, like /proc/PID/maps,
or if a regular user can trip it.
Comment 5 Pete Zaitcev 2003-12-22 16:57:02 EST
Oh wait, disregard that comment (except that "more grep" wasn't
at fault indeed). Emil wrote that it's /proc/slabinfo.

This happens if a module was removed. Which module?
Comment 6 Ernie Petrides 2005-10-03 18:43:37 EDT
Closing due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.